155387f0b7c5b89d9eab87c4e708540fd2040a9a
[profile/ivi/bundle.git] / packaging / bundle.spec
1 Name:       bundle
2 Summary:    String key-val dictionary ADT
3 Version:    0.1.16
4 Release:    1.1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    bundle-%{version}.tar.bz2
8 Patch0:     fix-build-failure-include-glib.h.patch
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(dlog)
14
15
16 %description
17 Simple string key-val dictionary ADT
18
19
20
21 %package devel
22 Summary:    String key-val dictionary ADT (devel)
23 Group:      Development/Libraries
24 Requires:   %{name} = %{version}-%{release}
25
26 %description devel
27 Simple string key-val dictionary ADT (devel)
28
29
30 %prep
31 %setup -q -n %{name}-%{version}
32 %patch0 -p1
33
34
35 %build
36 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
37
38
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43 %make_install
44
45
46
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52
53
54
55
56 %files
57 %{_libdir}/libbundle.so.*
58
59
60 %files devel
61 %{_includedir}/bundle.h
62 %{_includedir}/SLP_bundle_PG.h
63 %{_libdir}/pkgconfig/bundle.pc
64 %{_libdir}/libbundle.so
65