Fix warning about uninitialized variable
[platform/upstream/btrfs-progs.git] / packaging / btrfs-progs.spec
1 Name:           btrfs-progs
2 Version:        4.16.1
3 Release:        0
4 Summary:        Utilities for the Btrfs filesystem
5 Group:          Base/File Systems
6 License:        GPL-2.0
7 Url:            http://btrfs.wiki.kernel.org/index.php/Main_Page
8 Source:         %{name}-%{version}.tar.xz
9 Source1001:     btrfs-progs.manifest
10 BuildRequires:  libacl-devel
11 BuildRequires:  lzo-devel
12 BuildRequires:  libblkid-devel
13 BuildRequires:  pkgconfig(ext2fs)
14 BuildRequires:  pkgconfig(uuid)
15 BuildRequires:  pkgconfig(zlib)
16 # for /bin/true
17 Requires:       coreutils
18
19 %description
20 Utilities needed to create and maintain btrfs file systems under Linux.
21
22 %prep
23 %setup -q
24 cp %{SOURCE1001} .
25
26 %build
27 %autogen
28 %configure --disable-documentation --disable-python --disable-zstd
29 make %{?_smp_mflags}
30
31 %install
32 make install DESTDIR=%{buildroot} prefix=%{_prefix} bindir=%{_sbindir} mandir=%{_mandir}
33
34
35 rm -rf %{buildroot}%{_includedir}/btrfs/
36 rm -rf %{buildroot}%{_includedir}/btrfsutil.h
37 rm -rf %{buildroot}%{_libdir}/libbtrfs*
38 rm -rf %{buildroot}%{_libdir}/libbtrfsutil*
39
40
41 %docs_package
42
43 %files
44 %manifest %{name}.manifest
45 %license COPYING
46 %{_sbindir}/btrfs
47 %{_sbindir}/btrfs-convert
48 %{_sbindir}/btrfs-find-root
49 %{_sbindir}/btrfs-image
50 %{_sbindir}/btrfs-map-logical
51 %{_sbindir}/btrfsck
52 %{_sbindir}/btrfs-select-super
53 %{_sbindir}/btrfstune
54 %{_sbindir}/fsck.btrfs
55 %{_sbindir}/mkfs.btrfs