Using %license macro
[apps/native/boot-animation.git] / packaging / boot-animation.spec
1 #sbs-git:slp/pkgs/b/boot-animation boot-animation 0.2 d1bbca3948e4cdb6b2f9e75f176500f452fe6a33
2
3 Name: boot-animation
4 Version: 0.3.8
5 Release: 1
6 Summary: Boot animation
7 URL: http://slp-source.sec.samsung.net
8 Source: %{name}-%{version}.tar.gz
9 Source1: boot-animation.service
10 Source2: shutdown-animation.service
11 Source5: boot-animation.path
12 License: Apache-2.0
13 Group: Samsung/Application
14 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
15 BuildRequires: cmake
16 BuildRequires: edje, edje-bin, embryo, embryo-bin
17 BuildRequires: pkgconfig(ecore)
18 BuildRequires: pkgconfig(libexif)
19 BuildRequires: pkgconfig(elementary)
20 BuildRequires: pkgconfig(vconf)
21 BuildRequires: pkgconfig(mm-bootsound)
22 BuildRequires: pkgconfig(capi-appfw-preference)
23 BuildRequires: pkgconfig(capi-system-info)
24 BuildRequires: pkgconfig(capi-system-system-settings)
25 BuildRequires: pkgconfig(capi-ui-efl-util)
26 Requires: boot-animation-sound-file
27 Recommends: boot-animation-sound-file-profile_common
28 Requires(post): /usr/bin/vconftool
29
30 %description
31 Shows an animation and plays a sound when the device is booted or shutdown.
32
33 %package sound-file-profile_common
34 Summary: Default Boot Sound
35 Provides: boot-animation-sound-file-profile_mobile = %{version}-%{release}
36 Provides: boot-animation-sound-file-profile_tv = %{version}-%{release}
37 Provides: boot-animation-sound-file-profile_ivi = %{version}-%{release}
38 Provides: boot-animation-sound-file = %{version}-%{release}
39 Conflicts: boot-animation-sound-file-profile_wearable
40 Conflicts: boot-animation-extension_emulator
41
42 %description sound-file-profile_common
43 Provides the default boot-up sound file
44
45 %package sound-file-profile_wearable
46 Summary: Boot Sound for Wearable Profile
47 Provides: boot-animation-sound-file = %{version}-%{release}
48 Conflicts: boot-animation-sound-file-profile_common
49 Conflicts: boot-animation-extension-emulator
50
51 %description sound-file-profile_wearable
52 Boot-up sound file from B2 device.
53
54 %package extension_emulator
55 Summary: Boot Sound for SDK Emulator
56 Provides: boot-animation-sound-file = %{version}-%{release}
57 Conflicts: boot-animation-sound-file-profile_wearable
58 Conflicts: boot-animation-sound-file-profile_common
59
60 %description extension_emulator
61 Boot-up sound file for SDK emulator.
62
63 %prep
64 %setup -q
65 #%patch0 -p1
66
67 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
68
69 make %{?jobs:-j%jobs}
70
71 %install
72 rm -rf %{buildroot}
73 %make_install
74
75 mkdir -p %{buildroot}/usr/lib/systemd/system/multi-user.target.wants
76 install -m 0644 %SOURCE1 %{buildroot}/usr/lib/systemd/system/boot-animation.service
77 install -m 0644 %SOURCE2 %{buildroot}/usr/lib/systemd/system/shutdown-animation.service
78 install -m 0644 %SOURCE5 %{buildroot}/usr/lib/systemd/system/boot-animation.path
79 ln -s ../boot-animation.path %{buildroot}/usr/lib/systemd/system/multi-user.target.wants/
80
81 %clean
82 make clean
83
84 %docs_package
85
86 %post
87
88 %post sound-file-profile_wearable
89 mv /usr/share/keysound/poweron.wearable.ogg /usr/share/keysound/poweron.ogg
90
91 %preun sound-file-profile_wearable
92 mv /usr/share/keysound/poweron.ogg /usr/share/keysound/poweron.wearable.ogg
93
94 %post extension_emulator
95 mv /usr/share/keysound/poweron.sdk.wav /usr/share/keysound/poweron.wav
96
97 %preun extension_emulator
98 mv /usr/share/keysound/poweron.wav /usr/share/keysound/poweron.sdk.wav
99
100 %files
101 %manifest boot-animation.manifest
102 /usr/share/edje/360x360_PowerOn.edj
103 /usr/share/edje/360x360_PowerOff.edj
104 /usr/share/edje/360x480_PowerOn.edj
105 /usr/share/edje/360x480_PowerOff.edj
106 /usr/share/edje/480x800_PowerOn.edj
107 /usr/share/edje/480x800_PowerOff.edj
108 /usr/share/edje/720x1280_PowerOn.edj
109 /usr/share/edje/720x1280_PowerOff.edj
110 %license LICENSE
111 %{_bindir}/boot-animation
112 /usr/lib/systemd/system/boot-animation.service
113 /usr/lib/systemd/system/shutdown-animation.service
114 /usr/lib/systemd/system/boot-animation.path
115 /usr/lib/systemd/system/multi-user.target.wants/boot-animation.path
116
117 %files sound-file-profile_common
118 /usr/share/keysound/poweron.ogg
119
120 %files sound-file-profile_wearable
121 /usr/share/keysound/poweron.wearable.ogg
122
123 %files extension_emulator
124 /usr/share/keysound/poweron.sdk.wav