d3da633c5ee9748f9804867d22a5a0171d2a75b5
[platform/upstream/boost-jam.git] / packaging / boost-jam.spec
1 Name:           boost-jam
2 Version:        201104
3 Release:        0
4 Summary:        An Enhanced Make Replacement
5 License:        BSD-3-Clause
6 Group:          Development/Tools/Building
7 Source:         %{name}-%{version}.tar.xz
8 # From http://boost.cvs.sourceforge.net/boost/boost/tools/jam/test/:
9 Source2:        test.tar.gz 
10 Url:            http://www.boost.org/
11 BuildRequires:  xz
12
13 %description
14 Boost Jam is a build tool based on FTJam, which in turn is based on
15 Perforce Jam. It contains significant improvements made to facilitate
16 its use in the Boost Build System, but should be backward compatible
17 with Perforce Jam.
18
19 %prep
20 %setup -q
21 find . -type f|xargs chmod -R u+w
22
23 %build
24 export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wall -fno-strict-aliasing"
25 export CFLAGS="$RPM_OPT_FLAGS"
26 LOCATE_TARGET=bin ./build.sh gcc --symbols
27 # Trivial test: -- Documented used of bjam -v: Print the version of jam and exit:
28 bin/bjam -v
29 ln  -s bin bin.linux
30 cd ..
31 tar xvf %{SOURCE2}
32 ln -s %{name}-%{version} src
33 cd test
34 sh test.sh || if [ $? -gt 5 ]; then sh test.sh;fi
35
36 %install
37 mkdir -p %{buildroot}%{_bindir}
38 mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
39 install -m 755 bin/bjam %{buildroot}%{_bindir}/bjam-%{version}
40 ln -sf bjam-%{version} %{buildroot}%{_bindir}/bjam
41 ln -sf bjam-%{version} %{buildroot}%{_bindir}/jam
42
43 %files
44 %defattr(-,root,root)
45 %attr(755,root,root) %{_bindir}/*
46
47 %changelog