resetting manifest requested domain to floor
[platform/upstream/boost-jam.git] / packaging / boost-jam.spec
1 Name:           boost-jam
2 Version:        201104
3 Release:        0
4 Summary:        An Enhanced Make Replacement
5 License:        BSD-3-Clause
6 Group:          Development/Tools/Building
7 Source:         %{name}-%{version}.tar.xz
8 # From http://boost.cvs.sourceforge.net/boost/boost/tools/jam/test/:
9 Source2:        test.tar.gz 
10 Source1001:     boost-jam.manifest
11 Url:            http://www.boost.org/
12 BuildRequires:  xz
13
14 %description
15 Boost Jam is a build tool based on FTJam, which in turn is based on
16 Perforce Jam. It contains significant improvements made to facilitate
17 its use in the Boost Build System, but should be backward compatible
18 with Perforce Jam.
19
20 %prep
21 %setup -q
22 cp %{SOURCE1001} .
23 find . -type f|xargs chmod -R u+w
24
25 %build
26 export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wall -fno-strict-aliasing"
27 export CFLAGS="$RPM_OPT_FLAGS"
28 LOCATE_TARGET=bin ./build.sh gcc --symbols
29 # Trivial test: -- Documented used of bjam -v: Print the version of jam and exit:
30 bin/bjam -v
31 ln  -s bin bin.linux
32 cd ..
33 tar xvf %{SOURCE2}
34 ln -s %{name}-%{version} src
35 cd test
36 sh test.sh || if [ $? -gt 5 ]; then sh test.sh;fi
37
38 %install
39 mkdir -p %{buildroot}%{_bindir}
40 mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
41 install -m 755 bin/bjam %{buildroot}%{_bindir}/bjam-%{version}
42 ln -sf bjam-%{version} %{buildroot}%{_bindir}/bjam
43 ln -sf bjam-%{version} %{buildroot}%{_bindir}/jam
44
45 %files
46 %manifest %{name}.manifest
47 %defattr(-,root,root)
48 %attr(755,root,root) %{_bindir}/*
49
50 %changelog