Release 5.70
[platform/upstream/bluez.git] / packaging / bluez.spec
1 # Do not create provides fro extension-tm1 because the main package
2 # should anchor any reverse-dependencies
3 %global __provides_exclude_from ^(.*\\.tm1)$
4
5 #%define __spec_check_pre exit 0
6 %define unified true
7
8 #%define with_libcapng --enable-capng
9 %define _libpath /usr/lib
10 Name:           bluez
11 Summary:        Bluetooth Stack for Linux
12 Version:        5.66
13 Release:        1
14 Group:          Network & Connectivity/Bluetooth
15 License:        GPL-2.0+ and LGPL-2.1+
16 URL:            http://www.bluez.org/
17 Source:         bluez-%{version}.tar.gz
18 Source2:        bluez-coldplug.init
19 Source3:        bluetooth.sysconfig
20 Source4:        bluetooth.sh
21 Source5:        baselibs.conf
22 Source7:        bluetooth.modprobe
23 Source101:      obex-root-setup
24 Source102:      create-symlinks
25 Source103:      obex.sh
26 Source1001:     bluez.manifest
27 Patch :         Use-g_memdup2-for-glib-2.70-upgrade.patch
28 #Patch1 :    bluez-ncurses.patch
29 #Patch2 :    disable-eir-unittest.patch
30 #Requires:   dbus >= 0.60
31 #BuildRequires:  pkgconfig(libudev)
32 BuildRequires:  pkgconfig(dbus-1)
33 BuildRequires:  pkgconfig(iniparser)
34 BuildRequires:  pkgconfig(libxml-2.0)
35 BuildRequires:  pkgconfig(json-c)
36 BuildRequires:  pkgconfig(ell)
37 #BuildRequires:  pkgconfig(glib-2.0)
38 #BuildRequires:  pkgconfig(ncurses)
39 #BuildRequires:  flex
40 #BuildRequires:  bison
41 #BuildRequires:  readline-devel
42 #BuildRequires:  openssl-devel
43 BuildRequires:  flex
44 BuildRequires:  libcap-ng-devel
45 BuildRequires:  systemd
46 %{?systemd_requires}
47 BuildRequires:  pkgconfig(alsa)
48 BuildRequires:  automake
49 BuildRequires:  check-devel
50 BuildRequires:  glib2-devel >= 2.16
51 BuildRequires:  libsndfile-devel
52 BuildRequires:  libtool
53 BuildRequires:  libudev-devel
54 BuildRequires:  pkg-config
55 BuildRequires:  readline-devel
56 BuildRequires:  udev
57 BuildRequires:  pkgconfig(libtzplatform-config)
58 Requires:       %{name}-compat = %{version}-%{release}
59 Requires:       security-config
60 Recommends:     %{name}-profile_common = %{version}-%{release}
61
62 %description
63 The Bluetooth stack for Linux.
64
65 %if %{unified} == true
66 %package extension-bredr
67 Summary:    Bluez extension for BREDR functionality
68 Requires:  %{name} = %{version}-%{release}
69 Conflicts:  %{name}-extension-le = %{version}-%{release}
70 %description extension-bredr
71 Bluez extension for BREDR functionality
72
73 %package extension-le
74 Summary:    Bluez extension for LE functionality
75 Requires:  %{name} = %{version}-%{release}
76 Conflicts:  %{name}-extension-bredr = %{version}-%{release}
77 %description extension-le
78 Bluez extension for LE functionality
79 %endif
80
81 %package -n obexd
82 Summary:        OBEX Server A basic OBEX server implementation
83 Group:          Network & Connectivity/Bluetooth
84 Requires:       tizen-platform-config-tools
85
86 %description -n obexd
87 OBEX Server A basic OBEX server implementation.
88
89 %package test
90 Summary:        Tools for testing of various Bluetooth-functions
91 License:        GPL-2.0+
92 Group:          Development/Tools
93 Requires:       dbus-python
94 Requires:       python-gobject
95
96 %description test
97 Contains a few tools for testing various bluetooth functions. The
98 BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
99
100 %package tools
101 Summary:        Bluez configuration tools
102 License:        GPL-2.0+
103 Group:          Development/Tools
104
105 %description tools
106 # !!! WARNING !!!
107 # Using any tool in this package results direct access to bluez stack,
108 # so the result of the tool won't be applied to Tizen system properly.
109 # Recommend to use it cautiously and only in development phase.
110 Bluez tools to manipulate bluetooth devices and configuartion.
111
112 %package profile_common
113 Summary:        Modified bluez for mobile/common profile
114 Provides:       %{name}-compat = %{version}-%{release}
115 Provides:       %{name}-profile_mobile = %{version}-%{release}
116 Provides:       %{name}-profile_ivi = %{version}-%{release}
117 Conflicts:      %{name}-profile_wearable
118 Conflicts:      %{name}-profile_tv
119 %description profile_common
120 Bluez default service script for Tizen (mobile/common profile)
121
122 %package profile_wearable
123 Summary:        Modified bluez for wearable profile
124 Provides:       %{name}-compat = %{version}-%{release}
125 Conflicts:      %{name}-profile_common
126 Conflicts:      %{name}-profile_tv
127 %description profile_wearable
128 Bluez modified service script for Tizen wearable
129
130 %package profile_tv
131 Summary:        Modified bluez for wearable profile
132 Provides:       %{name}-compat = %{version}-%{release}
133 Conflicts:      %{name}-profile_common
134 Conflicts:      %{name}-profile_wearable
135 %description profile_tv
136 Bluez modified service script for Tizen TV
137
138 %package plugin-headless
139 Summary:        Bluez headless plugin
140 Requires:       %{name}-compat = %{version}-%{release}
141 %description plugin-headless
142 This package is Bluez plugin to manager headless device
143
144 %package plugin-keyboard
145 Summary:        Bluez keyboard plugin
146 Requires:       %{name}-compat = %{version}-%{release}
147 %description plugin-keyboard
148 This package is Bluez plugin to manager keyboard device
149
150 %package plugin-robot
151 Summary:        Bluez robot plugin
152 Requires:       %{name}-compat = %{version}-%{release}
153 %description plugin-robot
154 This package is Bluez plugin to manager robot device
155
156 %package plugin-da
157 Summary:        Bluez plugin for Digital Appliance
158 Requires:       %{name}-compat = %{version}-%{release}
159 %description plugin-da
160 This package is Bluez plugin to manager Digital Appliance devices
161
162 %package mesh
163 Summary:        contains binaries for bluetooth mesh
164 Requires:       %{name}-compat = %{version}-%{release}
165 License:        GPL-2.0+
166 %description mesh
167 Contains bluetooth mesh daemon
168
169 %prep
170 %setup -q
171 cp %{SOURCE1001} .
172 %patch -p1
173
174 %build
175 autoreconf -fiv
176
177 #if "{?profile}" == "ivi"
178 # TIZEN_FEATURE_BLUEZ_BRCM_CHIP: only in tools/hciattach.c ==> RUNTIME! (profile.h)
179 #endif
180
181 #if "{?profile}" == "wearable"
182 # TIZEN_FEATURE_BLUEZ_SMS_ONLY: only in obexd/plugins/messages-tizen.c ==> RUNTIME! (profile.h)
183 # TIZEN_FEATURE_BLUEZ_BRCM_QOS: only in profiles/audio/avdtp.c ==> RUNTIME! (profile.h)
184 # TIZEN_FEATURE_BLUEZ_ROLE_CHANGE: only in profiles/audio/avdtp.c ==> RUNTIME! (profile.h)
185 # TIZEN_FEATURE_BLUEZ_CONFIRM_ONLY: only in src/device.c ==> RUNTIME! (profile.h)
186 #endif
187
188
189 # For LE only
190
191 export CFLAGS_DEFAULT="$CFLAGS"
192
193 %if %{unified} == true
194 # Add GCC9 exception
195 export CFLAGS+=" -Wno-stringop-truncation -Wno-format-truncation -Wno-address-of-packed-member"
196
197 export LDFLAGS=" -lncurses -Wl,--as-needed "
198 export CFLAGS+=" -Werror -DTIZEN_FEATURE_BLUEZ_MODIFY -DTIZEN_FEATURE_BLUEZ_A2DP_MULTISTREAM -DTIZEN_FEATURE_BLUEZ_PBAP_SIM -DTIZEN_FEATURE_BLUEZ_AVRCP_TARGET -DTIZEN_FEATURE_BLUEZ_AVRCP_CONTROL -DTIZEN_FEATURE_BLUEZ_AVRCP_TARGET -DENABLE_AVRCP_CATEGORY1 -DTIZEN_BT_HID_DEVICE_ENABLE"
199
200 %ifarch aarch64
201 echo arch64
202 export CFLAGS+=" -DARCH64"
203 %endif
204
205 %ifarch riscv64
206 echo riscv64
207 export CFLAGS+=" -DARCH64"
208 %endif
209
210 %ifarch x86_64
211 echo x86_64
212 export CFLAGS+=" -DARCH64"
213 %endif
214
215 %reconfigure --disable-static \
216                         --sysconfdir=%{_sysconfdir} \
217                         --localstatedir=%{_localstatedir} \
218                         --with-systemdsystemunitdir=%{_libpath}/systemd/system \
219                         --with-systemduserunitdir=%{_libpath}/systemd/user \
220                         --libexecdir=%{_libexecdir} \
221                         --enable-debug \
222                         --enable-pie \
223                         --enable-usb=no \
224                         --enable-tools \
225                         --disable-bccmd \
226                         --enable-pcmcia=no \
227                         --enable-hid2hci=yes \
228                         --enable-alsa=no \
229                         --enable-gstreamer=no \
230                         --disable-dfutool \
231                         --disable-cups \
232                         --enable-proximity=yes \
233                         --enable-tds=yes \
234                         --enable-dbusoob \
235                         --enable-test \
236                         --enable-mesh=yes \
237                         --with-telephony=tizen \
238                         --enable-obex \
239                         --enable-library \
240                         --enable-gatt \
241                         --enable-testing \
242                         --enable-experimental \
243                         --enable-autopyypair=no \
244                         --enable-tizenunusedplugin=no \
245                         --disable-crypto-tests \
246                         --enable-external-ell
247
248 make %{?_smp_mflags} all V=1
249
250 mkdir -p le
251
252 #%make_install
253 cp -a  %{buildroot}%{_libexecdir}/bluetooth/bluetoothd le/
254
255
256 # For BREDR only
257 make distclean
258
259 autoreconf -fiv
260
261 export CFLAGS="$CFLAGS_DEFAULT"
262
263 # Add GCC9 exception
264 export CFLAGS+=" -Wno-stringop-truncation -Wno-format-truncation -Wno-address-of-packed-member"
265
266 export LDFLAGS=" -lncurses -Wl,--as-needed "
267 export CFLAGS+=" -Werror -DTIZEN_FEATURE_BLUEZ_MODIFY -DTIZEN_FEATURE_BLUEZ_A2DP_MULTISTREAM -DTIZEN_FEATURE_BLUEZ_PBAP_SIM -DTIZEN_FEATURE_BLUEZ_AVRCP_TARGET -DTIZEN_FEATURE_BLUEZ_AVRCP_CONTROL -DTIZEN_FEATURE_BLUEZ_AVRCP_TARGET -DENABLE_AVRCP_CATEGORY1 -DTIZEN_BT_HID_DEVICE_ENABLE"
268
269 %ifarch aarch64
270 echo arch64
271 export CFLAGS+=" -DARCH64"
272 %endif
273
274 %ifarch riscv64
275 echo riscv64
276 export CFLAGS+=" -DARCH64"
277 %endif
278
279 %ifarch x86_64
280 echo x86_64
281 export CFLAGS+=" -DARCH64"
282 %endif
283
284 %reconfigure --disable-static \
285                         --sysconfdir=%{_sysconfdir} \
286                         --localstatedir=%{_localstatedir} \
287                         --with-systemdsystemunitdir=%{_libpath}/systemd/system \
288                         --with-systemduserunitdir=%{_libpath}/systemd/user \
289                         --libexecdir=%{_libexecdir} \
290                         --enable-debug \
291                         --enable-pie \
292                         --enable-serial \
293                         --enable-input \
294                         --enable-usb=no \
295                         --enable-tools \
296                         --disable-bccmd \
297                         --enable-pcmcia=no \
298                         --enable-hid2hci=yes \
299                         --enable-alsa=no \
300                         --enable-gstreamer=no \
301                         --disable-dfutool \
302                         --disable-cups \
303                         --enable-health=yes \
304                         --enable-dbusoob \
305                         --enable-test \
306                         --enable-mesh=yes \
307                         --with-telephony=tizen \
308                         --enable-obex \
309                         --enable-library \
310                         --enable-testing \
311                         --enable-experimental \
312                         --enable-autopair=no \
313                         --enable-hid=yes \
314                         --enable-bredr=yes \
315                         --enable-tizenunusedplugin=no \
316                         --disable-crypto-tests \
317                         --enable-external-ell
318
319 make %{?_smp_mflags} all V=1
320
321 mkdir -p bredr
322
323 #%make_install
324 cp -a  %{buildroot}%{_libexecdir}/bluetooth/bluetoothd bredr/
325
326
327 # For BREDR + LE
328 make distclean
329
330 autoreconf -fiv
331 %endif
332 export CFLAGS="$CFLAGS_DEFAULT"
333
334 # Add GCC9 exception
335 export CFLAGS+=" -Wno-stringop-truncation -Wno-format-truncation -Wno-address-of-packed-member"
336
337 export LDFLAGS=" -lncurses -Wl,--as-needed "
338 export CFLAGS+=" -Werror -DTIZEN_FEATURE_BLUEZ_MODIFY -DTIZEN_FEATURE_BLUEZ_A2DP_MULTISTREAM -DTIZEN_FEATURE_BLUEZ_PBAP_SIM -DTIZEN_FEATURE_BLUEZ_AVRCP_TARGET -DTIZEN_FEATURE_BLUEZ_AVRCP_CONTROL -DTIZEN_FEATURE_BLUEZ_AVRCP_TARGET -DENABLE_AVRCP_CATEGORY1 -DTIZEN_BT_HID_DEVICE_ENABLE"
339
340 %ifarch aarch64
341 echo arch64
342 export CFLAGS+=" -DARCH64"
343 %endif
344
345 %ifarch riscv64
346 echo riscv64
347 export CFLAGS+=" -DARCH64"
348 %endif
349
350 %ifarch x86_64
351 echo x86_64
352 export CFLAGS+=" -DARCH64"
353 %endif
354
355 %reconfigure --disable-static \
356                         --sysconfdir=%{_sysconfdir} \
357                         --localstatedir=%{_localstatedir} \
358                         --with-systemdsystemunitdir=%{_libpath}/systemd/system \
359                         --with-systemduserunitdir=%{_libpath}/systemd/user \
360                         --libexecdir=%{_libexecdir} \
361                         --enable-debug \
362                         --enable-pie \
363                         --enable-serial \
364                         --enable-input \
365                         --enable-usb=no \
366                         --enable-tools \
367                         --disable-bccmd \
368                         --enable-pcmcia=no \
369                         --enable-hid2hci=yes \
370                         --enable-alsa=no \
371                         --enable-gstreamer=no \
372                         --disable-dfutool \
373                         --disable-cups \
374                         --enable-health=yes \
375                         --enable-proximity=yes \
376                         --enable-tds=yes \
377                         --enable-dbusoob \
378                         --enable-test \
379                         --with-telephony=tizen \
380                         --enable-obex \
381                         --enable-mesh=yes \
382                         --enable-library \
383                         --enable-gatt \
384                         --enable-testing \
385                         --enable-experimental \
386                         --enable-autopair=no \
387                         --enable-hid=yes \
388                         --enable-bredr=yes \
389                         --enable-tizenunusedplugin=no \
390                         --disable-crypto-tests \
391                         --enable-external-ell
392
393 make %{?_smp_mflags} all V=1
394
395 %check
396 make check
397
398 %install
399 %make_install
400
401 %if %{unified} == true
402 pushd bredr
403 for FILE in bluetoothd; do mv "$FILE" "%{buildroot}%{_libexecdir}/bluetooth/$FILE.bredr"; done
404 popd
405
406 pushd le
407 for FILE in bluetoothd; do mv "$FILE" "%{buildroot}%{_libexecdir}/bluetooth/$FILE.le"; done
408 popd
409 %endif
410
411 # bluez-test
412 rm -rvf $RPM_BUILD_ROOT/%{_libdir}/gstreamer-*
413 #install --mode=0755 -D %{S:4} $RPM_BUILD_ROOT/usr/lib/udev/bluetooth.sh
414 %if %{unified} == true
415 install --mode=0644 -D %{S:7} $RPM_BUILD_ROOT/%{_sysconfdir}/modprobe.d/50-bluetooth.conf
416 %endif
417
418 # no idea why this is suddenly necessary...
419 install --mode 0755 -d $RPM_BUILD_ROOT/var/lib/bluetooth
420
421 install -D -m 0644 src/main_w.conf %{buildroot}%{_sysconfdir}/bluetooth/main.conf.wearable
422 install -D -m 0644 src/main_m.conf %{buildroot}%{_sysconfdir}/bluetooth/main.conf
423 install -D -m 0644 src/main_headless.conf %{buildroot}%{_sysconfdir}/bluetooth/main.conf.headless
424 install -D -m 0644 src/main_keyboard.conf %{buildroot}%{_sysconfdir}/bluetooth/main.conf.keyboard
425 install -D -m 0644 src/main_robot.conf %{buildroot}%{_sysconfdir}/bluetooth/main.conf.robot
426 install -D -m 0644 src/main_da.conf %{buildroot}%{_sysconfdir}/bluetooth/main.conf.da
427
428 #install -D -m 0644 src/org.bluez.service %{buildroot}%{_datadir}/dbus-1/system-services/org.bluez.service
429
430 install -D -m 0644 src/bluetooth.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d/bluetooth.conf
431 install -D -m 0644 src/bluetooth_robot.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d/bluetooth_robot.conf
432 #install -D -m 0644 profiles/audio/audio.conf %{buildroot}%{_sysconfdir}/bluetooth/audio.conf
433 #install -D -m 0644 profiles/network/network.conf %{buildroot}%{_sysconfdir}/bluetooth/network.conf
434
435 #install -D -m 0644 COPYING %{buildroot}%{_datadir}/license/bluez
436 #install -D -m 0644 COPYING %{buildroot}%{_datadir}/license/libbluetooth3
437 #install -D -m 0644 COPYING %{buildroot}%{_datadir}/license/libbluetooth-devel
438
439 #install -D -m 0755 %SOURCE101 %{buildroot}%{_bindir}/obex-root-setup
440 #install -D -m 0755 %SOURCE102 %{buildroot}%{_sysconfdir}/obex/root-setup.d/000_create-symlinks
441 #install -D -m 0755 %SOURCE103 %{buildroot}%{_bindir}/obex.sh
442 install -D -m 0755 tools/btiotest $RPM_BUILD_ROOT/%{_bindir}/
443 install -D -m 0755 tools/bluetooth-player $RPM_BUILD_ROOT/%{_bindir}/
444 #install -D -m 0755 tools/mpris-player $RPM_BUILD_ROOT/%{_bindir}/
445 install -D -m 0755 tools/btmgmt $RPM_BUILD_ROOT/%{_bindir}/
446 install -D -m 0755 tools/scotest $RPM_BUILD_ROOT/%{_bindir}/
447 install -D -m 0755 tools/bluemoon $RPM_BUILD_ROOT/%{_bindir}/
448 install -D -m 0755 attrib/gatttool $RPM_BUILD_ROOT/%{_bindir}/
449 install -D -m 0755 tools/meshctl $RPM_BUILD_ROOT/%{_bindir}/
450 install -D -m 0755 tools/mesh-cfgclient $RPM_BUILD_ROOT/%{_bindir}/
451
452 # mesh conf
453 install -D -m 0644 mesh/mesh-main.conf %{buildroot}%{_sysconfdir}/bluetooth/mesh-main.conf
454
455 install -D -m 0755 tools/obexctl %{buildroot}%{_bindir}/obexctl
456
457 install -D -m 0644 obexd/src/obex.service %{buildroot}%{_libpath}/systemd/system/
458
459 install -D -m 0644 src/bluetooth.service %{buildroot}%{_libpath}/systemd/system/bluez-start.service
460
461 %if %{unified} == true
462 %post -n bluez-extension-bredr
463 pushd %{_libexecdir}/bluetooth
464 for FILE in bluetoothd.bredr; do mv "$FILE" "${FILE%.bredr}"; done
465 popd
466 /sbin/ldconfig
467
468 %post -n bluez-extension-le
469 pushd %{_libexecdir}/bluetooth
470 for FILE in bluetoothd.le; do mv "$FILE" "${FILE%.le}"; done
471 popd
472 /sbin/ldconfig
473 %endif
474
475 %files
476 %manifest %{name}.manifest
477 %defattr(-, root, root)
478 %license COPYING
479 #%{_sysconfdir}/bluetooth/audio.conf
480 #%{_sysconfdir}/bluetooth/network.conf
481 #%{_sysconfdir}/bluetooth/rfcomm.conf
482 #%{_datadir}/man/*/*
483 %attr(750, network_fw, network_fw)%{_bindir}/hcitool
484 %{_bindir}/l2ping
485 %{_bindir}/obexctl
486 %{_bindir}/rfcomm
487 %{_bindir}/btsnoop
488 %{_bindir}/mpris-proxy
489 %{_bindir}/sdptool
490 %{_bindir}/ciptool
491 #%{_bindir}/dfutool
492 %{_bindir}/btmon
493 %{_bindir}/hcidump
494 %attr(750, network_fw, network_fw)%{_bindir}/btattach
495 %attr(750, network_fw, network_fw)%{_bindir}/hciattach
496 %attr(750, network_fw, network_fw)%{_bindir}/hciconfig
497 %attr(755, network_fw, network_fw)%{_libexecdir}/bluetooth/bluetoothd
498 %exclude %{_libexecdir}/bluetooth/bluetoothd.bredr
499 %exclude %{_libexecdir}/bluetooth/bluetoothd.le
500 %exclude %{_includedir}/bluetooth/*
501 %exclude %{_libdir}/pkgconfig/bluez.pc
502 #%{_bindir}/bccmd
503 #%{_sbindir}/hid2hci
504 %dir /usr/lib/udev
505 /usr/lib/udev/*
506 %{_unitdir}/bluez-start.service
507 %exclude %{_unitdir}/bluetooth.service
508
509 %if %{unified} == true
510 %files -n bluez-extension-bredr
511 %manifest %{name}.manifest
512 %defattr(-, root, root)
513 %{_libexecdir}/bluetooth/bluetoothd.bredr
514
515 %files -n bluez-extension-le
516 %manifest %{name}.manifest
517 %defattr(-, root, root)
518 %{_libexecdir}/bluetooth/bluetoothd.le
519 %config %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
520 %dir /var/lib/bluetooth
521 %dir %{_sysconfdir}/modprobe.d
522 %config(noreplace) %{_sysconfdir}/modprobe.d/50-bluetooth.conf
523 %endif
524
525 %files mesh
526 %manifest %{name}.manifest
527 %defattr(-, root, root)
528 %license COPYING
529 %{_sysconfdir}/dbus-1/system.d/bluetooth-mesh.conf
530 %attr(755, network_fw, network_fw)%{_libexecdir}/bluetooth/bluetooth-meshd
531 %{_libpath}/systemd/system/bluetooth-mesh.service
532 %exclude %{_datadir}/dbus-1/system-services/org.bluez.mesh.service
533 %exclude /usr/lib/debug/*
534 %{_sysconfdir}/bluetooth/mesh-main.conf
535
536 %files -n obexd
537 %manifest %{name}.manifest
538 %defattr(-,root,root,-)
539 %{_libexecdir}/bluetooth/obexd
540 %{_libpath}/systemd/system/obex.service
541 %{_datadir}/dbus-1/system-services/org.bluez.obex.service
542 #%{_sysconfdir}/obex/root-setup.d/000_create-symlinks
543 #%{_bindir}/obex-root-setup
544 #%{_bindir}/obex.sh
545
546 %files tools
547 %{_bindir}/bluetoothctl
548 %{_bindir}/btmgmt
549 %{_bindir}/gatttool
550 %{_bindir}/bluemoon
551 %{_bindir}/hex2hcd
552 %{_bindir}/meshctl
553 %{_bindir}/mesh-cfgclient
554 %{_bindir}/bluetooth-player
555
556 %files test
557 %manifest %{name}.manifest
558 %defattr(-,root,root)
559 %{_libdir}/bluez/test/*
560 %{_bindir}/l2test
561 %{_bindir}/rctest
562 %{_bindir}/btiotest
563 #%{_bindir}/mpris-player
564 %{_bindir}/scotest
565 %{_bindir}/isotest
566 %{_bindir}/avtest
567 #%{_bindir}/btattach
568 %exclude /usr/lib/debug/*
569 %{_libdir}/libbluetooth.so*
570
571 %docs_package
572
573 %post profile_wearable
574 ln -sf main.conf.wearable %{_sysconfdir}/bluetooth/main.conf
575 %preun profile_wearable
576 rm %{_sysconfdir}/bluetooth/main.conf
577 %files profile_wearable
578 %manifest %{name}.manifest
579 %{_sysconfdir}/bluetooth/main.conf.wearable
580 %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
581
582 %files profile_tv
583 %manifest %{name}.manifest
584 %{_sysconfdir}/bluetooth/main.conf
585 %exclude %{_datadir}/dbus-1/system-services/org.bluez.service
586 %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
587
588 %files profile_common
589 %manifest %{name}.manifest
590 %{_sysconfdir}/bluetooth/main.conf
591 %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
592
593 %post plugin-headless
594 ln -sf main.conf.headless %{_sysconfdir}/bluetooth/main.conf
595 %preun plugin-headless
596 rm %{_sysconfdir}/bluetooth/main.conf
597 %files plugin-headless
598 %manifest %{name}.manifest
599 %{_sysconfdir}/bluetooth/main.conf.headless
600
601 %post plugin-keyboard
602 ln -sf main.conf.keyboard %{_sysconfdir}/bluetooth/main.conf
603 %preun plugin-keyboard
604 rm %{_sysconfdir}/bluetooth/main.conf
605 %files plugin-keyboard
606 %manifest %{name}.manifest
607 %{_sysconfdir}/bluetooth/main.conf.keyboard
608
609 %post plugin-robot
610 ln -sf main.conf.robot %{_sysconfdir}/bluetooth/main.conf
611 mv %{_sysconfdir}/dbus-1/system.d/bluetooth_robot.conf %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
612 %preun plugin-robot
613 rm %{_sysconfdir}/bluetooth/main.conf
614 %files plugin-robot
615 %manifest %{name}.manifest
616 %{_sysconfdir}/bluetooth/main.conf.robot
617 %{_sysconfdir}/dbus-1/system.d/bluetooth_robot.conf
618
619 %post plugin-da
620 ln -sf main.conf.da %{_sysconfdir}/bluetooth/main.conf
621 %preun plugin-da
622 rm %{_sysconfdir}/bluetooth/main.conf
623 %files plugin-da
624 %manifest %{name}.manifest
625 %{_sysconfdir}/bluetooth/main.conf.da
626
627 %changelog