Migrate bluez-start.service to bluez
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
1 Name:       bluetooth-tools
2 Summary:    Bluetooth-tools
3 Version:    0.6.0
4 Release:    1
5 Group:      Network & Connectivity/Bluetooth
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #Source1001: bluetooth-address.service
9 BuildRequires:  cmake
10 Suggests:       bluetooth-share
11 Requires:       tizen-platform-config-tools
12 Requires:      bluetooth-scripts
13 Requires:   %{name}-compat = %{version}-%{release}
14 Recommends:   %{name}-profile_common = %{version}-%{release}
15
16 %description
17 Tools fo bluetooth run/stop and set address
18
19 %package profile_common
20 Summary:    Bluetooth-tools extension for common/tv
21 Provides:   %{name}-compat = %{version}-%{release}
22 Provides:   %{name}-profile_tv = %{version}-%{release}
23 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
24 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
25 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
26 %description profile_common
27 Bluetooth-tools extension for Tizen common / tv profile.
28
29 %package profile_mobile
30 Summary:    Bluetooth-tools extension for mobile/tv
31 Provides:   %{name}-compat = %{version}-%{release}
32 Conflicts:  %{name}-profile_common = %{version}-%{release}
33 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
34 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
35 %description profile_mobile
36 Bluetooth-tools extension for Tizen mobile profile.
37
38 %package profile_wearable
39 Summary:    Bluetooth-tools extension for wearable/tv
40 Provides:   %{name}-compat = %{version}-%{release}
41 Conflicts:  %{name}-profile_common = %{version}-%{release}
42 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
43 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
44 %description profile_wearable
45 Bluetooth-tools extension for Tizen wearable profile.
46
47 %package profile_ivi
48 Summary:    Bluetooth-tools extension for ivi/tv
49 Provides:   %{name}-compat = %{version}-%{release}
50 Conflicts:  %{name}-profile_common = %{version}-%{release}
51 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
52 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
53 %description profile_ivi
54 Bluetooth-tools extension for Tizen ivi profile.
55
56 %package no-firmware
57 Summary:    On/Off Bluetooth adapter
58 Group:      Network & Connectivity/Bluetooth
59 Requires:   %{name} = %{version}-%{release}
60 Provides:   bluetooth-scripts
61 Conflicts:  bluetooth-firmware-bcm
62
63 %description no-firmware
64 On/Off bluetooth device
65
66 %prep
67 %setup -q
68
69 %build
70 export CFLAGS+=" -fpie -fvisibility=hidden"
71 export CXXFLAGS+=" -fpie -fvisibility=hidden"
72 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
73
74 %cmake
75 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
76 %if 0%{?tizen_build_binary_release_type_eng}
77         -DBT_HCI_LOG_SIZE=10
78 %else
79         -DBT_HCI_LOG_SIZE=5
80 %endif
81
82 %__make %{?_smp_mflags}
83
84 %install
85 rm -rf %{buildroot}
86 %make_install
87
88 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
89 mkdir -p %{buildroot}/run/bluetooth
90 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
91 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
92
93 install -D -m 0644 packaging/bluetooth-stack-up.service %{buildroot}%{_unitdir}/bluetooth-stack-up.service
94
95 install -D -m 0644 packaging/bluetooth-stack-down.service %{buildroot}%{_unitdir}/bluetooth-stack-down.service
96
97 install -D -m 0644 packaging/bluetooth-stack-down-with-radio.service %{buildroot}%{_unitdir}/bluetooth-stack-down-with-radio.service
98
99 #install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_unitdir}/bluetooth-force-hci-logger.service
100 #install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_unitdir}/bluetooth-hci-dump@.service
101
102 install -D -m 0644 packaging/bluetooth-hci-up.service %{buildroot}%{_unitdir}/bluetooth-hci-up.service
103 install -D -m 0644 packaging/bluetooth-hci-down.service %{buildroot}%{_unitdir}/bluetooth-hci-down.service
104
105 install -D -m 0644 packaging/bluetooth-stack-up-common.service %{buildroot}%{_unitdir}/bluetooth-stack-up-common.service
106 install -D -m 0644 packaging/bluetooth-stack-down-common.service %{buildroot}%{_unitdir}/bluetooth-stack-down-common.service
107
108 %post
109 mkdir -p %{_unitdir}/multi-user.target.wants/
110
111 %files
112 %manifest %{name}.manifest
113 %license LICENSE.APLv2
114 %defattr(-,root,root,-)
115 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-on.sh
116 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
117 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
118 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
119
120 %post profile_common
121 pushd %{_prefix}/etc/bluetooth/
122 ln -sf common/bt-stack-up.sh bt-stack-up.sh
123 ln -sf common/bt-stack-down.sh bt-stack-down.sh
124 ln -sf common/bt-reset-env.sh bt-reset-env.sh
125 popd
126 pushd %{_unitdir}
127 mv bluetooth-stack-up-common.service bluetooth-stack-up.service
128 mv bluetooth-stack-down-common.service bluetooth-stack-down.service
129 popd
130 %preun profile_common
131 pushd %{_prefix}/etc/bluetooth/
132 rm bt-stack-up.sh
133 rm bt-stack-down.sh
134 rm bt-reset-env.sh
135 popd
136 pushd %{_unitdir}
137 rm bluetooth-stack-up.service
138 rm bluetooth-stack-down.service
139 popd
140 %files profile_common
141 %license LICENSE.APLv2
142 #%{_sysconfdir}/rc.d/init.d/bluetooth-address
143 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-up.sh
144 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-down.sh
145 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-reset-env.sh
146 %{_unitdir}/bluetooth-stack-up-common.service
147 %{_unitdir}/bluetooth-stack-down-common.service
148 %{_unitdir}/bluetooth-hci-up.service
149 %{_unitdir}/bluetooth-hci-down.service
150
151 %post profile_mobile
152 pushd %{_prefix}/etc/bluetooth/
153 ln -sf mobile/bt-stack-up.sh bt-stack-up.sh
154 ln -sf mobile/bt-stack-down.sh bt-stack-down.sh
155 ln -sf mobile/bt-stack-down-with-radio.sh bt-stack-down-with-radio.sh
156 ln -sf mobile/bt-reset-env.sh bt-reset-env.sh
157 popd
158 %preun profile_mobile
159 pushd %{_prefix}/etc/bluetooth/
160 rm bt-stack-up.sh
161 rm bt-stack-down.sh
162 rm bt-stack-down-with-radio.sh
163 rm bt-reset-env.sh
164 popd
165 %files profile_mobile
166 %license LICENSE.APLv2
167 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-up.sh
168 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
169 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
170 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
171 %{_unitdir}/bluetooth-stack-down-with-radio.service
172 %{_unitdir}/bluetooth-stack-up.service
173 %{_unitdir}/bluetooth-stack-down.service
174 %{_unitdir}/bluetooth-hci-up.service
175 %{_unitdir}/bluetooth-hci-down.service
176
177 %post profile_ivi
178 pushd %{_prefix}/etc/bluetooth/
179 ln -sf ivi/bt-stack-up.sh bt-stack-up.sh
180 ln -sf ivi/bt-stack-down.sh bt-stack-down.sh
181 ln -sf ivi/bt-reset-env.sh bt-reset-env.sh
182 popd
183 %preun profile_ivi
184 pushd %{_prefix}/etc/bluetooth/
185 rm bt-stack-up.sh
186 rm bt-stack-down.sh
187 rm bt-reset-env.sh
188 popd
189 %files profile_ivi
190 %license LICENSE.APLv2
191 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
192 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
193 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
194 %{_unitdir}/bluetooth-stack-up.service
195 %{_unitdir}/bluetooth-stack-down.service
196 %{_unitdir}/bluetooth-hci-up.service
197 %{_unitdir}/bluetooth-hci-down.service
198
199 %post profile_wearable
200 pushd %{_prefix}/etc/bluetooth/
201 ln -sf wearable/bt-stack-up.sh bt-stack-up.sh
202 ln -sf wearable/bt-stack-down.sh bt-stack-down.sh
203 ln -sf wearable/bt-reset-env.sh bt-reset-env.sh
204 popd
205 %preun profile_wearable
206 pushd %{_prefix}/etc/bluetooth/
207 rm bt-stack-up.sh
208 rm bt-stack-down.sh
209 rm bt-reset-env.sh
210 popd
211 %files profile_wearable
212 %license LICENSE.APLv2
213 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
214 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
215 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
216 %{_unitdir}/bluetooth-stack-up.service
217 %{_unitdir}/bluetooth-stack-down.service
218 %{_unitdir}/bluetooth-hci-up.service
219 %{_unitdir}/bluetooth-hci-down.service
220
221 %files no-firmware
222 %manifest %{name}.manifest
223 %license LICENSE.APLv2
224 %defattr(-, root, root)
225 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
226 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh
227 %{_unitdir}/bluetooth-stack-up.service
228 %{_unitdir}/bluetooth-stack-down.service
229 %{_unitdir}/bluetooth-hci-up.service
230 %{_unitdir}/bluetooth-hci-down.service
231