Integrate Cynara into bluetooth-share
[platform/core/connectivity/bluetooth-share.git] / packaging / bluetooth-share.spec
1 Name:       bluetooth-share
2 Summary:    Bluetooth file share Agent
3 Version:    0.0.47
4 Release:    0
5 Group:      Network & Connectivity/Bluetooth
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 Source1002: libbluetooth-share.manifest
10 Source1003: libbluetooth-share-devel.manifest
11 Source1004: init_db.sh
12 Requires(post): coreutils
13 Requires(post): smack
14 BuildRequires:  cmake
15 BuildRequires:  gettext-tools
16 BuildRequires:  pkgconfig(appcore-efl)
17 BuildRequires:  pkgconfig(bluetooth-api)
18 BuildRequires:  pkgconfig(glib-2.0)
19 BuildRequires:  pkgconfig(dlog)
20 BuildRequires:  pkgconfig(sqlite3)
21 BuildRequires:  pkgconfig(ecore)
22 # Same check as in tizen-extensions-crosswalk. A per-package or global
23 # bcond would be better, but for now let's follow Crosswalk's approach.
24 #%if "%{profile}" == "mobile"
25 #BuildRequires:  pkgconfig(calendar-service2)
26 #BuildRequires:  pkgconfig(contacts-service2)
27 #%endif
28 BuildRequires:  pkgconfig(vconf)
29 BuildRequires:  pkgconfig(pmapi)
30 BuildRequires:  pkgconfig(sysman)
31 BuildRequires:  pkgconfig(notification)
32 BuildRequires:  pkgconfig(appsvc)
33 BuildRequires:  pkgconfig(db-util)
34 BuildRequires:  pkgconfig(capi-content-media-content)
35 BuildRequires:  pkgconfig(libtzplatform-config)
36 BuildRequires:  pkgconfig(cynara-client)
37 BuildRequires:  pkgconfig(cynara-session)
38 BuildRequires:  pkgconfig(cynara-creds-dbus)
39
40 %description
41 Bluetooth File Share Agent
42
43 %package -n libbluetooth-share
44 Summary:    Bluetooth share library
45 Group:      Development/Libraries
46 Requires:   %{name} = %{version}-%{release}
47
48 %description -n libbluetooth-share
49 Bluetooth share library
50
51 %package -n libbluetooth-share-devel
52 Summary:    Development package for libbluetooth-share
53 Group:      Development/Libraries
54 Requires:   %{name} = %{version}-%{release}
55
56 %description -n libbluetooth-share-devel
57 Development package for libbluetooth-share
58
59 %prep
60 %setup -q
61 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} .
62
63 %build
64 export CFLAGS+=" -fpie -fvisibility=hidden"
65 export LDFLAGS+=" -Wl,--rpath=/usr/%{_libdir} -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
66
67 %cmake . \
68         -DTZ_SYS_ETC=%{TZ_SYS_ETC}
69 make
70
71 %install
72 %make_install
73 mkdir -p  %{buildroot}%{TZ_SYS_SHARE}/bt-ftp
74 install -D -m 0755 %{SOURCE1004} %{buildroot}%{TZ_SYS_SHARE}/%{name}/ressources/init_db.sh
75
76 %post -n libbluetooth-share-devel -p /sbin/ldconfig
77
78 %post -n libbluetooth-share -p /sbin/ldconfig
79
80 %postun -n libbluetooth-share-devel -p /sbin/ldconfig
81
82 %postun -n libbluetooth-share -p /sbin/ldconfig
83
84 %files
85 %manifest %{name}.manifest
86 %defattr(-,root,root,-)
87 %{_bindir}/bluetooth-share
88 %{_datadir}/dbus-1/system-services/org.bluetooth.share.service
89 %{TZ_SYS_SHARE}/bt-ftp
90 %{TZ_SYS_SHARE}/%{name}
91
92 %files -n libbluetooth-share
93 %manifest libbluetooth-share.manifest
94 %defattr(-, root, root)
95 %{_libdir}/libbluetooth-share-api.so.0.*
96
97 %files -n libbluetooth-share-devel
98 %manifest libbluetooth-share-devel.manifest
99 %defattr(-, root, root)
100 %{_includedir}/bluetooth-share-api/bluetooth-share-api.h
101 %{_libdir}/libbluetooth-share-api.so
102 %{_libdir}/pkgconfig/bluetooth-share-api.pc