Add rule file in accesses.d folder
[platform/core/connectivity/bluetooth-share.git] / packaging / bluetooth-share.spec
1 %define _optdir /opt
2
3 Name:       bluetooth-share
4 Summary:    Bluetooth file share Agent
5 Version:    0.0.47
6 Release:    2
7 Group:      TO_BE/FILLED_IN
8 License:    Apache License, Version 2.0
9 Source0:    %{name}-%{version}.tar.gz
10 Requires(post): vconf
11 Requires(post): coreutils
12 Requires(post): sqlite
13 Requires(post): smack-utils
14 BuildRequires:  cmake
15 BuildRequires:  gettext-tools
16 BuildRequires:  pkgconfig(appcore-efl)
17 BuildRequires:  pkgconfig(bluetooth-api)
18 BuildRequires:  pkgconfig(glib-2.0)
19 BuildRequires:  pkgconfig(aul)
20 BuildRequires:  pkgconfig(dlog)
21 BuildRequires:  pkgconfig(calendar-service2)
22 BuildRequires:  pkgconfig(contacts-service2)
23 BuildRequires:  pkgconfig(vconf)
24 BuildRequires:  pkgconfig(syspopup-caller)
25 BuildRequires:  pkgconfig(pmapi)
26 BuildRequires:  pkgconfig(sysman)
27 BuildRequires:  pkgconfig(notification)
28 BuildRequires:  pkgconfig(appsvc)
29 BuildRequires:  pkgconfig(db-util)
30 BuildRequires:  pkgconfig(libprivilege-control)
31 BuildRequires:  pkgconfig(capi-content-media-content)
32
33 %description
34 Bluetooth File Share Agent
35
36 %package -n libbluetooth-share
37 Summary:    Bluetooth share library
38 Group:      Development/Libraries
39 Requires:   %{name} = %{version}-%{release}
40
41 %description -n libbluetooth-share
42 Bluetooth share library
43
44 %package -n libbluetooth-share-devel
45 Summary:    Development package for libbluetooth-share
46 Group:      Development/Libraries
47 Requires:   %{name} = %{version}-%{release}
48
49 %description -n libbluetooth-share-devel
50 Development package for libbluetooth-share
51
52 %prep
53 %setup -q
54
55 %build
56 export CFLAGS+=" -fpie -fvisibility=hidden"
57 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
58
59 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
60 make
61
62 %install
63 rm -rf %{buildroot}
64 %make_install
65 mkdir -p  %{buildroot}%{_optdir}/share/bt-ftp
66
67 %post
68 # For the FTP server folder
69 if  [ ! -e /opt/share/bt-ftp ]
70 then
71         mkdir -p  /opt/share/bt-ftp
72 fi
73
74 if  [ ! -e /opt/share/bt-ftp/Media ]
75 then
76         ln -s /opt/usr/media /opt/share/bt-ftp/Media
77 fi
78
79 if  [ ! -e /opt/share/bt-ftp/SD_External ]
80 then
81         ln -s /opt/storage/sdcard /opt/share/bt-ftp/SD_External
82 fi
83
84 if [ ! -f /opt/usr/dbspace/.bluetooth_trasnfer.db ]
85 then
86         sqlite3 /opt/usr/dbspace/.bluetooth_trasnfer.db 'PRAGMA journal_mode = PERSIST;
87         create table if not exists inbound (
88                 id INTEGER PRIMARY KEY autoincrement,
89                 sid INTEGER,
90                 tr_status INTEGER,
91                 file_path TEXT,
92                 dev_name TEXT,
93                 timestamp INTEGER default 0,
94                 addr TEXT,
95                 type TEXT,
96                 content TEXT
97         );
98         create table if not exists outbound (
99                 id INTEGER PRIMARY KEY autoincrement,
100                 sid INTEGER,
101                 tr_status INTEGER,
102                 file_path TEXT,
103                 dev_name TEXT,
104                 timestamp INTEGER default 0,
105                 addr TEXT,
106                 type TEXT,
107                 content TEXT
108         );
109         '
110 fi
111
112 chown :5000 /opt/usr/dbspace/.bluetooth_trasnfer.db
113 chown :5000 /opt/usr/dbspace/.bluetooth_trasnfer.db-journal
114 chmod 660 /opt/usr/dbspace/.bluetooth_trasnfer.db
115 chmod 660 /opt/usr/dbspace/.bluetooth_trasnfer.db-journal
116
117 if [ -f /usr/lib/rpm-plugins/msm.so ]
118 then
119 chsmack -a 'bt_share::db' /opt/usr/dbspace/.bluetooth_trasnfer.db
120 chsmack -a 'bt_share::db' /opt/usr/dbspace/.bluetooth_trasnfer.db-journal
121 fi
122
123 %files
124 %manifest bluetooth-share.manifest
125 /opt/etc/smack/accesses.d/bluetooth-share.rule
126 %defattr(-,root,root,-)
127 %{_bindir}/bluetooth-share
128 %{_datadir}/dbus-1/services/org.bluetooth.share.service
129 %{_optdir}/share/bt-ftp
130
131 %files -n libbluetooth-share
132 %defattr(-, root, root)
133 %{_libdir}/libbluetooth-share-api.so.0.*
134
135 %files -n libbluetooth-share-devel
136 %defattr(-, root, root)
137 /usr/include/bluetooth-share-api/bluetooth-share-api.h
138 %{_libdir}/libbluetooth-share-api.so
139 %{_libdir}/pkgconfig/bluetooth-share-api.pc