Initial Import
[profile/ivi/bluetooth-qt.git] / packaging / bluetooth-qt.spec
1 %define buildwayland 1 
2 %if %{buildwayland}
3 %define backend -wayland
4 %else
5 %define backend -xlib
6 %endif
7
8 Name:       bluetooth-qt%{backend}
9 Summary:    Library for accessing bluetooth functionality in Qt
10 Version:    0.1.0
11 Release:    1
12 Group:      System/GUI/Other
13 License:    Apache License 2.0
14 Source0:    bluetooth-qt-%{version}.tar.bz2
15 Patch0:     bmc20660.patch
16 Requires(post): /sbin/ldconfig
17 Requires(postun): /sbin/ldconfig
18 BuildRequires:  pkgconfig(QtCore%{backend})
19 BuildRequires:  pkgconfig(QtDBus%{backend})
20 BuildRequires:  pkgconfig(QtOpenGL%{backend})
21 BuildRequires:  pkgconfig(QtGui%{backend})
22 BuildRequires:  pkgconfig(dbus-1)
23 BuildRequires:  doxygen
24
25
26 %description
27 This is a library for accessing bluetooth through bluez functionality in Qt.
28
29
30
31 %package devel
32 Summary:    Development files for bluetooth-qt
33 Group:      Development/Libraries
34 Requires:   %{name} = %{version}-%{release}
35
36 %description devel
37 This package contains the files necessary to develop
38 applications using qt to access bluetooth devices using bluez
39
40
41
42 %prep
43 %setup -q -n bluetooth-qt-%{version}
44
45 # bmc20660.patch
46 %patch0 -p1
47 # >> setup
48 # << setup
49
50 %build
51 # >> build pre
52 qmake install_prefix=/usr
53 # << build pre
54
55
56 make %{?jobs:-j%jobs}
57
58 # >> build post
59 # << build post
60 %install
61 rm -rf %{buildroot}
62 # >> install pre
63 # << install pre
64 %make_install
65
66 # >> install post
67 # << install post
68
69
70
71 %post -p /sbin/ldconfig
72
73 %postun -p /sbin/ldconfig
74
75
76
77
78
79 %files
80 %defattr(-,root,root,-)
81 %{_libdir}/libbluetooth-qt.so.*
82 %{_libdir}/qt4/imports/Tizen/Bluetooth/*
83 /etc/dbus-1/system.d/bluetooth-qt.conf
84 # >> files
85 # << files
86
87
88 %files devel
89 %defattr(-,root,root,-)
90 %{_includedir}/bluetooth-qt/*.h
91 %{_libdir}/libbluetooth-qt.so
92 %{_libdir}/*.prl
93 %{_libdir}/pkgconfig/*.pc
94 %{_libdir}/*.pc
95 # >> files devel
96 # << files devel
97