Merge tizen_next codes into tizen branch
[platform/core/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
1 # Do not create provides from emulator .so files because the main package
2 # should anchor any reverse-dependencies
3 %global __provides_exclude_from ^(.*\\.emulator)$
4
5 %bcond_with x
6 %define _dumpdir /opt/etc/dump.d/module.d
7 %define _varlibdir /opt/var/lib
8
9 Name:       bluetooth-frwk
10 Summary:    Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
11 Version:    0.3.0
12 Release:    1
13 Group:      Network & Connectivity/Bluetooth
14 License:    Apache-2.0
15 Source0:    %{name}-%{version}.tar.gz
16 Source1001: bluetooth-frwk.manifest
17
18 Requires: bluetooth-tools
19
20 %define bt_bluez_hal ENABLED
21
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(glib-2.0)
25 BuildRequires:  pkgconfig(gio-2.0)
26 BuildRequires:  pkgconfig(gio-unix-2.0)
27 BuildRequires:  pkgconfig(syspopup-caller)
28 BuildRequires:  pkgconfig(vconf)
29 BuildRequires:  pkgconfig(libxml-2.0)
30 BuildRequires:  pkgconfig(capi-network-connection)
31 BuildRequires:  pkgconfig(alarm-service)
32 BuildRequires:  pkgconfig(capi-content-mime-type)
33 BuildRequires:  pkgconfig(pkgmgr)
34 #BuildRequires:  pkgconfig(journal)
35 BuildRequires:  pkgconfig(eventsystem)
36 BuildRequires:  pkgconfig(libsoup-2.4)
37 BuildRequires:  pkgconfig(capi-network-tethering)
38 BuildRequires:  cmake
39 BuildRequires:  pkgconfig(cynara-client)
40 BuildRequires:  pkgconfig(cynara-creds-gdbus)
41 BuildRequires:  pkgconfig(libtzplatform-config)
42 BuildRequires:  pkgconfig(storage)
43 BuildRequires:  pkgconfig(capi-system-info)
44 BuildRequires:  pkgconfig(capi-appfw-app-control)
45
46 Requires(post): /usr/bin/vconftool
47 Requires(post): /sbin/ldconfig
48 Requires(postun): /sbin/ldconfig
49
50 %description
51 Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
52  This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
53
54 %package profile_common
55 Summary:    bluetooth-frwk service and conf files for common profile
56 Requires:   %{name} = %{version}-%{release}
57 Conflicts:  %{name}-profile_mobile
58 Conflicts:  %{name}-profile_wearable
59 Conflicts:  %{name}-profile_tv
60 Conflicts:  %{name}-profile_ivi
61 %description profile_common
62 Bluetooth framework configuration and service files for Tizen common profile
63
64 %package profile_mobile
65 Summary:    bluetooth-frwk service and conf files for mobile profile
66 Requires:   %{name} = %{version}-%{release}
67 Conflicts:  %{name}-profile_common
68 Conflicts:  %{name}-profile_wearable
69 Conflicts:  %{name}-profile_tv
70 Conflicts:  %{name}-profile_ivi
71 %description profile_mobile
72 Bluetooth framework configuration and service files for Tizen mobile profile
73
74 # extension-TM1
75 %ifarch %{ix86} || %{arm}
76 %package extension-TM1
77 Summary:    bluetooth-frwk service and conf files for mobile TM1
78 Requires:   %{name}-profile_mobile = %{version}-%{release}
79 %description extension-TM1
80 Bluetooth framework configuration and service files for Tizen mobile TM1
81 %endif
82
83 %package profile_wearable
84 Summary:    bluetooth-frwk service and conf files for wearable profile
85 Requires:   %{name} = %{version}-%{release}
86 Conflicts:  %{name}-profile_mobile
87 Conflicts:  %{name}-profile_common
88 Conflicts:  %{name}-profile_tv
89 Conflicts:  %{name}-profile_ivi
90 %description profile_wearable
91 Bluetooth framework configuration and service files for Tizen wearable profile
92
93 %package profile_tv
94 Summary:    bluetooth-frwk service and conf files for tv profile
95 Requires:   %{name} = %{version}-%{release}
96 Conflicts:  %{name}-profile_mobile
97 Conflicts:  %{name}-profile_wearable
98 Conflicts:  %{name}-profile_common
99 Conflicts:  %{name}-profile_ivi
100 %description profile_tv
101 Bluetooth framework configuration and service files for Tizen tv profile
102
103 %package profile_ivi
104 Summary:    bluetooth-frwk service and conf files for ivi profile
105 Requires:   %{name} = %{version}-%{release}
106 Conflicts:  %{name}-profile_mobile
107 Conflicts:  %{name}-profile_wearable
108 Conflicts:  %{name}-profile_tv
109 Conflicts:  %{name}-profile_common
110 %description profile_ivi
111 Bluetooth framework configuration and service files for Tizen ivi profile
112
113 %ifarch %{ix86} x86_64
114 %package extension-emulator
115 Summary:    bluetooth-frwk service and conf files for emulator
116 Requires:   %{name} = %{version}-%{release}
117 %description extension-emulator
118 bluetooth-frwk service and conf files for emulator
119 %endif // ifarch %{ix86} x86_64
120
121 %package devel
122 Summary:    Bluetooth framework for BlueZ and Obexd
123 Group:      Development/Libraries
124 Requires:   %{name} = %{version}-%{release}
125
126 %description devel
127 This package is development files for Bluetooth framework based on BlueZ and Obexd stack.
128 This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
129
130 %package service
131 Summary:    Bluetooth Service daemon
132 Group:      Network & Connectivity/Bluetooth
133 Requires:   %{name} = %{version}-%{release}
134
135 %description service
136 This package is Bluetooth Service daemon to manage BT services.
137
138 %package httpproxy
139 Summary:    Bluetooth HTTP Proxy Service daemon
140 Group:      Network & Connectivity/Bluetooth
141 Requires:   %{name} = %{version}-%{release}
142
143 %description httpproxy
144 This package is Bluetooth HTTP Proxy Service daemon
145
146 %package otp
147 Summary:    Bluetooth OTP Service daemon
148 Group:      Network & Connectivity/Bluetooth
149 Requires:   %{name} = %{version}-%{release}
150
151 %description otp
152 This package is Bluetooth OTP Service daemon
153
154 %package core
155 Summary:    Bluetooth Core daemon
156 Group:      Network & Connectivity/Bluetooth
157 Requires:   %{name} = %{version}-%{release}
158
159 %description core
160 This package is Bluetooth core daemon to manage activation / deactivation.
161
162 %package test
163 Summary:    Bluetooth test application
164 Group:      Network & Connectivity/Bluetooth
165 Requires:   %{name} = %{version}-%{release}
166
167 %description test
168 This package is Bluetooth test application.
169
170 %package oal
171 Summary:    Bluetooth OAL
172 Group:      Network & Connectivity/Bluetooth
173 Requires:   %{name} = %{version}-%{release}
174
175 %description oal
176 This package is BT stack common interface.
177
178 %package plugin-headed
179 Summary:    Bluetooth plugin Headed
180 Group:      Network & Connectivity/Bluetooth
181 Requires:   %{name} = %{version}-%{release}
182
183 %description plugin-headed
184 This package is Bluetooth plugin to manage UI and syspopup
185
186 %prep
187 %setup -q
188 cp %{SOURCE1001} .
189
190
191 %build
192 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
193 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_OBEX"
194 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_PAN_NAP"
195 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_IPSP"
196 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
197 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
198
199 %define _servicefile packaging/bluetooth-frwk-common.service
200 %define _servicedir starter.target.wants
201
202 %if "%{?profile}" == "mobile"
203 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_NETWORK_TETHERING_ENABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED -DTIZEN_PROFILE_MOBILE -DTIZEN_FEATURE_TELEPHONY_ENABLED"
204 %if "%{?tizen_target_name}" == "TM1"
205 %define _servicefile packaging/bluetooth-frwk-mobile-sprd.service
206 %else
207 %define _servicefile packaging/bluetooth-frwk-mobile.service
208 %endif
209 %define _servicedir multi-user.target.wants
210 %endif
211
212 %if "%{?profile}" == "wearable"
213 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_WEARABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED"
214 %define _servicefile packaging/bluetooth-frwk-wearable.service
215 %define _servicedir multi-user.target.wants
216 %endif
217
218 %if "%{?profile}" == "tv"
219 export CFLAGS="$CFLAGS -DUSB_BLUETOOTH -DTIZEN_TV -DAUTO_ACCEPT"
220 %define _servicefile packaging/bluetooth-frwk-tv.service
221 %define _servicedir multi-user.target.wants
222 %endif
223
224 %if "%{?profile}" == "ivi"
225 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_IVI"
226 %define _servicefile packaging/bluetooth-frwk-wearable.service
227 %define _servicedir multi-user.target.wants
228 %endif
229
230 %ifarch x86_64
231 export CFLAGS="$CFLAGS -Wall -g -fvisibility=hidden -fPIC"
232 export CFLAGS+=" -DARCH64"
233 export CXXFLAGS+=" -DARCH64"
234 export FFLAGS+=" -DARCH64"
235 %else
236 export CFLAGS="$CFLAGS -fpie"
237 export LDFLAGS="$CFLAGS -pie"
238 %endif
239
240 %if %{bt_bluez_hal} == ENABLED
241 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT -DTIZEN_BT_HAL"
242 %else
243 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
244 %endif
245 export LDFLAGS="$CFLAGS -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs"
246
247 %ifarch %{ix86} x86_64
248 export CFLAGS+=" -DTIZEN_TEST_EMUL"
249 export CXXFLAGS+=" -DTIZEN_TEST_EMUL"
250 export FFLAGS+=" -DTIZEN_TEST_EMUL"
251 %endif
252
253 %if %{bt_bluez_hal} == ENABLED
254 export BT_INCLUDE_OAL_BLUEZ=ENABLED
255 export CFLAGS="$CFLAGS -DTIZEN_BT_INCLUDE_OAL_BLUEZ"
256 %else
257 export BT_INCLUDE_OAL_BLUEZ=DISABLED
258 %endif
259
260 export CFLAGS_DEFAULT="$CFLAGS"
261 export CXXFLAGS_DEFAULT="$CXXFLAGS"
262 export FFLAGS_DEFAULT="$FFLAGS"
263
264 # extension-TM1
265 %ifarch %{ix86} || %{arm}
266 mkdir -p tm1
267 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
268 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
269 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
270
271 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
272 -DCMAKE_LIB_DIR=%{_libdir} \
273 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
274 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
275         -DLIBNOTIFY_SUPPORT=Off \
276         -DLIBNOTIFICATION_SUPPORT=Off
277 make
278
279 %cmake
280
281 %make_install
282 cp %{buildroot}%{_bindir}/bt-core tm1/bt-core.tm1
283 %endif
284
285 # extension-emulator
286 %ifarch %{ix86} x86_64
287 export CFLAGS="${CFLAGS_BASE} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
288 export CXXFLAGS="${CXXFLAGS_BASE} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
289 export FFLAGS="${FFLAGS_BASE} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
290
291 mkdir -p build_emulator
292
293 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
294 -DCMAKE_LIB_DIR=%{_libdir} \
295 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
296 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
297         -DLIBNOTIFY_SUPPORT=Off \
298         -DLIBNOTIFICATION_SUPPORT=Off
299 make
300
301 %cmake
302
303 %make_install
304 cp %{buildroot}%{_libdir}/libbluetooth-api.so* build_emulator/
305 pushd build_emulator/
306 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
307 popd
308 %endif
309
310 # non-extension-TM1 / non-extension-emulator
311
312 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
313 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
314 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
315
316 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
317 -DCMAKE_LIB_DIR=%{_libdir} \
318 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
319 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
320         -DLIBNOTIFY_SUPPORT=Off \
321         -DLIBNOTIFICATION_SUPPORT=Off
322 make
323
324 %cmake
325
326 %install
327 rm -rf %{buildroot}
328 %make_install
329
330 mkdir -p %{buildroot}%{_unitdir}/starter.target.wants
331 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
332
333 # extension-emulator
334 %ifarch %{ix86} x86_64
335 cp build_emulator/libbluetooth-api.so*.emulator %{buildroot}%{_libdir}/
336 mv %{buildroot}/%{_bindir}/bt-service-emul %{buildroot}/%{_bindir}/bt-service
337 %endif
338
339 # Rename the postfix (.mobile, .tv, ..) at post script
340 # mobile
341 install -m 0644 packaging/bluetooth-frwk-mobile.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.mobile
342
343 # extension-TM1
344 %ifarch %{ix86} || %{arm}
345 cp tm1/bt-core.tm1 %{buildroot}%{_bindir}/
346 install -m 0644 packaging/bluetooth-frwk-mobile-sprd.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tm1
347 %endif
348
349 # wearable / ivi
350 install -m 0644 packaging/bluetooth-frwk-wearable.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.wearable
351 # On IVI bt-service needs to be run as 'app' even if there is a 'guest' user.
352 cp %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
353 sed -i 's/%TZ_SYS_DEFAULT_USER/app/' %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
354
355 # tv
356 install -m 0644 packaging/bluetooth-frwk-tv.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tv
357
358 # common
359 install -m 0644 packaging/bluetooth-frwk-common.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.common
360
361 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
362 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/starter.target.wants/bluetooth-frwk.service
363
364 %postun -p /sbin/ldconfig
365
366 %post service
367 /usr/bin/chsmack -a '_' %{_varlibdir}/bluetooth/auto-pair-blacklist
368 /usr/bin/chown 5001:100 %{_varlibdir}/bluetooth/auto-pair-blacklist
369
370 %files
371 %manifest %{name}.manifest
372 %license LICENSE
373 %defattr(-, root, root)
374 %{_libdir}/libbluetooth-api.so.*
375 %exclude %{_libdir}/libbluetooth-api.so*.emulator
376
377 %files devel
378 %defattr(-, root, root)
379 %{_includedir}/bt-service/bluetooth-api.h
380 %{_includedir}/bt-service/bluetooth-hid-api.h
381 %{_includedir}/bt-service/bluetooth-audio-api.h
382 %{_includedir}/bt-service/bluetooth-telephony-api.h
383 %{_includedir}/bt-service/bluetooth-media-control.h
384 %{_includedir}/bt-service/bluetooth-scmst-api.h
385 %{_includedir}/bt-service/bluetooth-ipsp-api.h
386 %{_includedir}/bt-service/bluetooth-gatt-server-api.h
387 %{_libdir}/pkgconfig/bluetooth-api.pc
388 %{_libdir}/libbluetooth-api.so
389
390 # extension-emulator
391 %ifarch %{ix86} x86_64
392 %post extension-emulator
393 pushd %{_libdir}
394 for FILE in libbluetooth-api.so*.emulator; do mv "${FILE}" "${FILE%.emulator}"; done
395 popd
396 %preun extension-emulator
397 pushd %{_libdir}
398 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
399 popd
400 %files extension-emulator
401 %manifest %{name}.manifest
402 %defattr(-, root, root)
403 %{_libdir}/libbluetooth-api.so.*.emulator
404 %{_libdir}/libbluetooth-api.so.emulator
405 %endif
406
407 %files service
408 %manifest %{name}.manifest
409 %license LICENSE
410 %defattr(-, root, root)
411 %{_bindir}/bt-service
412 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-service.conf
413 %{_bindir}/bluetooth-frwk-test
414 %{_varlibdir}/bluetooth
415 %{_prefix}/etc/bluetooth
416 %attr(-,owner,users) %{_varlibdir}/bluetooth/auto-pair-blacklist
417
418 %files httpproxy
419 %manifest %{name}.manifest
420 %license LICENSE
421 %defattr(-, root, root)
422 %{_bindir}/bt-httpproxy
423 %{_datadir}/dbus-1/system-services/org.projectx.httpproxy.service
424 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-httpproxy.conf
425
426
427 %files otp
428 %manifest %{name}.manifest
429 %license LICENSE
430 %defattr(-, root, root)
431 %{_bindir}/bt-otp
432 %{_datadir}/dbus-1/system-services/org.projectx.otp.service
433 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-otp.conf
434
435 %files core
436 %manifest %{name}.manifest
437 %license LICENSE
438 %defattr(-, root, root)
439 %{_datadir}/dbus-1/system-services/org.projectx.bt_core.service
440 %{_bindir}/bt-core
441 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-core.conf
442
443 %files test
444 %manifest %{name}.manifest
445 %license LICENSE
446 %defattr(-, root, root)
447 %{_bindir}/bluetooth-frwk-test
448 #%{_bindir}/bluetooth-gatt-test
449 #%{_bindir}/bluetooth-advertising-test
450
451 %files plugin-headed
452 %manifest %{name}.manifest
453 %license LICENSE
454 %defattr(-, root, root)
455 %{_libdir}/bt-plugin-headed.so
456
457 %post profile_common
458 pushd %{_unitdir}
459 mv bluetooth-frwk.service.common bluetooth-frwk.service
460 popd
461 %preun profile_common
462 pushd %{_unitdir}
463 mv bluetooth-frwk.service bluetooth-frwk.service.common
464 popd
465 %files profile_common
466 %license LICENSE
467 %{_unitdir}/starter.target.wants/bluetooth-frwk.service
468 %{_unitdir}/bluetooth-frwk.service.common
469 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
470
471 %post profile_mobile
472 pushd %{_unitdir}
473 mv bluetooth-frwk.service.mobile bluetooth-frwk.service
474 popd
475 %preun profile_mobile
476 pushd %{_unitdir}
477 mv bluetooth-frwk.service bluetooth-frwk.service.mobile
478 popd
479 %files profile_mobile
480 %license LICENSE
481 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
482 %{_unitdir}/bluetooth-frwk.service.mobile
483 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
484
485 # extension-TM1
486 %ifarch %{ix86} || %{arm}
487 %post extension-TM1
488 pushd %{_unitdir}
489 mv bluetooth-frwk.service.tm1 bluetooth-frwk.service
490 popd
491 pushd %{_bindir}
492 mv bt-core.tm1 bt-core
493 popd
494 %preun extension-TM1
495 pushd %{_unitdir}
496 mv bluetooth-frwk.service bluetooth-frwk.service.tm1
497 popd
498 pushd %{_bindir}
499 mv bt-core bt-core.tm1
500 popd
501 %files extension-TM1
502 %{_unitdir}/bluetooth-frwk.service.tm1
503 %license LICENSE
504 %defattr(-, root, root)
505 %{_bindir}/bt-core.tm1
506 %endif
507
508 %post profile_wearable
509 pushd %{_unitdir}
510 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
511 popd
512 %preun profile_wearable
513 pushd %{_unitdir}
514 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
515 popd
516 %files profile_wearable
517 %license LICENSE
518 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
519 %{_unitdir}/bluetooth-frwk.service.wearable
520 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
521
522 %post profile_tv
523 pushd %{_unitdir}
524 mv bluetooth-frwk.service.tv bluetooth-frwk.service
525 popd
526 %preun profile_tv
527 pushd %{_unitdir}
528 mv bluetooth-frwk.service bluetooth-frwk.service.tv
529 popd
530 %files profile_tv
531 %license LICENSE
532 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
533 %{_unitdir}/bluetooth-frwk.service.tv
534 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
535
536 # Note: ivi reuses bluetooth-frwk.service.wearable
537 %post profile_ivi
538 pushd %{_unitdir}
539 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
540 popd
541 pushd %{_datadir}/dbus-1/system-services
542 mv org.projectx.bt.service.ivi org.projectx.bt.service
543 popd
544 %preun profile_ivi
545 pushd %{_unitdir}
546 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
547 popd
548 pushd %{_datadir}/dbus-1/system-services
549 mv org.projectx.bt.service org.projectx.bt.service.ivi
550 popd
551 %files profile_ivi
552 %license LICENSE
553 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
554 %{_unitdir}/bluetooth-frwk.service.wearable
555 %{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
556
557 %files oal
558 %manifest %{name}.manifest
559 %{_libdir}/libbt-oal.so*
560
561 %if %{bt_bluez_hal} == ENABLED
562 %manifest %{name}.manifest
563 %{_libdir}/libbluetooth.default.so*
564 %endif