[Bluetooth-OAL] Jira issue : TFIVE-26
[platform/core/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
1 # Do not create provides from emulator .so files because the main package
2 # should anchor any reverse-dependencies
3 %global __provides_exclude_from ^(.*\\.emulator)$
4
5 %bcond_with x
6 %define _dumpdir /opt/etc/dump.d/module.d
7 %define _varlibdir /opt/var/lib
8
9 Name:       bluetooth-frwk
10 Summary:    Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
11 Version:    0.3.0
12 Release:    1
13 Group:      Network & Connectivity/Bluetooth
14 License:    Apache-2.0
15 Source0:    %{name}-%{version}.tar.gz
16 Source1001: bluetooth-frwk.manifest
17
18 Requires: bluetooth-tools
19
20 %define bt_bluez_hal ENABLED
21
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(glib-2.0)
25 BuildRequires:  pkgconfig(gio-2.0)
26 BuildRequires:  pkgconfig(gio-unix-2.0)
27 BuildRequires:  pkgconfig(syspopup-caller)
28 BuildRequires:  pkgconfig(vconf)
29 BuildRequires:  pkgconfig(libxml-2.0)
30 BuildRequires:  pkgconfig(capi-network-connection)
31 BuildRequires:  pkgconfig(alarm-service)
32 BuildRequires:  pkgconfig(capi-content-mime-type)
33 BuildRequires:  pkgconfig(pkgmgr)
34 #BuildRequires:  pkgconfig(journal)
35 BuildRequires:  pkgconfig(eventsystem)
36 BuildRequires:  pkgconfig(libsoup-2.4)
37 BuildRequires:  pkgconfig(capi-network-tethering)
38 BuildRequires:  cmake
39 BuildRequires:  pkgconfig(cynara-client)
40 BuildRequires:  pkgconfig(cynara-creds-gdbus)
41 BuildRequires:  pkgconfig(libtzplatform-config)
42 BuildRequires:  pkgconfig(storage)
43 BuildRequires:  pkgconfig(capi-system-info)
44 BuildRequires:  pkgconfig(capi-appfw-app-control)
45
46 Requires(post): /usr/bin/vconftool
47 Requires(post): /sbin/ldconfig
48 Requires(postun): /sbin/ldconfig
49
50 %description
51 Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
52  This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
53
54 %package profile_common
55 Summary:    bluetooth-frwk service and conf files for common profile
56 Requires:   %{name} = %{version}-%{release}
57 Conflicts:  %{name}-profile_mobile
58 Conflicts:  %{name}-profile_wearable
59 Conflicts:  %{name}-profile_tv
60 Conflicts:  %{name}-profile_ivi
61 %description profile_common
62 Bluetooth framework configuration and service files for Tizen common profile
63
64 %package profile_mobile
65 Summary:    bluetooth-frwk service and conf files for mobile profile
66 Requires:   %{name} = %{version}-%{release}
67 Conflicts:  %{name}-profile_common
68 Conflicts:  %{name}-profile_wearable
69 Conflicts:  %{name}-profile_tv
70 Conflicts:  %{name}-profile_ivi
71 %description profile_mobile
72 Bluetooth framework configuration and service files for Tizen mobile profile
73
74 # extension-TM1
75 %ifarch %{ix86} || %{arm}
76 %package extension-TM1
77 Summary:    bluetooth-frwk service and conf files for mobile TM1
78 Requires:   %{name}-profile_mobile = %{version}-%{release}
79 %description extension-TM1
80 Bluetooth framework configuration and service files for Tizen mobile TM1
81 %endif
82
83 %package profile_wearable
84 Summary:    bluetooth-frwk service and conf files for wearable profile
85 Requires:   %{name} = %{version}-%{release}
86 Conflicts:  %{name}-profile_mobile
87 Conflicts:  %{name}-profile_common
88 Conflicts:  %{name}-profile_tv
89 Conflicts:  %{name}-profile_ivi
90 %description profile_wearable
91 Bluetooth framework configuration and service files for Tizen wearable profile
92
93 %package profile_tv
94 Summary:    bluetooth-frwk service and conf files for tv profile
95 Requires:   %{name} = %{version}-%{release}
96 Conflicts:  %{name}-profile_mobile
97 Conflicts:  %{name}-profile_wearable
98 Conflicts:  %{name}-profile_common
99 Conflicts:  %{name}-profile_ivi
100 %description profile_tv
101 Bluetooth framework configuration and service files for Tizen tv profile
102
103 %package profile_ivi
104 Summary:    bluetooth-frwk service and conf files for ivi profile
105 Requires:   %{name} = %{version}-%{release}
106 Conflicts:  %{name}-profile_mobile
107 Conflicts:  %{name}-profile_wearable
108 Conflicts:  %{name}-profile_tv
109 Conflicts:  %{name}-profile_common
110 %description profile_ivi
111 Bluetooth framework configuration and service files for Tizen ivi profile
112
113 %ifarch %{ix86} x86_64
114 %package extension-emulator
115 Summary:    bluetooth-frwk service and conf files for emulator
116 Requires:   %{name} = %{version}-%{release}
117 %description extension-emulator
118 bluetooth-frwk service and conf files for emulator
119 %endif // ifarch %{ix86} x86_64
120
121 %package devel
122 Summary:    Bluetooth framework for BlueZ and Obexd
123 Group:      Development/Libraries
124 Requires:   %{name} = %{version}-%{release}
125
126 %description devel
127 This package is development files for Bluetooth framework based on BlueZ and Obexd stack.
128 This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
129
130 %package service
131 Summary:    Bluetooth Service daemon
132 Group:      Network & Connectivity/Bluetooth
133 Requires:   %{name} = %{version}-%{release}
134
135 %description service
136 This package is Bluetooth Service daemon to manage BT services.
137
138 %package httpproxy
139 Summary:    Bluetooth HTTP Proxy Service daemon
140 Group:      Network & Connectivity/Bluetooth
141 Requires:   %{name} = %{version}-%{release}
142
143 %description httpproxy
144 This package is Bluetooth HTTP Proxy Service daemon
145
146 %package otp
147 Summary:    Bluetooth OTP Service daemon
148 Group:      Network & Connectivity/Bluetooth
149 Requires:   %{name} = %{version}-%{release}
150
151 %description otp
152 This package is Bluetooth OTP Service daemon
153
154 %package core
155 Summary:    Bluetooth Core daemon
156 Group:      Network & Connectivity/Bluetooth
157 Requires:   %{name} = %{version}-%{release}
158
159 %description core
160 This package is Bluetooth core daemon to manage activation / deactivation.
161
162 %package test
163 Summary:    Bluetooth test application
164 Group:      Network & Connectivity/Bluetooth
165 Requires:   %{name} = %{version}-%{release}
166
167 %description test
168 This package is Bluetooth test application.
169
170 %package oal
171 Summary:    Bluetooth OAL
172 Group:      Network & Connectivity/Bluetooth
173 Requires:   %{name} = %{version}-%{release}
174
175 %description oal
176 This package is BT stack common interface.
177
178 %package plugin-headed
179 Summary:    Bluetooth plugin Headed
180 Group:      Network & Connectivity/Bluetooth
181 Requires:   %{name} = %{version}-%{release}
182
183 %description plugin-headed
184 This package is Bluetooth plugin to manage UI and syspopup
185
186 %prep
187 %setup -q
188 cp %{SOURCE1001} .
189
190
191 %build
192 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
193 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_OBEX"
194 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_PAN_NAP"
195 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_IPSP"
196 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
197 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
198
199 %define _servicefile packaging/bluetooth-frwk-common.service
200 %define _servicedir starter.target.wants
201
202 %if "%{?profile}" == "mobile"
203 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_NETWORK_TETHERING_ENABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED -DTIZEN_PROFILE_MOBILE -DTIZEN_FEATURE_TELEPHONY_ENABLED"
204 %if "%{?tizen_target_name}" == "TM1"
205 %define _servicefile packaging/bluetooth-frwk-mobile-sprd.service
206 %else
207 %define _servicefile packaging/bluetooth-frwk-mobile.service
208 %endif
209 %define _servicedir multi-user.target.wants
210 %endif
211
212 %if "%{?profile}" == "wearable"
213 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_WEARABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED"
214 %define _servicefile packaging/bluetooth-frwk-wearable.service
215 %define _servicedir multi-user.target.wants
216 %endif
217
218 %if "%{?profile}" == "tv"
219 export CFLAGS="$CFLAGS -DUSB_BLUETOOTH -DTIZEN_TV -DAUTO_ACCEPT"
220 %define _servicefile packaging/bluetooth-frwk-tv.service
221 %define _servicedir multi-user.target.wants
222 %endif
223
224 %if "%{?profile}" == "ivi"
225 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_IVI"
226 %define _servicefile packaging/bluetooth-frwk-wearable.service
227 %define _servicedir multi-user.target.wants
228 %endif
229
230 %ifarch x86_64
231 #export CFLAGS="$CFLAGS -Wall -g -fvisibility=hidden -fPIC"
232 export CFLAGS="$CFLAGS -fpie"
233 export CFLAGS+=" -DARCH64"
234 export CXXFLAGS+=" -DARCH64"
235 export FFLAGS+=" -DARCH64"
236 %else
237 export CFLAGS="$CFLAGS -fpie"
238 export LDFLAGS="$CFLAGS -pie"
239 %endif
240
241 %if %{bt_bluez_hal} == ENABLED
242 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT -DTIZEN_BT_HAL"
243 %else
244 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
245 %endif
246 export LDFLAGS="$CFLAGS -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs"
247
248 %ifarch %{ix86} x86_64
249 export CFLAGS+=" -DTIZEN_TEST_EMUL"
250 export CXXFLAGS+=" -DTIZEN_TEST_EMUL"
251 export FFLAGS+=" -DTIZEN_TEST_EMUL"
252 %endif
253
254 %if %{bt_bluez_hal} == ENABLED
255 export BT_INCLUDE_OAL_BLUEZ=ENABLED
256 export CFLAGS="$CFLAGS -DTIZEN_BT_INCLUDE_OAL_BLUEZ"
257 %else
258 export BT_INCLUDE_OAL_BLUEZ=DISABLED
259 %endif
260
261 export CFLAGS_DEFAULT="$CFLAGS"
262 export CXXFLAGS_DEFAULT="$CXXFLAGS"
263 export FFLAGS_DEFAULT="$FFLAGS"
264
265 # extension-TM1
266 %ifarch %{ix86} || %{arm}
267 mkdir -p tm1
268 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
269 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
270 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
271
272 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
273 -DCMAKE_LIB_DIR=%{_libdir} \
274 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
275 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
276         -DLIBNOTIFY_SUPPORT=Off \
277         -DLIBNOTIFICATION_SUPPORT=Off
278 make
279
280 %cmake
281
282 %make_install
283 cp %{buildroot}%{_bindir}/bt-core tm1/bt-core.tm1
284 %endif
285
286 # extension-emulator
287 %ifarch %{ix86} x86_64
288 export CFLAGS="${CFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
289 export CXXFLAGS="${CXXFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
290 export FFLAGS="${FFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
291
292 mkdir -p build_emulator
293
294 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
295 -DCMAKE_LIB_DIR=%{_libdir} \
296 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
297 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
298         -DLIBNOTIFY_SUPPORT=Off \
299         -DLIBNOTIFICATION_SUPPORT=Off
300 make
301
302 %cmake
303
304 %make_install
305 cp %{buildroot}%{_libdir}/libbluetooth-api.so* build_emulator/
306 pushd build_emulator/
307 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
308 popd
309 %endif
310
311 # non-extension-TM1 / non-extension-emulator
312
313 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
314 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
315 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
316
317 %ifarch aarch64
318 echo arch64
319 export CFLAGS+=" -DARCH64"
320 export CXXFLAGS+=" -DARCH64"
321 export FFLAGS+=" -DARCH64"
322 %endif
323
324 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
325 -DCMAKE_LIB_DIR=%{_libdir} \
326 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
327 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
328         -DLIBNOTIFY_SUPPORT=Off \
329         -DLIBNOTIFICATION_SUPPORT=Off
330 make
331
332 %cmake
333
334 %install
335 rm -rf %{buildroot}
336 %make_install
337
338 mkdir -p %{buildroot}%{_unitdir}/starter.target.wants
339 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
340
341 # extension-emulator
342 %ifarch %{ix86} x86_64
343 cp build_emulator/libbluetooth-api.so*.emulator %{buildroot}%{_libdir}/
344 #mv %{buildroot}/%{_bindir}/bt-service-emul %{buildroot}/%{_bindir}/bt-service
345 %endif
346
347 # Rename the postfix (.mobile, .tv, ..) at post script
348 # mobile
349 install -m 0644 packaging/bluetooth-frwk-mobile.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.mobile
350
351 # extension-TM1
352 %ifarch %{ix86} || %{arm}
353 cp tm1/bt-core.tm1 %{buildroot}%{_bindir}/
354 install -m 0644 packaging/bluetooth-frwk-mobile-sprd.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tm1
355 %endif
356
357 # wearable / ivi
358 install -m 0644 packaging/bluetooth-frwk-wearable.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.wearable
359 # On IVI bt-service needs to be run as 'app' even if there is a 'guest' user.
360 cp %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
361 sed -i 's/%TZ_SYS_DEFAULT_USER/app/' %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
362
363 # tv
364 install -m 0644 packaging/bluetooth-frwk-tv.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tv
365
366 # common
367 install -m 0644 packaging/bluetooth-frwk-common.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.common
368
369 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
370 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/starter.target.wants/bluetooth-frwk.service
371
372 %postun -p /sbin/ldconfig
373
374 %post service
375 /usr/bin/chsmack -a '_' %{_varlibdir}/bluetooth/auto-pair-blacklist
376 /usr/bin/chown 5001:100 %{_varlibdir}/bluetooth/auto-pair-blacklist
377
378 %files
379 %manifest %{name}.manifest
380 %license LICENSE
381 %defattr(-, root, root)
382 %{_libdir}/libbluetooth-api.so.*
383 %exclude %{_libdir}/libbluetooth-api.so*.emulator
384
385 %files devel
386 %defattr(-, root, root)
387 %{_includedir}/bt-service/bluetooth-api.h
388 %{_includedir}/bt-service/bluetooth-hid-api.h
389 %{_includedir}/bt-service/bluetooth-audio-api.h
390 %{_includedir}/bt-service/bluetooth-telephony-api.h
391 %{_includedir}/bt-service/bluetooth-media-control.h
392 %{_includedir}/bt-service/bluetooth-scmst-api.h
393 %{_includedir}/bt-service/bluetooth-ipsp-api.h
394 %{_includedir}/bt-service/bluetooth-gatt-server-api.h
395 %{_libdir}/pkgconfig/bluetooth-api.pc
396 %{_libdir}/libbluetooth-api.so
397
398 # extension-emulator
399 %ifarch %{ix86} x86_64
400 %post extension-emulator
401 pushd %{_libdir}
402 for FILE in libbluetooth-api.so*.emulator; do mv "${FILE}" "${FILE%.emulator}"; done
403 popd
404 %preun extension-emulator
405 pushd %{_libdir}
406 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
407 popd
408 %files extension-emulator
409 %manifest %{name}.manifest
410 %defattr(-, root, root)
411 %{_libdir}/libbluetooth-api.so.*.emulator
412 %{_libdir}/libbluetooth-api.so.emulator
413 %endif
414
415 %files service
416 %manifest %{name}.manifest
417 %license LICENSE
418 %defattr(-, root, root)
419 %{_bindir}/bt-service
420 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-service.conf
421 %{_bindir}/bluetooth-frwk-test
422 %{_varlibdir}/bluetooth
423 %{_prefix}/etc/bluetooth
424 %attr(-,owner,users) %{_varlibdir}/bluetooth/auto-pair-blacklist
425
426 %files httpproxy
427 %manifest %{name}.manifest
428 %license LICENSE
429 %defattr(-, root, root)
430 %{_bindir}/bt-httpproxy
431 %{_datadir}/dbus-1/system-services/org.projectx.httpproxy.service
432 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-httpproxy.conf
433
434
435 %files otp
436 %manifest %{name}.manifest
437 %license LICENSE
438 %defattr(-, root, root)
439 %{_bindir}/bt-otp
440 %{_datadir}/dbus-1/system-services/org.projectx.otp.service
441 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-otp.conf
442
443 %files core
444 %manifest %{name}.manifest
445 %license LICENSE
446 %defattr(-, root, root)
447 %{_datadir}/dbus-1/system-services/org.projectx.bt_core.service
448 %{_bindir}/bt-core
449 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-core.conf
450
451 %files test
452 %manifest %{name}.manifest
453 %license LICENSE
454 %defattr(-, root, root)
455 %{_bindir}/bluetooth-frwk-test
456 #%{_bindir}/bluetooth-gatt-test
457 #%{_bindir}/bluetooth-advertising-test
458
459 %files plugin-headed
460 %manifest %{name}.manifest
461 %license LICENSE
462 %defattr(-, root, root)
463 %{_libdir}/bt-plugin-headed.so
464
465 %post profile_common
466 pushd %{_unitdir}
467 mv bluetooth-frwk.service.common bluetooth-frwk.service
468 popd
469 %preun profile_common
470 pushd %{_unitdir}
471 mv bluetooth-frwk.service bluetooth-frwk.service.common
472 popd
473 %files profile_common
474 %license LICENSE
475 %{_unitdir}/starter.target.wants/bluetooth-frwk.service
476 %{_unitdir}/bluetooth-frwk.service.common
477 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
478
479 %post profile_mobile
480 pushd %{_unitdir}
481 mv bluetooth-frwk.service.mobile bluetooth-frwk.service
482 popd
483 %preun profile_mobile
484 pushd %{_unitdir}
485 mv bluetooth-frwk.service bluetooth-frwk.service.mobile
486 popd
487 %files profile_mobile
488 %license LICENSE
489 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
490 %{_unitdir}/bluetooth-frwk.service.mobile
491 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
492
493 # extension-TM1
494 %ifarch %{ix86} || %{arm}
495 %post extension-TM1
496 pushd %{_unitdir}
497 mv bluetooth-frwk.service.tm1 bluetooth-frwk.service
498 popd
499 pushd %{_bindir}
500 mv bt-core.tm1 bt-core
501 popd
502 %preun extension-TM1
503 pushd %{_unitdir}
504 mv bluetooth-frwk.service bluetooth-frwk.service.tm1
505 popd
506 pushd %{_bindir}
507 mv bt-core bt-core.tm1
508 popd
509 %files extension-TM1
510 %{_unitdir}/bluetooth-frwk.service.tm1
511 %license LICENSE
512 %defattr(-, root, root)
513 %{_bindir}/bt-core.tm1
514 %endif
515
516 %post profile_wearable
517 pushd %{_unitdir}
518 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
519 popd
520 %preun profile_wearable
521 pushd %{_unitdir}
522 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
523 popd
524 %files profile_wearable
525 %license LICENSE
526 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
527 %{_unitdir}/bluetooth-frwk.service.wearable
528 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
529
530 %post profile_tv
531 pushd %{_unitdir}
532 mv bluetooth-frwk.service.tv bluetooth-frwk.service
533 popd
534 %preun profile_tv
535 pushd %{_unitdir}
536 mv bluetooth-frwk.service bluetooth-frwk.service.tv
537 popd
538 %files profile_tv
539 %license LICENSE
540 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
541 %{_unitdir}/bluetooth-frwk.service.tv
542 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
543
544 # Note: ivi reuses bluetooth-frwk.service.wearable
545 %post profile_ivi
546 pushd %{_unitdir}
547 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
548 popd
549 pushd %{_datadir}/dbus-1/system-services
550 mv org.projectx.bt.service.ivi org.projectx.bt.service
551 popd
552 %preun profile_ivi
553 pushd %{_unitdir}
554 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
555 popd
556 pushd %{_datadir}/dbus-1/system-services
557 mv org.projectx.bt.service org.projectx.bt.service.ivi
558 popd
559 %files profile_ivi
560 %license LICENSE
561 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
562 %{_unitdir}/bluetooth-frwk.service.wearable
563 %{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
564
565 %files oal
566 %manifest %{name}.manifest
567 %{_libdir}/libbt-oal.so*
568
569 %if %{bt_bluez_hal} == ENABLED
570 %manifest %{name}.manifest
571 %{_libdir}/libbluetooth.default.so*
572 %endif