Describe the license
[framework/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
1 Name:       bluetooth-frwk
2 Summary:    Bluetooth framework for BlueZ This package is Bluetooth framework based on Blue
3 Version:    0.1.21
4 Release:    1
5 Group:      main
6 License:    Apache 2.0 License
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig(aul)
10 BuildRequires:  pkgconfig(contacts-service)
11 BuildRequires:  pkgconfig(dbus-glib-1)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(syspopup-caller)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(libxml-2.0)
17 BuildRequires:  pkgconfig(bluez)
18 BuildRequires:  pkgconfig(dbus-1)
19 BuildRequires:  pkgconfig(appcore-efl)
20 BuildRequires:  pkgconfig(openobex)
21 BuildRequires:  cmake
22
23 Requires(post): /sbin/ldconfig
24 Requires(postun): /sbin/ldconfig
25
26 %description
27 Bluetooth framework for BlueZ This package is Bluetooth framework based on BlueZ stack.
28  This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
29
30
31 %package devel
32 Summary:    Bluetooth framework for BlueZ
33 Group:      TO_BE/FILLED
34 Requires:   %{name} = %{version}-%{release}
35
36 %description devel
37 This package is development files for Bluetooth framework based on BlueZ stack.
38 This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
39
40
41 %package agent
42 Summary:    Bluetooth Agent for pairing and authorization
43 Group:      TO_BE/FILLED
44 Requires:   %{name} = %{version}-%{release}
45
46 %description agent
47 This package is Bluetooth useraction Agent to response pairing, authorization, and mode change with BlueZ.
48
49 %prep
50 %setup -q
51
52
53 %build
54 export CFLAGS+=" -fpie"
55 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
56
57 cmake . -DCMAKE_INSTALL_PREFIX=/usr
58
59 make
60
61 %install
62 rm -rf %{buildroot}
63 %make_install
64
65 %post -p /sbin/ldconfig
66
67 %postun -p /sbin/ldconfig
68
69 %files
70 /usr/lib/*.so.*
71
72 %files devel
73 /usr/lib/*.so
74 /usr/include/*
75 /usr/lib/pkgconfig/*
76
77 %files agent
78 /usr/bin/bluetooth-agent
79 /usr/bin/bluetooth-pb-agent
80 /etc/*
81 /usr/share/process-info/bluetooth-agent.ini
82 /usr/share/dbus-1/services/org.bluez.frwk_agent.service
83 /usr/share/dbus-1/services/org.bluez.pb_agent.service