c7ae5f2f16619c4b008509304e866f3f9c3fc7e0
[framework/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
1 Name:       bluetooth-frwk
2 Summary:    Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
3 Version:    0.1.88
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig(aul)
10 BuildRequires:  pkgconfig(contacts-service)
11 BuildRequires:  pkgconfig(dbus-glib-1)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(syspopup-caller)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(libxml-2.0)
17 BuildRequires:  pkgconfig(dbus-1)
18 BuildRequires:  pkgconfig(utilX)
19 BuildRequires:  pkgconfig(msg-service)
20 BuildRequires:  pkgconfig(email-service)
21 BuildRequires:  pkgconfig(appcore-efl)
22 BuildRequires:  pkgconfig(appsvc)
23 BuildRequires:  cmake
24
25 Requires(post): /sbin/ldconfig
26 Requires(postun): /sbin/ldconfig
27
28 %description
29 Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
30  This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
31
32
33 %package devel
34 Summary:    Bluetooth framework for BlueZ and Obexd
35 Group:      TO_BE/FILLED
36 Requires:   %{name} = %{version}-%{release}
37
38 %description devel
39 This package is development files for Bluetooth framework based on BlueZ and Obexd stack.
40 This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
41
42
43 %package agent
44 Summary:    Bluetooth Agent for pairing and authorization
45 Group:      TO_BE/FILLED
46 Requires:   %{name} = %{version}-%{release}
47
48 %description agent
49 This package is Bluetooth useraction Agent to response pairing, authorization, and mode change with BlueZ.
50
51 %prep
52 %setup -q
53
54
55 %build
56 export CFLAGS+=" -fpie"
57 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
58
59 cmake . -DCMAKE_INSTALL_PREFIX=/usr
60
61 make
62
63 %install
64 rm -rf %{buildroot}
65 %make_install
66
67 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc3.d/
68 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc5.d/
69 ln -s %{_sysconfdir}/rc.d/init.d/bluetooth-frwk-agent %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S80bluetooth-frwk-agent
70 ln -s %{_sysconfdir}/rc.d/init.d/bluetooth-frwk-agent %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S80bluetooth-frwk-agent
71
72 %post
73 vconftool set -t int db/bluetooth/status "0" -g 6520
74 vconftool set -t int memory/private/libbluetooth-frwk-0/obex_no_agent "0" -g 6520 -i
75 vconftool set -t string memory/private/libbluetooth-frwk-0/uuid "" -g 6520 -i
76 vconftool set -t string memory/bluetooth/sco_headset_name "" -g 6520 -i
77
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(-, root, root)
82 %{_libdir}/libbluetooth-api.so.*
83 %{_libdir}/libbluetooth-media-control.so.*
84 %{_libdir}/libbluetooth-telephony.so.*
85
86 %files devel
87 %defattr(-, root, root)
88 %{_includedir}/bluetooth-media-control/bluetooth-media-control.h
89 %{_includedir}/bluetooth-api/bluetooth-hid-api.h
90 %{_includedir}/bluetooth-api/bluetooth-audio-api.h
91 %{_includedir}/bluetooth-api/bluetooth-control-api.h
92 %{_includedir}/bluetooth-api/bluetooth-api.h
93 %{_includedir}/bluetooth-telephony/bluetooth-telephony-api.h
94 %{_libdir}/pkgconfig/bluetooth-media-control.pc
95 %{_libdir}/pkgconfig/bluetooth-api.pc
96 %{_libdir}/pkgconfig/bluetooth-telephony.pc
97 %{_libdir}/libbluetooth-api.so
98 %{_libdir}/libbluetooth-media-control.so
99 %{_libdir}/libbluetooth-telephony.so
100
101
102 %files agent
103 %defattr(-, root, root)
104 %{_sysconfdir}/rc.d/init.d/bluetooth-frwk-agent
105 %{_sysconfdir}/rc.d/rc3.d/S80bluetooth-frwk-agent
106 %{_sysconfdir}/rc.d/rc5.d/S80bluetooth-frwk-agent
107 %{_datadir}/dbus-1/services/org.bluez.pb_agent.service
108 %{_datadir}/dbus-1/services/org.bluez.frwk_agent.service
109 %{_datadir}/dbus-1/services/org.bluez.map_agent.service
110 %{_datadir}/dbus-1/services/org.bluez.hfp_agent.service
111 %{_bindir}/bluetooth-agent
112 %{_bindir}/bluetooth-map-agent
113 %{_bindir}/bluetooth-pb-agent
114 %{_bindir}/bluetooth-hfp-agent
115