Add the permanent log feature
[platform/core/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
1 # Do not create provides from emulator .so files because the main package
2 # should anchor any reverse-dependencies
3 %global __provides_exclude_from ^(.*\\.emulator)$
4
5 %bcond_with x
6 %define _dumpdir /opt/etc/dump.d/module.d
7 %define _varlibdir /opt/var/lib
8
9 Name:       bluetooth-frwk
10 Summary:    Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
11 Version:    0.3.0
12 Release:    1
13 Group:      Network & Connectivity/Bluetooth
14 License:    Apache-2.0
15 Source0:    %{name}-%{version}.tar.gz
16 Source1001: bluetooth-frwk.manifest
17
18 Requires: bluetooth-tools
19
20 %define bt_bluez_hal ENABLED
21 %define bt_gatt_client_fd ENABLED
22 %define bt_permanent_log DISABLED
23
24 BuildRequires:  pkgconfig(aul)
25 BuildRequires:  pkgconfig(dlog)
26 BuildRequires:  pkgconfig(glib-2.0)
27 BuildRequires:  pkgconfig(gio-2.0)
28 BuildRequires:  pkgconfig(gio-unix-2.0)
29 BuildRequires:  pkgconfig(syspopup-caller)
30 BuildRequires:  pkgconfig(vconf)
31 BuildRequires:  pkgconfig(libxml-2.0)
32 BuildRequires:  pkgconfig(capi-network-connection)
33 BuildRequires:  pkgconfig(alarm-service)
34 BuildRequires:  pkgconfig(capi-content-mime-type)
35 BuildRequires:  pkgconfig(eventsystem)
36 BuildRequires:  pkgconfig(libsoup-2.4)
37 BuildRequires:  pkgconfig(capi-network-tethering)
38 BuildRequires:  cmake
39 BuildRequires:  pkgconfig(cynara-client)
40 BuildRequires:  pkgconfig(cynara-creds-gdbus)
41 BuildRequires:  pkgconfig(libtzplatform-config)
42 BuildRequires:  pkgconfig(storage)
43 BuildRequires:  pkgconfig(capi-system-info)
44 BuildRequires:  pkgconfig(capi-appfw-app-control)
45 BuildRequires:  pkgconfig(gmock)
46 BuildRequires:  pkgconfig(libactd)
47 BuildRequires:  pkgconfig(libsystemd-daemon)
48
49 Requires(post): /usr/bin/vconftool
50 Requires(post): /sbin/ldconfig
51 Requires(postun): /sbin/ldconfig
52
53 %description
54 Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
55  This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
56
57 %package profile_common
58 Summary:    bluetooth-frwk service and conf files for common profile
59 Requires:   %{name} = %{version}-%{release}
60 Conflicts:  %{name}-profile_mobile
61 Conflicts:  %{name}-profile_wearable
62 Conflicts:  %{name}-profile_tv
63 Conflicts:  %{name}-profile_ivi
64 %description profile_common
65 Bluetooth framework configuration and service files for Tizen common profile
66
67 %package profile_mobile
68 Summary:    bluetooth-frwk service and conf files for mobile profile
69 Requires:   %{name} = %{version}-%{release}
70 Conflicts:  %{name}-profile_common
71 Conflicts:  %{name}-profile_wearable
72 Conflicts:  %{name}-profile_tv
73 Conflicts:  %{name}-profile_ivi
74 %description profile_mobile
75 Bluetooth framework configuration and service files for Tizen mobile profile
76
77 # extension-TM1
78 %ifarch %{ix86} || %{arm}
79 %package extension-TM1
80 Summary:    bluetooth-frwk service and conf files for mobile TM1
81 Requires:   %{name}-profile_mobile = %{version}-%{release}
82 %description extension-TM1
83 Bluetooth framework configuration and service files for Tizen mobile TM1
84 %endif
85
86 %package profile_wearable
87 Summary:    bluetooth-frwk service and conf files for wearable profile
88 Requires:   %{name} = %{version}-%{release}
89 Conflicts:  %{name}-profile_mobile
90 Conflicts:  %{name}-profile_common
91 Conflicts:  %{name}-profile_tv
92 Conflicts:  %{name}-profile_ivi
93 %description profile_wearable
94 Bluetooth framework configuration and service files for Tizen wearable profile
95
96 %package profile_tv
97 Summary:    bluetooth-frwk service and conf files for tv profile
98 Requires:   %{name} = %{version}-%{release}
99 Conflicts:  %{name}-profile_mobile
100 Conflicts:  %{name}-profile_wearable
101 Conflicts:  %{name}-profile_common
102 Conflicts:  %{name}-profile_ivi
103 %description profile_tv
104 Bluetooth framework configuration and service files for Tizen tv profile
105
106 %package profile_ivi
107 Summary:    bluetooth-frwk service and conf files for ivi profile
108 Requires:   %{name} = %{version}-%{release}
109 Conflicts:  %{name}-profile_mobile
110 Conflicts:  %{name}-profile_wearable
111 Conflicts:  %{name}-profile_tv
112 Conflicts:  %{name}-profile_common
113 %description profile_ivi
114 Bluetooth framework configuration and service files for Tizen ivi profile
115
116 %ifarch %{ix86} x86_64
117 %package extension-emulator
118 Summary:    bluetooth-frwk service and conf files for emulator
119 Requires:   %{name} = %{version}-%{release}
120 %description extension-emulator
121 bluetooth-frwk service and conf files for emulator
122 %endif // ifarch %{ix86} x86_64
123
124 %package devel
125 Summary:    Bluetooth framework for BlueZ and Obexd
126 Group:      Development/Libraries
127 Requires:   %{name} = %{version}-%{release}
128
129 %description devel
130 This package is development files for Bluetooth framework based on BlueZ and Obexd stack.
131 This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
132
133 %package service
134 Summary:    Bluetooth Service daemon
135 Group:      Network & Connectivity/Bluetooth
136 Requires:   %{name} = %{version}-%{release}
137
138 %description service
139 This package is Bluetooth Service daemon to manage BT services.
140
141 %package httpproxy
142 Summary:    Bluetooth HTTP Proxy Service daemon
143 Group:      Network & Connectivity/Bluetooth
144 Requires:   %{name} = %{version}-%{release}
145
146 %description httpproxy
147 This package is Bluetooth HTTP Proxy Service daemon
148
149 %package otp
150 Summary:    Bluetooth OTP Service daemon
151 Group:      Network & Connectivity/Bluetooth
152 Requires:   %{name} = %{version}-%{release}
153
154 %description otp
155 This package is Bluetooth OTP Service daemon
156
157 %package core
158 Summary:    Bluetooth Core daemon
159 Group:      Network & Connectivity/Bluetooth
160 Requires:   %{name} = %{version}-%{release}
161
162 %description core
163 This package is Bluetooth core daemon to manage activation / deactivation.
164
165 %package test
166 Summary:    Bluetooth test application
167 Group:      Network & Connectivity/Bluetooth
168 Requires:   %{name} = %{version}-%{release}
169
170 %description test
171 This package is Bluetooth test application.
172
173 %package oal
174 Summary:    Bluetooth OAL
175 Group:      Network & Connectivity/Bluetooth
176 Requires:   %{name} = %{version}-%{release}
177
178 %description oal
179 This package is BT stack common interface.
180
181 %package plugin-headed
182 Summary:    Bluetooth plugin Headed
183 Group:      Network & Connectivity/Bluetooth
184 Requires:   %{name} = %{version}-%{release}
185
186 %description plugin-headed
187 This package is Bluetooth plugin to manage UI and syspopup
188
189 %package -n bluetooth-haltests
190 Summary: HAL Test package for bluetooth OAL
191 Group:   TO_BE/FILLED
192 Requires: %{name} = %{version}-%{release}
193
194 %description -n bluetooth-haltests
195 This package is C-API test application.
196
197 %prep
198 %setup -q
199 cp %{SOURCE1001} .
200
201
202 %build
203 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
204 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_OBEX"
205 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_PAN_NAP"
206 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_IPSP"
207 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
208 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
209 export CFLAGS="$CFLAGS -DTIZEN_GATT_CLIENT"
210 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_ACTD"
211
212 %define _servicefile packaging/bluetooth-frwk-common.service
213 %define _servicedir starter.target.wants
214
215 %if "%{?profile}" == "mobile"
216 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_NETWORK_TETHERING_ENABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED -DTIZEN_PROFILE_MOBILE -DTIZEN_FEATURE_TELEPHONY_ENABLED"
217 %if "%{?tizen_target_name}" == "TM1"
218 %define _servicefile packaging/bluetooth-frwk-mobile-sprd.service
219 %else
220 %define _servicefile packaging/bluetooth-frwk-mobile.service
221 %endif
222 %define _servicedir multi-user.target.wants
223 %endif
224
225 %if "%{?profile}" == "wearable"
226 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_WEARABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED"
227 %define _servicefile packaging/bluetooth-frwk-wearable.service
228 %define _servicedir multi-user.target.wants
229 %endif
230
231 %if "%{?profile}" == "tv"
232 export CFLAGS="$CFLAGS -DUSB_BLUETOOTH -DTIZEN_TV -DAUTO_ACCEPT"
233 %define _servicefile packaging/bluetooth-frwk-tv.service
234 %define _servicedir multi-user.target.wants
235 %endif
236
237 %if "%{?profile}" == "ivi"
238 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_IVI"
239 %define _servicefile packaging/bluetooth-frwk-wearable.service
240 %define _servicedir multi-user.target.wants
241 %endif
242
243 %ifarch x86_64
244 #export CFLAGS="$CFLAGS -Wall -g -fvisibility=hidden -fPIC"
245 export CFLAGS="$CFLAGS -fpie"
246 export CFLAGS+=" -DARCH64"
247 export CXXFLAGS+=" -DARCH64"
248 export FFLAGS+=" -DARCH64"
249 %else
250 export CFLAGS="$CFLAGS -fpie"
251 export LDFLAGS="$CFLAGS -pie"
252 %endif
253
254 %if %{bt_bluez_hal} == ENABLED
255 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT -DTIZEN_BT_HAL"
256 %else
257 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
258 %endif
259 export LDFLAGS="$CFLAGS -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs"
260
261 %if %{bt_gatt_client_fd} == DISABLED
262 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_GATT_CLIENT_FD_DISABLE"
263 %endif
264
265 %if %{bt_permanent_log} == ENABLED
266 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_PERMANENT_LOG"
267 %endif
268
269 %ifarch %{ix86} x86_64
270 export CFLAGS+=" -DTIZEN_TEST_EMUL"
271 export CXXFLAGS+=" -DTIZEN_TEST_EMUL"
272 export FFLAGS+=" -DTIZEN_TEST_EMUL"
273 %endif
274
275 %if %{bt_bluez_hal} == ENABLED
276 export BT_INCLUDE_OAL_BLUEZ=ENABLED
277 export CFLAGS="$CFLAGS -DTIZEN_BT_INCLUDE_OAL_BLUEZ"
278 %else
279 export BT_INCLUDE_OAL_BLUEZ=DISABLED
280 %endif
281
282 export CFLAGS_DEFAULT="$CFLAGS"
283 export CXXFLAGS_DEFAULT="$CXXFLAGS"
284 export FFLAGS_DEFAULT="$FFLAGS"
285
286 # extension-TM1
287 %ifarch %{ix86} || %{arm}
288 mkdir -p tm1
289 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
290 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
291 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
292
293 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
294 -DCMAKE_LIB_DIR=%{_libdir} \
295 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
296 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
297         -DLIBNOTIFY_SUPPORT=Off \
298         -DLIBNOTIFICATION_SUPPORT=Off
299 make %{?_smp_mflags}
300
301 %cmake
302
303 %make_install
304 cp %{buildroot}%{_bindir}/bt-core tm1/bt-core.tm1
305 %endif
306
307 # extension-emulator
308 %ifarch %{ix86} x86_64
309 export CFLAGS="${CFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
310 export CXXFLAGS="${CXXFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
311 export FFLAGS="${FFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
312
313 mkdir -p build_emulator
314
315 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
316 -DCMAKE_LIB_DIR=%{_libdir} \
317 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
318 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
319         -DLIBNOTIFY_SUPPORT=Off \
320         -DLIBNOTIFICATION_SUPPORT=Off
321 make %{?_smp_mflags}
322
323 %cmake
324
325 %make_install
326 cp %{buildroot}%{_libdir}/libbluetooth-api.so* build_emulator/
327 pushd build_emulator/
328 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
329 popd
330 %endif
331
332 # non-extension-TM1 / non-extension-emulator
333
334 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
335 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
336 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
337
338 %ifarch aarch64
339 echo arch64
340 export CFLAGS+=" -DARCH64"
341 export CXXFLAGS+=" -DARCH64"
342 export FFLAGS+=" -DARCH64"
343 %endif
344
345 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
346 -DCMAKE_LIB_DIR=%{_libdir} \
347 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
348 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
349         -DLIBNOTIFY_SUPPORT=Off \
350         -DLIBNOTIFICATION_SUPPORT=Off
351 make %{?_smp_mflags}
352
353 %cmake
354
355 %install
356 rm -rf %{buildroot}
357 %make_install
358
359 mkdir -p %{buildroot}%{_unitdir}/starter.target.wants
360 mkdir -p %{buildroot}%{_unitdir}/delayed.target.wants
361 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
362 mkdir -p %{buildroot}/%{_prefix}/lib/udev/rules.d
363
364 cp packaging/99-bluetooth-rfkill.rules %{buildroot}/%{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
365
366 # extension-emulator
367 %ifarch %{ix86} x86_64
368 cp build_emulator/libbluetooth-api.so*.emulator %{buildroot}%{_libdir}/
369 #mv %{buildroot}/%{_bindir}/bt-service-emul %{buildroot}/%{_bindir}/bt-service
370 %endif
371
372 # Rename the postfix (.mobile, .tv, ..) at post script
373 # mobile
374 install -m 0644 packaging/bluetooth-frwk-mobile.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.mobile
375
376 # extension-TM1
377 %ifarch %{ix86} || %{arm}
378 cp tm1/bt-core.tm1 %{buildroot}%{_bindir}/
379 install -m 0644 packaging/bluetooth-frwk-mobile-sprd.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tm1
380 %endif
381
382 # wearable / ivi
383 install -m 0644 packaging/bluetooth-frwk-wearable.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.wearable
384 # On IVI bt-service needs to be run as 'app' even if there is a 'guest' user.
385 cp %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
386 sed -i 's/%TZ_SYS_DEFAULT_USER/app/' %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
387
388 # tv
389 install -m 0644 packaging/bluetooth-frwk-tv.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tv
390
391 # common
392 install -m 0644 packaging/bluetooth-frwk-common.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.common
393
394 # bt-core
395 install -m 0644 bt-core/bluetooth-frwk-core.service %{buildroot}%{_unitdir}/bluetooth-frwk-core.service
396
397 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
398 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/starter.target.wants/bluetooth-frwk.service
399
400 %postun -p /sbin/ldconfig
401
402 %post service
403 /usr/bin/chsmack -a '_' %{_varlibdir}/bluetooth/auto-pair-blacklist
404 /usr/bin/chown network_fw:network_fw %{_varlibdir}/bluetooth/auto-pair-blacklist
405
406 %files
407 %manifest %{name}.manifest
408 %license LICENSE
409 %defattr(-, root, root)
410 %{_libdir}/libbluetooth-api.so.*
411 %exclude %{_libdir}/libbluetooth-api.so*.emulator
412
413 %files devel
414 %defattr(-, root, root)
415 %{_includedir}/bt-service/bluetooth-api.h
416 %{_includedir}/bt-service/bluetooth-hid-api.h
417 %{_includedir}/bt-service/bluetooth-audio-api.h
418 %{_includedir}/bt-service/bluetooth-telephony-api.h
419 %{_includedir}/bt-service/bluetooth-media-control.h
420 %{_includedir}/bt-service/bluetooth-scmst-api.h
421 %{_includedir}/bt-service/bluetooth-ipsp-api.h
422 %{_includedir}/bt-service/bluetooth-gatt-server-api.h
423 %{_includedir}/bt-service/bluetooth-gatt-client-api.h
424 %{_libdir}/pkgconfig/bluetooth-api.pc
425 %{_libdir}/libbluetooth-api.so
426
427 # extension-emulator
428 %ifarch %{ix86} x86_64
429 %post extension-emulator
430 pushd %{_libdir}
431 for FILE in libbluetooth-api.so*.emulator; do mv "${FILE}" "${FILE%.emulator}"; done
432 popd
433 %preun extension-emulator
434 pushd %{_libdir}
435 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
436 popd
437 %files extension-emulator
438 %manifest %{name}.manifest
439 %defattr(-, root, root)
440 %{_libdir}/libbluetooth-api.so.*.emulator
441 %{_libdir}/libbluetooth-api.so.emulator
442 %endif
443
444 %files service
445 %manifest %{name}.manifest
446 %license LICENSE
447 %defattr(-, root, root)
448 %{_bindir}/bt-service
449 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-service.conf
450 %{_bindir}/bluetooth-frwk-test
451 %{_varlibdir}/bluetooth
452 %{_prefix}/etc/bluetooth
453 %attr(-,network_fw,network_fw) %{_varlibdir}/bluetooth/auto-pair-blacklist
454
455 %files httpproxy
456 %manifest %{name}.manifest
457 %license LICENSE
458 %defattr(-, root, root)
459 %{_bindir}/bt-httpproxy
460 %{_datadir}/dbus-1/system-services/org.projectx.httpproxy.service
461 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-httpproxy.conf
462
463
464 %files otp
465 %manifest %{name}.manifest
466 %license LICENSE
467 %defattr(-, root, root)
468 %{_bindir}/bt-otp
469 %{_datadir}/dbus-1/system-services/org.projectx.otp.service
470 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-otp.conf
471
472 %files core
473 %manifest %{name}.manifest
474 %license LICENSE
475 %defattr(-, root, root)
476 %{_unitdir}/bluetooth-frwk-core.service
477 %{_datadir}/dbus-1/system-services/org.projectx.bt_core.service
478 %{_bindir}/bt-core
479 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-core.conf
480 %{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
481
482 %files test
483 %manifest %{name}.manifest
484 %license LICENSE
485 %defattr(-, root, root)
486 %{_bindir}/bluetooth-frwk-test
487 #%{_bindir}/bluetooth-gatt-test
488 #%{_bindir}/bluetooth-advertising-test
489
490 %files plugin-headed
491 %manifest %{name}.manifest
492 %license LICENSE
493 %defattr(-, root, root)
494 %{_libdir}/bt-plugin-headed.so
495
496 %post profile_common
497 pushd %{_unitdir}
498 mv bluetooth-frwk.service.common bluetooth-frwk.service
499 popd
500 %preun profile_common
501 pushd %{_unitdir}
502 mv bluetooth-frwk.service bluetooth-frwk.service.common
503 popd
504 %files profile_common
505 %license LICENSE
506 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
507 %exclude %{_unitdir}/starter.target.wants/bluetooth-frwk.service
508 %{_unitdir}/bluetooth-frwk.service.common
509 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
510
511 %post profile_mobile
512 pushd %{_unitdir}
513 mv bluetooth-frwk.service.mobile bluetooth-frwk.service
514 popd
515 %preun profile_mobile
516 pushd %{_unitdir}
517 mv bluetooth-frwk.service bluetooth-frwk.service.mobile
518 popd
519 %files profile_mobile
520 %license LICENSE
521 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
522 %{_unitdir}/bluetooth-frwk.service.mobile
523 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
524
525 # extension-TM1
526 %ifarch %{ix86} || %{arm}
527 %post extension-TM1
528 pushd %{_unitdir}
529 mv bluetooth-frwk.service.tm1 bluetooth-frwk.service
530 popd
531 pushd %{_bindir}
532 mv bt-core.tm1 bt-core
533 popd
534 %preun extension-TM1
535 pushd %{_unitdir}
536 mv bluetooth-frwk.service bluetooth-frwk.service.tm1
537 popd
538 pushd %{_bindir}
539 mv bt-core bt-core.tm1
540 popd
541 %files extension-TM1
542 %{_unitdir}/bluetooth-frwk.service.tm1
543 %license LICENSE
544 %defattr(-, root, root)
545 %{_bindir}/bt-core.tm1
546 %endif
547
548 %post profile_wearable
549 pushd %{_unitdir}
550 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
551 popd
552 %preun profile_wearable
553 pushd %{_unitdir}
554 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
555 popd
556 %files profile_wearable
557 %license LICENSE
558 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
559 %{_unitdir}/bluetooth-frwk.service.wearable
560 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
561
562 %post profile_tv
563 pushd %{_unitdir}
564 mv bluetooth-frwk.service.tv bluetooth-frwk.service
565 popd
566 %preun profile_tv
567 pushd %{_unitdir}
568 mv bluetooth-frwk.service bluetooth-frwk.service.tv
569 popd
570 %files profile_tv
571 %license LICENSE
572 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
573 %{_unitdir}/bluetooth-frwk.service.tv
574 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
575
576 # Note: ivi reuses bluetooth-frwk.service.wearable
577 %post profile_ivi
578 pushd %{_unitdir}
579 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
580 popd
581 pushd %{_datadir}/dbus-1/system-services
582 mv org.projectx.bt.service.ivi org.projectx.bt.service
583 popd
584 %preun profile_ivi
585 pushd %{_unitdir}
586 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
587 popd
588 pushd %{_datadir}/dbus-1/system-services
589 mv org.projectx.bt.service org.projectx.bt.service.ivi
590 popd
591 %files profile_ivi
592 %license LICENSE
593 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
594 %{_unitdir}/bluetooth-frwk.service.wearable
595 %{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
596
597 %files oal
598 %manifest %{name}.manifest
599 %defattr(-, root, root)
600 %{_libdir}/libbt-oal.so*
601 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-gap-agent.conf
602
603 %if %{bt_bluez_hal} == ENABLED
604 %{_libdir}/libbluetooth.default.so*
605 %endif
606
607 %files -n bluetooth-haltests
608 %manifest %{name}.manifest
609 %{_bindir}/bluetooth-haltests