8ae5058e26b4dd8940019a9161504d2a12585aa5
[platform/core/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
1 # Do not create provides from emulator .so files because the main package
2 # should anchor any reverse-dependencies
3 %global __provides_exclude_from ^(.*\\.emulator)$
4
5 %bcond_with x
6 %define _dumpdir /opt/etc/dump.d/module.d
7 %define _varlibdir /opt/var/lib
8
9 Name:       bluetooth-frwk
10 Summary:    Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
11 Version:    0.3.0
12 Release:    1
13 Group:      Network & Connectivity/Bluetooth
14 License:    Apache-2.0
15 Source0:    %{name}-%{version}.tar.gz
16 Source1001: bluetooth-frwk.manifest
17
18 Requires: bluetooth-tools
19
20 %define bt_bluez_hal ENABLED
21
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(glib-2.0)
25 BuildRequires:  pkgconfig(gio-2.0)
26 BuildRequires:  pkgconfig(gio-unix-2.0)
27 BuildRequires:  pkgconfig(syspopup-caller)
28 BuildRequires:  pkgconfig(vconf)
29 BuildRequires:  pkgconfig(libxml-2.0)
30 BuildRequires:  pkgconfig(capi-network-connection)
31 BuildRequires:  pkgconfig(alarm-service)
32 BuildRequires:  pkgconfig(capi-content-mime-type)
33 BuildRequires:  pkgconfig(eventsystem)
34 BuildRequires:  pkgconfig(libsoup-2.4)
35 BuildRequires:  pkgconfig(capi-network-tethering)
36 BuildRequires:  cmake
37 BuildRequires:  pkgconfig(cynara-client)
38 BuildRequires:  pkgconfig(cynara-creds-gdbus)
39 BuildRequires:  pkgconfig(libtzplatform-config)
40 BuildRequires:  pkgconfig(storage)
41 BuildRequires:  pkgconfig(capi-system-info)
42 BuildRequires:  pkgconfig(capi-appfw-app-control)
43
44 Requires(post): /usr/bin/vconftool
45 Requires(post): /sbin/ldconfig
46 Requires(postun): /sbin/ldconfig
47
48 %description
49 Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
50  This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
51
52 %package profile_common
53 Summary:    bluetooth-frwk service and conf files for common profile
54 Requires:   %{name} = %{version}-%{release}
55 Conflicts:  %{name}-profile_mobile
56 Conflicts:  %{name}-profile_wearable
57 Conflicts:  %{name}-profile_tv
58 Conflicts:  %{name}-profile_ivi
59 %description profile_common
60 Bluetooth framework configuration and service files for Tizen common profile
61
62 %package profile_mobile
63 Summary:    bluetooth-frwk service and conf files for mobile profile
64 Requires:   %{name} = %{version}-%{release}
65 Conflicts:  %{name}-profile_common
66 Conflicts:  %{name}-profile_wearable
67 Conflicts:  %{name}-profile_tv
68 Conflicts:  %{name}-profile_ivi
69 %description profile_mobile
70 Bluetooth framework configuration and service files for Tizen mobile profile
71
72 # extension-TM1
73 %ifarch %{ix86} || %{arm}
74 %package extension-TM1
75 Summary:    bluetooth-frwk service and conf files for mobile TM1
76 Requires:   %{name}-profile_mobile = %{version}-%{release}
77 %description extension-TM1
78 Bluetooth framework configuration and service files for Tizen mobile TM1
79 %endif
80
81 %package profile_wearable
82 Summary:    bluetooth-frwk service and conf files for wearable profile
83 Requires:   %{name} = %{version}-%{release}
84 Conflicts:  %{name}-profile_mobile
85 Conflicts:  %{name}-profile_common
86 Conflicts:  %{name}-profile_tv
87 Conflicts:  %{name}-profile_ivi
88 %description profile_wearable
89 Bluetooth framework configuration and service files for Tizen wearable profile
90
91 %package profile_tv
92 Summary:    bluetooth-frwk service and conf files for tv profile
93 Requires:   %{name} = %{version}-%{release}
94 Conflicts:  %{name}-profile_mobile
95 Conflicts:  %{name}-profile_wearable
96 Conflicts:  %{name}-profile_common
97 Conflicts:  %{name}-profile_ivi
98 %description profile_tv
99 Bluetooth framework configuration and service files for Tizen tv profile
100
101 %package profile_ivi
102 Summary:    bluetooth-frwk service and conf files for ivi profile
103 Requires:   %{name} = %{version}-%{release}
104 Conflicts:  %{name}-profile_mobile
105 Conflicts:  %{name}-profile_wearable
106 Conflicts:  %{name}-profile_tv
107 Conflicts:  %{name}-profile_common
108 %description profile_ivi
109 Bluetooth framework configuration and service files for Tizen ivi profile
110
111 %ifarch %{ix86} x86_64
112 %package extension-emulator
113 Summary:    bluetooth-frwk service and conf files for emulator
114 Requires:   %{name} = %{version}-%{release}
115 %description extension-emulator
116 bluetooth-frwk service and conf files for emulator
117 %endif // ifarch %{ix86} x86_64
118
119 %package devel
120 Summary:    Bluetooth framework for BlueZ and Obexd
121 Group:      Development/Libraries
122 Requires:   %{name} = %{version}-%{release}
123
124 %description devel
125 This package is development files for Bluetooth framework based on BlueZ and Obexd stack.
126 This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
127
128 %package service
129 Summary:    Bluetooth Service daemon
130 Group:      Network & Connectivity/Bluetooth
131 Requires:   %{name} = %{version}-%{release}
132
133 %description service
134 This package is Bluetooth Service daemon to manage BT services.
135
136 %package httpproxy
137 Summary:    Bluetooth HTTP Proxy Service daemon
138 Group:      Network & Connectivity/Bluetooth
139 Requires:   %{name} = %{version}-%{release}
140
141 %description httpproxy
142 This package is Bluetooth HTTP Proxy Service daemon
143
144 %package otp
145 Summary:    Bluetooth OTP Service daemon
146 Group:      Network & Connectivity/Bluetooth
147 Requires:   %{name} = %{version}-%{release}
148
149 %description otp
150 This package is Bluetooth OTP Service daemon
151
152 %package core
153 Summary:    Bluetooth Core daemon
154 Group:      Network & Connectivity/Bluetooth
155 Requires:   %{name} = %{version}-%{release}
156
157 %description core
158 This package is Bluetooth core daemon to manage activation / deactivation.
159
160 %package test
161 Summary:    Bluetooth test application
162 Group:      Network & Connectivity/Bluetooth
163 Requires:   %{name} = %{version}-%{release}
164
165 %description test
166 This package is Bluetooth test application.
167
168 %package oal
169 Summary:    Bluetooth OAL
170 Group:      Network & Connectivity/Bluetooth
171 Requires:   %{name} = %{version}-%{release}
172
173 %description oal
174 This package is BT stack common interface.
175
176 %package plugin-headed
177 Summary:    Bluetooth plugin Headed
178 Group:      Network & Connectivity/Bluetooth
179 Requires:   %{name} = %{version}-%{release}
180
181 %description plugin-headed
182 This package is Bluetooth plugin to manage UI and syspopup
183
184 %prep
185 %setup -q
186 cp %{SOURCE1001} .
187
188
189 %build
190 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
191 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_OBEX"
192 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_PAN_NAP"
193 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_IPSP"
194 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
195 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
196 export CFLAGS="$CFLAGS -DTIZEN_GATT_CLIENT"
197
198 %define _servicefile packaging/bluetooth-frwk-common.service
199 %define _servicedir starter.target.wants
200
201 %if "%{?profile}" == "mobile"
202 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_NETWORK_TETHERING_ENABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED -DTIZEN_PROFILE_MOBILE -DTIZEN_FEATURE_TELEPHONY_ENABLED"
203 %if "%{?tizen_target_name}" == "TM1"
204 %define _servicefile packaging/bluetooth-frwk-mobile-sprd.service
205 %else
206 %define _servicefile packaging/bluetooth-frwk-mobile.service
207 %endif
208 %define _servicedir multi-user.target.wants
209 %endif
210
211 %if "%{?profile}" == "wearable"
212 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_WEARABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED"
213 %define _servicefile packaging/bluetooth-frwk-wearable.service
214 %define _servicedir multi-user.target.wants
215 %endif
216
217 %if "%{?profile}" == "tv"
218 export CFLAGS="$CFLAGS -DUSB_BLUETOOTH -DTIZEN_TV -DAUTO_ACCEPT"
219 %define _servicefile packaging/bluetooth-frwk-tv.service
220 %define _servicedir multi-user.target.wants
221 %endif
222
223 %if "%{?profile}" == "ivi"
224 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_IVI"
225 %define _servicefile packaging/bluetooth-frwk-wearable.service
226 %define _servicedir multi-user.target.wants
227 %endif
228
229 %ifarch x86_64
230 #export CFLAGS="$CFLAGS -Wall -g -fvisibility=hidden -fPIC"
231 export CFLAGS="$CFLAGS -fpie"
232 export CFLAGS+=" -DARCH64"
233 export CXXFLAGS+=" -DARCH64"
234 export FFLAGS+=" -DARCH64"
235 %else
236 export CFLAGS="$CFLAGS -fpie"
237 export LDFLAGS="$CFLAGS -pie"
238 %endif
239
240 %if %{bt_bluez_hal} == ENABLED
241 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT -DTIZEN_BT_HAL"
242 %else
243 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
244 %endif
245 export LDFLAGS="$CFLAGS -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs"
246
247 %ifarch %{ix86} x86_64
248 export CFLAGS+=" -DTIZEN_TEST_EMUL"
249 export CXXFLAGS+=" -DTIZEN_TEST_EMUL"
250 export FFLAGS+=" -DTIZEN_TEST_EMUL"
251 %endif
252
253 %if %{bt_bluez_hal} == ENABLED
254 export BT_INCLUDE_OAL_BLUEZ=ENABLED
255 export CFLAGS="$CFLAGS -DTIZEN_BT_INCLUDE_OAL_BLUEZ"
256 %else
257 export BT_INCLUDE_OAL_BLUEZ=DISABLED
258 %endif
259
260 export CFLAGS_DEFAULT="$CFLAGS"
261 export CXXFLAGS_DEFAULT="$CXXFLAGS"
262 export FFLAGS_DEFAULT="$FFLAGS"
263
264 # extension-TM1
265 %ifarch %{ix86} || %{arm}
266 mkdir -p tm1
267 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
268 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
269 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
270
271 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
272 -DCMAKE_LIB_DIR=%{_libdir} \
273 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
274 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
275         -DLIBNOTIFY_SUPPORT=Off \
276         -DLIBNOTIFICATION_SUPPORT=Off
277 make
278
279 %cmake
280
281 %make_install
282 cp %{buildroot}%{_bindir}/bt-core tm1/bt-core.tm1
283 %endif
284
285 # extension-emulator
286 %ifarch %{ix86} x86_64
287 export CFLAGS="${CFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
288 export CXXFLAGS="${CXXFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
289 export FFLAGS="${FFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
290
291 mkdir -p build_emulator
292
293 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
294 -DCMAKE_LIB_DIR=%{_libdir} \
295 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
296 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
297         -DLIBNOTIFY_SUPPORT=Off \
298         -DLIBNOTIFICATION_SUPPORT=Off
299 make
300
301 %cmake
302
303 %make_install
304 cp %{buildroot}%{_libdir}/libbluetooth-api.so* build_emulator/
305 pushd build_emulator/
306 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
307 popd
308 %endif
309
310 # non-extension-TM1 / non-extension-emulator
311
312 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
313 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
314 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
315
316 %ifarch aarch64
317 echo arch64
318 export CFLAGS+=" -DARCH64"
319 export CXXFLAGS+=" -DARCH64"
320 export FFLAGS+=" -DARCH64"
321 %endif
322
323 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
324 -DCMAKE_LIB_DIR=%{_libdir} \
325 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
326 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
327         -DLIBNOTIFY_SUPPORT=Off \
328         -DLIBNOTIFICATION_SUPPORT=Off
329 make
330
331 %cmake
332
333 %install
334 rm -rf %{buildroot}
335 %make_install
336
337 mkdir -p %{buildroot}%{_unitdir}/starter.target.wants
338 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
339 mkdir -p %{buildroot}/%{_prefix}/lib/udev/rules.d
340
341 cp packaging/99-bluetooth-rfkill.rules %{buildroot}/%{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
342
343 # extension-emulator
344 %ifarch %{ix86} x86_64
345 cp build_emulator/libbluetooth-api.so*.emulator %{buildroot}%{_libdir}/
346 #mv %{buildroot}/%{_bindir}/bt-service-emul %{buildroot}/%{_bindir}/bt-service
347 %endif
348
349 # Rename the postfix (.mobile, .tv, ..) at post script
350 # mobile
351 install -m 0644 packaging/bluetooth-frwk-mobile.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.mobile
352
353 # extension-TM1
354 %ifarch %{ix86} || %{arm}
355 cp tm1/bt-core.tm1 %{buildroot}%{_bindir}/
356 install -m 0644 packaging/bluetooth-frwk-mobile-sprd.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tm1
357 %endif
358
359 # wearable / ivi
360 install -m 0644 packaging/bluetooth-frwk-wearable.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.wearable
361 # On IVI bt-service needs to be run as 'app' even if there is a 'guest' user.
362 cp %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
363 sed -i 's/%TZ_SYS_DEFAULT_USER/app/' %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
364
365 # tv
366 install -m 0644 packaging/bluetooth-frwk-tv.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tv
367
368 # common
369 install -m 0644 packaging/bluetooth-frwk-common.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.common
370
371 # bt-core
372 install -m 0644 bt-core/bluetooth-frwk-core.service %{buildroot}%{_unitdir}/bluetooth-frwk-core.service
373
374
375 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
376 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/starter.target.wants/bluetooth-frwk.service
377
378 %post core
379 mkdir -p %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d
380 ln -sf %{_libdir}/systemd/system/bluetooth-frwk-core.service %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-frwk-core.service
381 ln -sf %{_libdir}/systemd/system/bluetooth-frwk-core.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
382
383
384 %postun -p /sbin/ldconfig
385
386 %post service
387 /usr/bin/chsmack -a '_' %{_varlibdir}/bluetooth/auto-pair-blacklist
388 /usr/bin/chown 5001:100 %{_varlibdir}/bluetooth/auto-pair-blacklist
389
390 %files
391 %manifest %{name}.manifest
392 %license LICENSE
393 %defattr(-, root, root)
394 %{_libdir}/libbluetooth-api.so.*
395 %exclude %{_libdir}/libbluetooth-api.so*.emulator
396
397 %files devel
398 %defattr(-, root, root)
399 %{_includedir}/bt-service/bluetooth-api.h
400 %{_includedir}/bt-service/bluetooth-hid-api.h
401 %{_includedir}/bt-service/bluetooth-audio-api.h
402 %{_includedir}/bt-service/bluetooth-telephony-api.h
403 %{_includedir}/bt-service/bluetooth-media-control.h
404 %{_includedir}/bt-service/bluetooth-scmst-api.h
405 %{_includedir}/bt-service/bluetooth-ipsp-api.h
406 %{_includedir}/bt-service/bluetooth-gatt-server-api.h
407 %{_includedir}/bt-service/bluetooth-gatt-client-api.h
408 %{_libdir}/pkgconfig/bluetooth-api.pc
409 %{_libdir}/libbluetooth-api.so
410
411 # extension-emulator
412 %ifarch %{ix86} x86_64
413 %post extension-emulator
414 pushd %{_libdir}
415 for FILE in libbluetooth-api.so*.emulator; do mv "${FILE}" "${FILE%.emulator}"; done
416 popd
417 %preun extension-emulator
418 pushd %{_libdir}
419 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
420 popd
421 %files extension-emulator
422 %manifest %{name}.manifest
423 %defattr(-, root, root)
424 %{_libdir}/libbluetooth-api.so.*.emulator
425 %{_libdir}/libbluetooth-api.so.emulator
426 %endif
427
428 %files service
429 %manifest %{name}.manifest
430 %license LICENSE
431 %defattr(-, root, root)
432 %{_bindir}/bt-service
433 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-service.conf
434 %{_bindir}/bluetooth-frwk-test
435 %{_varlibdir}/bluetooth
436 %{_prefix}/etc/bluetooth
437 %attr(-,owner,users) %{_varlibdir}/bluetooth/auto-pair-blacklist
438
439 %files httpproxy
440 %manifest %{name}.manifest
441 %license LICENSE
442 %defattr(-, root, root)
443 %{_bindir}/bt-httpproxy
444 %{_datadir}/dbus-1/system-services/org.projectx.httpproxy.service
445 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-httpproxy.conf
446
447
448 %files otp
449 %manifest %{name}.manifest
450 %license LICENSE
451 %defattr(-, root, root)
452 %{_bindir}/bt-otp
453 %{_datadir}/dbus-1/system-services/org.projectx.otp.service
454 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-otp.conf
455
456 %files core
457 %manifest %{name}.manifest
458 %license LICENSE
459 %defattr(-, root, root)
460 %{_unitdir}/bluetooth-frwk-core.service
461 %{_datadir}/dbus-1/system-services/org.projectx.bt_core.service
462 %{_bindir}/bt-core
463 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-core.conf
464 %{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
465
466 %files test
467 %manifest %{name}.manifest
468 %license LICENSE
469 %defattr(-, root, root)
470 %{_bindir}/bluetooth-frwk-test
471 #%{_bindir}/bluetooth-gatt-test
472 #%{_bindir}/bluetooth-advertising-test
473
474 %files plugin-headed
475 %manifest %{name}.manifest
476 %license LICENSE
477 %defattr(-, root, root)
478 %{_libdir}/bt-plugin-headed.so
479
480 %post profile_common
481 pushd %{_unitdir}
482 mv bluetooth-frwk.service.common bluetooth-frwk.service
483 popd
484 %preun profile_common
485 pushd %{_unitdir}
486 mv bluetooth-frwk.service bluetooth-frwk.service.common
487 popd
488 %files profile_common
489 %license LICENSE
490 %{_unitdir}/starter.target.wants/bluetooth-frwk.service
491 %{_unitdir}/bluetooth-frwk.service.common
492 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
493
494 %post profile_mobile
495 pushd %{_unitdir}
496 mv bluetooth-frwk.service.mobile bluetooth-frwk.service
497 popd
498 %preun profile_mobile
499 pushd %{_unitdir}
500 mv bluetooth-frwk.service bluetooth-frwk.service.mobile
501 popd
502 %files profile_mobile
503 %license LICENSE
504 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
505 %{_unitdir}/bluetooth-frwk.service.mobile
506 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
507
508 # extension-TM1
509 %ifarch %{ix86} || %{arm}
510 %post extension-TM1
511 pushd %{_unitdir}
512 mv bluetooth-frwk.service.tm1 bluetooth-frwk.service
513 popd
514 pushd %{_bindir}
515 mv bt-core.tm1 bt-core
516 popd
517 %preun extension-TM1
518 pushd %{_unitdir}
519 mv bluetooth-frwk.service bluetooth-frwk.service.tm1
520 popd
521 pushd %{_bindir}
522 mv bt-core bt-core.tm1
523 popd
524 %files extension-TM1
525 %{_unitdir}/bluetooth-frwk.service.tm1
526 %license LICENSE
527 %defattr(-, root, root)
528 %{_bindir}/bt-core.tm1
529 %endif
530
531 %post profile_wearable
532 pushd %{_unitdir}
533 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
534 popd
535 %preun profile_wearable
536 pushd %{_unitdir}
537 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
538 popd
539 %files profile_wearable
540 %license LICENSE
541 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
542 %{_unitdir}/bluetooth-frwk.service.wearable
543 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
544
545 %post profile_tv
546 pushd %{_unitdir}
547 mv bluetooth-frwk.service.tv bluetooth-frwk.service
548 popd
549 %preun profile_tv
550 pushd %{_unitdir}
551 mv bluetooth-frwk.service bluetooth-frwk.service.tv
552 popd
553 %files profile_tv
554 %license LICENSE
555 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
556 %{_unitdir}/bluetooth-frwk.service.tv
557 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
558
559 # Note: ivi reuses bluetooth-frwk.service.wearable
560 %post profile_ivi
561 pushd %{_unitdir}
562 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
563 popd
564 pushd %{_datadir}/dbus-1/system-services
565 mv org.projectx.bt.service.ivi org.projectx.bt.service
566 popd
567 %preun profile_ivi
568 pushd %{_unitdir}
569 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
570 popd
571 pushd %{_datadir}/dbus-1/system-services
572 mv org.projectx.bt.service org.projectx.bt.service.ivi
573 popd
574 %files profile_ivi
575 %license LICENSE
576 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
577 %{_unitdir}/bluetooth-frwk.service.wearable
578 %{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
579
580 %files oal
581 %manifest %{name}.manifest
582 %{_libdir}/libbt-oal.so*
583 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-gap-agent.conf
584
585 %if %{bt_bluez_hal} == ENABLED
586 %manifest %{name}.manifest
587 %{_libdir}/libbluetooth.default.so*
588 %endif