Add Gear S2 firmware
[platform/adaptation/bluetooth-firmware-bcm.git] / packaging / bluetooth-firmware-bcm.spec
1 Name:      bluetooth-firmware-bcm
2 Summary:    firmware and tools for bluetooth
3 Version:    0.1.3
4 Release:    1
5 Group:      Hardware Support/Handset
6 License:    Apache
7 # NOTE: Source name does not match package name.  This should be
8 # resolved in the future, by I don't have that power. - Ryan Ware
9 Source0:    %{name}-%{version}.tar.gz
10
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  cmake
13
14 %description
15  firmware and tools for bluetooth
16
17 %package exynos3250
18 Summary:    bcm firmware and tools for exynos3250
19 Group:      TO_BE/FILLED
20
21 %description exynos3250
22 bcm firmware and tools for exynos3250
23
24 %prep
25 %setup -q
26
27 %build
28 cmake ./ -DCMAKE_INSTALL_PREFIX=%{_prefix} -DPLUGIN_INSTALL_PREFIX=%{_prefix}
29 make %{?jobs:-j%jobs}
30
31 %install
32 rm -rf %{buildroot}
33
34 %make_install
35
36 mkdir -p %{buildroot}/usr/share/license
37 cp LICENSE.APLv2 %{buildroot}/usr/share/license/%{name}
38 cat %{_builddir}/%{name}-%{version}/LICENSE.Broadcom >> %{buildroot}/usr/share/license/%{name}
39
40 %files
41 %defattr(-,root,root,-)
42 #%{_bindir}/bcmtool_4330b1
43 %exclude %{_bindir}/bcmtool_4343w
44 %{_bindir}/bcmtool_4358a1
45 %{_bindir}/setbd
46 #%{_prefix}/etc/bluetooth/BT_FW_BCM4330B1_002.001.003.0221.0265.hcd
47 %{_prefix}/etc/bluetooth/BT_FW_BCM4358A1_001.002.005.0032.0066.hcd
48 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
49 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh
50 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh
51
52 %files exynos3250
53 %defattr(-,root,root,-)
54 %{_bindir}/bcmtool_4343w
55 %{_bindir}/setbd
56 %{_prefix}/etc/bluetooth/BCM4343A1_001.002.009.0035.0096_ORC_Orbis_WC1-S.hcd
57 %{_prefix}/etc/bluetooth/BCM4343A1_001.002.009.0022.0050_Murata_Type-1FR.hcd
58 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
59 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start-exynos3250.sh
60 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh
61 /usr/share/license/%{name}