Revert "[Warnings] Fix build warnings."
[platform/adaptation/bluetooth-firmware-bcm.git] / packaging / bluetooth-firmware-bcm.spec
1 Name:      bluetooth-firmware-bcm
2 Summary:    firmware and tools for bluetooth
3 Version:    0.1.3
4 Release:    1
5 Group:      Hardware Support/Handset
6 License:    Apache
7 # NOTE: Source name does not match package name.  This should be
8 # resolved in the future, by I don't have that power. - Ryan Ware
9 Source0:    %{name}-%{version}.tar.gz
10
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  cmake
13
14 %description
15  firmware and tools for bluetooth
16
17
18 %prep
19 %setup -q
20
21 %build
22 cmake ./ -DCMAKE_INSTALL_PREFIX=%{_prefix} -DPLUGIN_INSTALL_PREFIX=%{_prefix}
23 make %{?jobs:-j%jobs}
24
25 %install
26 rm -rf %{buildroot}
27 %make_install
28
29
30 %files
31 %defattr(-,root,root,-)
32 #%{_bindir}/bcmtool_4330b1
33 %{_bindir}/bcmtool_4358a1
34 %{_bindir}/setbd
35 #%{_prefix}/etc/bluetooth/BT_FW_BCM4330B1_002.001.003.0221.0265.hcd
36 %{_prefix}/etc/bluetooth/BT_FW_BCM4358A1_001.002.005.0032.0066.hcd
37 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
38 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh
39 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh