resetting manifest requested domain to floor
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
1 Name:       bluetooth-agent
2 Summary:    Bluetooth agent packages that support various external profiles
3 Version:    0.0.9
4 Release:    2
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     bluetooth-agent.manifest
9
10 BuildRequires:  pkgconfig(contacts-service2)
11 BuildRequires:  pkgconfig(dbus-glib-1)
12 BuildRequires:  pkgconfig(msg-service)
13 BuildRequires:  pkgconfig(email-service)
14 BuildRequires:  pkgconfig(tapi)
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(vconf)
17 BuildRequires:  pkgconfig(appsvc)
18 BuildRequires:  cmake
19
20 %description
21 Bluetooth agent packages that support various external profiles
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28 cmake . -DCMAKE_INSTALL_PREFIX=/usr
29
30 make VERBOSE=1
31
32 %install
33 rm -rf %{buildroot}
34 %make_install
35
36 %files
37 %manifest %{name}.manifest
38 %defattr(-, root, root)
39 %{_bindir}/bluetooth-map-agent
40 %{_bindir}/bluetooth-pb-agent
41 %{_bindir}/bluetooth-hfp-agent
42 %{_datadir}/dbus-1/services/org.bluez.pb_agent.service
43 %{_datadir}/dbus-1/services/org.bluez.map_agent.service
44 %{_datadir}/dbus-1/services/org.bluez.hfp_agent.service