Increase the version number to upload
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
1 Name:       bluetooth-agent
2 Summary:    Bluetooth agent packages that support various external profiles
3 Version:    0.0.9
4 Release:    2
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig(contacts-service2)
10 BuildRequires:  pkgconfig(dbus-glib-1)
11 BuildRequires:  pkgconfig(msg-service)
12 BuildRequires:  pkgconfig(email-service)
13 BuildRequires:  pkgconfig(tapi)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(appsvc)
17 BuildRequires:  cmake
18
19 %description
20 Bluetooth agent packages that support various external profiles
21
22 %prep
23 %setup -q
24
25 %build
26 cmake . -DCMAKE_INSTALL_PREFIX=/usr
27
28 make VERBOSE=1
29
30 %install
31 rm -rf %{buildroot}
32 %make_install
33
34 %files
35 %manifest bluetooth-agent.manifest
36 %defattr(-, root, root)
37 %{_bindir}/bluetooth-map-agent
38 %{_bindir}/bluetooth-pb-agent
39 %{_bindir}/bluetooth-hfp-agent
40 %{_datadir}/dbus-1/services/org.bluez.pb_agent.service
41 %{_datadir}/dbus-1/services/org.bluez.map_agent.service
42 %{_datadir}/dbus-1/services/org.bluez.hfp_agent.service