Fix the build error for wearable profile
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
1 %define _usrlibdir /usr/lib
2
3 Name:       bluetooth-agent
4 Summary:    Bluetooth agent packages that support various external profiles
5 Version:    0.1.0
6 Release:    1
7 Group:      Network & Connectivity/Bluetooth
8 License:    Apache-2.0
9 Source0:    %{name}-%{version}.tar.gz
10 Source1001:     bluetooth-agent.manifest
11
12 %if "%{?profile}" == "tv"
13 ExcludeArch: %{arm} %ix86 x86_64
14 %endif
15
16 BuildRequires:  pkgconfig(aul)
17 BuildRequires:  pkgconfig(bluetooth-api)
18 %if "%{?profile}" == "wearable"
19 BuildRequires:  pkgconfig(alarm-service)
20 BuildRequires:  pkgconfig(capi-appfw-app-manager)
21 BuildRequires:  pkgconfig(capi-system-device)
22 %else
23 BuildRequires:  pkgconfig(contacts-service2)
24 BuildRequires:  pkgconfig(msg-service)
25 BuildRequires:  pkgconfig(email-service)
26 %endif
27 BuildRequires:  pkgconfig(capi-system-info)
28 BuildRequires:  pkgconfig(dbus-glib-1)
29 BuildRequires:  pkgconfig(tapi)
30 BuildRequires:  pkgconfig(dlog)
31 BuildRequires:  pkgconfig(vconf)
32 BuildRequires:  pkgconfig(appsvc)
33 BuildRequires:  pkgconfig(capi-appfw-application)
34 BuildRequires:  pkgconfig(capi-media-image-util)
35 BuildRequires:  pkgconfig(contacts-service2)
36 BuildRequires:  pkgconfig(libexif)
37 BuildRequires:  pkgconfig(gio-2.0)
38 BuildRequires:  cmake
39 Requires: security-config
40
41 %description
42 Bluetooth agent packages that support various external profiles
43
44 %prep
45 %setup -q
46 cp %{SOURCE1001} .
47
48 %build
49 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
50 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
51 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
52 export CFLAGS="$CFLAGS -DTIZEN_MEDIA_ENHANCE"
53 export CFLAGS="$CFLAGS -DTIZEN_BT_HFP_AG_ENABLE"
54
55 %if "%{?profile}" == "wearable"
56 export CFLAGS="$CFLAGS -DTIZEN_WEARABLE"
57 export CFLAGS="$CFLAGS -DTIZEN_SUPPORT_LUNAR_DEVICE"
58 %else
59 export CFLAGS="$CFLAGS -DTIZEN_KIRAN"
60 %endif
61
62 export CFLAGS+=" -fpie -DPBAP_SIM_ENABLE"
63
64 export CFLAGS+=" -fpie -fvisibility=hidden"
65 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
66
67 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
68 %if "%{?profile}" == "wearable"
69         -DTIZEN_WEARABLE=1 \
70 %else
71         -DTIZEN_WEARABLE=0 \
72 %endif
73         -DTIZEN_BT_HFP_AG_ENABLE=1
74
75 make VERBOSE=1
76
77 %install
78 rm -rf %{buildroot}
79 %make_install
80
81 install -D -m 0644 LICENSE %{buildroot}%{_datadir}/license/bluetooth-agent
82 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
83 #%if "%{?profile}" != "wearable"
84 #install -m 0644 packaging/bluetooth-ag-agent.service %{buildroot}%{_unitdir}/
85 #ln -s ../bluetooth-ag-agent.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-ag-agent.service
86 #%endif
87 %if 0%{?sec_product_feature_bt_map_server_enable}
88 install -D -m 0644 packaging/bluetooth-map-agent.service %{buildroot}%{_libdir}/systemd/user/bluetooth-map-agent.service
89 %endif
90
91
92 %post
93 %if 0%{?sec_product_feature_bt_map_server_enable}
94 ln -sf %{_libdir}/systemd/user/bluetooth-map-agent.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
95 %endif
96
97 %files
98 %manifest %{name}.manifest
99 %defattr(-, root, root)
100 %if "%{?profile}" == "wearable"
101 %{_bindir}/bluetooth-hf-agent
102 %{_datadir}/dbus-1/system-services/org.bluez.hf_agent.service
103 %else
104 %{_bindir}/bluetooth-ag-agent
105 %{_bindir}/bluetooth-map-agent
106 %{_bindir}/bluetooth-pb-agent
107 %{_datadir}/dbus-1/system-services/org.bluez.pb_agent.service
108 %{_datadir}/dbus-1/system-services/org.bluez.map_agent.service
109 %{_datadir}/dbus-1/system-services/org.bluez.ag_agent.service
110 #%{_usrlibdir}/systemd/system/bluetooth-ag-agent.service
111 #%{_usrlibdir}/systemd/system/multi-user.target.wants/bluetooth-ag-agent.service
112 %attr(0666,-,-) /var/lib/bluetooth/voice-recognition-blacklist
113 %{_sysconfdir}/dbus-1/system.d/bluetooth-ag-agent.conf
114 %endif
115 %{_datadir}/license/bluetooth-agent