Merge branch 'master' into tizen_2.1
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
1 Name:       bluetooth-agent
2 Summary:    Bluetooth agent packages that support various external profiles
3 Version:    0.0.8
4 Release:    2
5 Group:      TO_BE/FILLED_IN
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig(aul)
10 BuildRequires:  pkgconfig(contacts-service2)
11 BuildRequires:  pkgconfig(dbus-glib-1)
12 BuildRequires:  pkgconfig(msg-service)
13 BuildRequires:  pkgconfig(tapi)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(appsvc)
17 BuildRequires:  pkgconfig(capi-appfw-application)
18 BuildRequires:  cmake
19
20 %description
21 Bluetooth agent packages that support various external profiles
22
23 %prep
24 %setup -q
25
26 %build
27 export CFLAGS+=" -fpie -fvisibility=hidden"
28 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
29
30 cmake . -DCMAKE_INSTALL_PREFIX=/usr
31
32 make VERBOSE=1
33
34 %install
35 rm -rf %{buildroot}
36 %make_install
37
38 %files
39 %manifest bluetooth-agent.manifest
40 %defattr(-, root, root)
41 %{_bindir}/bluetooth-map-agent
42 %{_bindir}/bluetooth-pb-agent
43 %{_bindir}/bluetooth-hfp-agent
44 %{_datadir}/dbus-1/services/org.bluez.pb_agent.service
45 %{_datadir}/dbus-1/services/org.bluez.map_agent.service
46 %{_datadir}/dbus-1/services/org.bluez.hfp_agent.service