packaging: Add tizen spec
[platform/upstream/bcc.git] / packaging / bcc-tools.spec
1 Name: bcc-tools
2 Version: 0.3.0
3 Release: 0
4 Summary: Tools for BPF-based Linux IO analysis, networking, monitoring
5 License: Apache-2.0
6 Vendor: None (open source)
7 Group: Development/Compilers
8 URL: https://github.com/iovisor/bcc
9 Source0:   %{name}-%{version}.tar.gz
10 Requires: /sbin/ldconfig
11 BuildRequires: gcc >= 3.4
12 BuildRequires: cmake python
13 BuildRequires: bison flex llvm-devel clang-devel libelf-devel
14 BuildRequires: llvm-static-devel
15
16 %description
17 BCC is a toolkit for creating efficient kernel tracing and manipulation
18 programs, and includes several useful tools and examples. It makes use
19 of extended BPF (Berkeley Packet Filters), formally known as eBPF, a new
20 feature that was first added to Linux 3.15. Much of what BCC uses
21 requires Linux 4.1 and above.
22
23 %package devel
24 Summary: Developer package for BCC
25 License: Apache-2.0
26
27 %description devel
28 bcc tools - devel
29 This package provides development libraries.
30
31 %prep
32 %setup -q -n bcc-tools-%{version}
33
34 %build
35
36 cmake -DCMAKE_INSTALL_PREFIX=/usr -DINSTALL_CPP_EXAMPLES=ON .
37
38 make %{?jobs:-j%jobs}
39
40 %install
41 %make_install
42
43 %clean
44 rm -rf %{buildroot}
45
46 %post -p /sbin/ldconfig
47
48 %postun -p /sbin/ldconfig
49
50 %files
51 %{_libdir}/libbpf.so
52 %{_libdir}/libbcc.so.*
53 %{_prefix}/lib/python2.7/site-packages/bcc*
54 %{_datadir}/bcc/*
55
56 %files devel
57 %{_includedir}/*
58 %{_libdir}/libbcc.so
59 %{_libdir}/pkgconfig/libbcc.pc
60