e13ec769d835e2c56f769c1284b9cc33a9044732
[platform/upstream/autoconf213.git] / packaging / autoconf213.spec
1 Name:           autoconf213
2 License:        GPL v2 or later
3 Group:          Development/Tools/Building
4 Url:            http://www.gnu.org/software/autoconf
5 AutoReqProv:    on
6 Requires:       gawk, m4 >= 1.1, mktemp, perl
7 Version:        2.13
8 Release:        1
9 Summary:        A GNU Tool for Automatically Configuring Source Code
10 BuildArch:      noarch
11 Source:         autoconf-%{version}.tar.bz2
12 BuildRequires:  texinfo
13 BuildRequires:  makeinfo
14
15 %description
16 GNU Autoconf is a tool for configuring source code and makefiles. Using
17 autoconf, programmers can create portable and configurable packages,
18 because the person building the package is allowed to specify various
19 configuration options.
20
21 You should install autoconf if you are developing software and would
22 like to create shell scripts to configure your source code packages.
23
24 Note that the autoconf package is not required for the end user who may
25 be configuring software with an autoconf-generated script; autoconf is
26 only required for the generation of the scripts, not their use.
27
28
29
30 Authors:
31 --------
32     Ben Elliston  <bje@cygnus.com>
33     David J MacKenzie  <djm@catapult.va.pubnix.com>
34
35 %prep
36 %setup -n autoconf-%{version} -q
37
38
39 mv autoconf.texi autoconf213.texi
40 rm -f autoconf.info
41
42 %build
43 ./configure --prefix=%{_prefix} --infodir=%{_infodir} --mandir=%{_mandir} \
44             --program-suffix=-2.13
45 make
46
47 %install
48 %make_install
49 # We don't want to include the standards.info stuff in the package,
50 # because it comes from binutils...
51 rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
52
53 %post
54 %install_info --info-dir=%{_infodir} %{_infodir}/autoconf2.13.info.gz
55
56 %postun
57 %install_info_delete --info-dir=%{_infodir} %{_infodir}/autoconf2.13.info.gz
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(-,root,root)
64 %doc AUTHORS COPYING NEWS README TODO
65 %{_prefix}/bin/*
66 %{_prefix}/share/autoconf-2.13
67 %doc %{_infodir}/*.gz