5af70e1c796efccd1ad8611f56824e9b1f3a0935
[platform/upstream/autoconf213.git] / packaging / autoconf213.spec
1 Name:           autoconf213
2 License:        GPL v2 or later
3 Group:          Development/Tools/Building
4 Url:            http://www.gnu.org/software/autoconf
5 AutoReqProv:    on
6 Requires:       gawk, m4 >= 1.1, mktemp, perl
7 Version:        2.13
8 Release:        1
9 Summary:        A GNU Tool for Automatically Configuring Source Code
10 BuildArch:      noarch
11 Source:         autoconf-%{version}.tar.bz2
12 Source1001:     autoconf213.manifest
13 BuildRequires:  texinfo
14 BuildRequires:  makeinfo
15
16 %description
17 GNU Autoconf is a tool for configuring source code and makefiles. Using
18 autoconf, programmers can create portable and configurable packages,
19 because the person building the package is allowed to specify various
20 configuration options.
21
22 You should install autoconf if you are developing software and would
23 like to create shell scripts to configure your source code packages.
24
25 Note that the autoconf package is not required for the end user who may
26 be configuring software with an autoconf-generated script; autoconf is
27 only required for the generation of the scripts, not their use.
28
29
30
31 Authors:
32 --------
33     Ben Elliston  <bje@cygnus.com>
34     David J MacKenzie  <djm@catapult.va.pubnix.com>
35
36 %prep
37 %setup -n autoconf-%{version} -q
38 cp %{SOURCE1001} .
39
40
41 mv autoconf.texi autoconf213.texi
42 rm -f autoconf.info
43
44 %build
45 ./configure --prefix=%{_prefix} --infodir=%{_infodir} --mandir=%{_mandir} \
46             --program-suffix=-2.13
47 make
48
49 %install
50 %make_install
51 # We don't want to include the standards.info stuff in the package,
52 # because it comes from binutils...
53 rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
54
55 %post
56 %install_info --info-dir=%{_infodir} %{_infodir}/autoconf2.13.info.gz
57
58 %postun
59 %install_info_delete --info-dir=%{_infodir} %{_infodir}/autoconf2.13.info.gz
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %manifest %{name}.manifest
66 %defattr(-,root,root)
67 %doc AUTHORS COPYING NEWS README TODO
68 %{_prefix}/bin/*
69 %{_prefix}/share/autoconf-2.13
70 %doc %{_infodir}/*.gz