resetting manifest requested domain to floor
[platform/upstream/autoconf.git] / packaging / autoconf.spec
1 Name:           autoconf
2 BuildRequires:  xz
3 BuildRequires:  m4 >= 1.4.6
4 Url:            http://www.gnu.org/software/autoconf
5 Requires:       m4 >= 1.4.6
6 Requires:       perl >= 5.6
7 Version:        2.69
8 Release:        0
9 Summary:        A GNU Tool for Automatically Configuring Source Code
10 License:        GPL-3.0+
11 Group:          Development/Tools/Building
12 Source:         autoconf-%{version}.tar.xz
13 Source1001:     autoconf.manifest
14 BuildArch:      noarch
15
16 %description
17 GNU Autoconf is a tool for configuring source code and makefiles. Using
18 autoconf, programmers can create portable and configurable packages,
19 because the person building the package is allowed to specify various
20 configuration options.
21
22 You should install autoconf if you are developing software and would
23 like to create shell scripts to configure your source code packages.
24
25 Note that the autoconf package is not required for the end user who may
26 be configuring software with an autoconf-generated script; autoconf is
27 only required for the generation of the scripts, not their use.
28
29 %prep
30 %setup -q -n autoconf-%{version}
31 cp %{SOURCE1001} .
32
33 %build
34 %configure
35 make %{?_smp_mflags}
36
37 %check
38 trap 'test $? -ne 0 && cat tests/testsuite.log' EXIT
39 make check
40
41 %install
42 %{?make_install} %{!?make_install:make install DESTDIR=%{buildroot}}
43 rm -f $RPM_BUILD_ROOT%{_prefix}/share/emacs/site-lisp/*.el*
44 # info's dir file is not auto ignored on some systems
45 rm -rf %{buildroot}%{_infodir}/dir
46
47 %post
48 %install_info --info-dir=%{_infodir} %{_infodir}/autoconf.info.gz
49
50 %postun
51 %install_info_delete --info-dir=%{_infodir} %{_infodir}/autoconf.info.gz
52
53
54 %files
55 %manifest %{name}.manifest
56 %defattr(-,root,root)
57 %doc COPYING
58 %{_prefix}/bin/*
59 %{_prefix}/share/autoconf
60 %doc %{_infodir}/*.gz
61 %doc %{_mandir}/man1/*.gz
62
63 %changelog