Correct VOICE_PCM_DEVICE to "hw:sprdphone,1" and remove an unused device AUDIO_DEVICE...
[platform/adaptation/spreadtrum/audio-hal-sc7727.git] / packaging / audio-hal-sc7727.spec
1 Name:       audio-hal-sc7727
2 Summary:    TIZEN Audio HAL for SC7727
3 Version:    0.1.2
4 Release:    0
5 Group:      System/Libraries
6 License:    Apache-2.0
7 URL:        http://tizen.org
8 Source0:    audio-hal-sc7727-%{version}.tar.gz
9 BuildRequires: pkgconfig(vconf)
10 BuildRequires: pkgconfig(iniparser)
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(alsa)
13 #BuildRequires: pkgconfig(tinyalsa)
14 Provides: libtizen-audio.so
15
16 %description
17 TIZEN Audio HAL for SC7727
18
19 %prep
20 %setup -q -n %{name}-%{version}
21
22 %build
23 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
24 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
25 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
26
27 export USE_TINYALSA="0"
28
29 %autogen
30 %configure
31
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36 mkdir -p %{buildroot}%{_datadir}/license
37 cp LICENSE.Apache-2.0 %{buildroot}%{_datadir}/license/%{name}
38 %make_install
39
40 %post
41 /sbin/ldconfig
42
43 %postun
44 /sbin/ldconfig
45
46 %files
47 %manifest audio-hal-sc7727.manifest
48 %defattr(-,root,root,-)
49 %{_libdir}/libtizen-audio.so
50 %{_datadir}/license/%{name}