Update to 2.7.4
[platform/upstream/atk.git] / packaging / atk.spec
1 %bcond_with introspection
2
3 Name:           atk
4 Version:        2.7.4
5 Release:        0
6 License:        LGPL-2.1+
7 Summary:        An Accessibility ToolKit
8 Url:            http://www.gtk.org/
9 Group:          System/Libraries
10 Source:         http://download.gnome.org/sources/atk/2.7/%{name}-%{version}.tar.xz
11 Source98:       baselibs.conf
12 BuildRequires:  fdupes
13 BuildRequires:  gcc-c++
14 BuildRequires:  glib2-devel >= 2.31.2
15 %if %{with introspection}
16 BuildRequires:  gobject-introspection-devel
17 %endif
18 Requires:       libatk
19
20 %description
21 The ATK library provides a set of accessibility interfaces. By
22 supporting the ATK interfaces, an application or toolkit can be used
23 with screen readers, magnifiers, and alternate input devices.
24
25 %package -n libatk
26 Summary:        An Accessibility ToolKit
27 Group:          System/Libraries
28 Provides:       %{name} = %{version}
29 Obsoletes:      %{name} < %{version}
30
31 %description -n libatk
32 The ATK library provides a set of accessibility interfaces. By
33 supporting the ATK interfaces, an application or toolkit can be used
34 with screen readers, magnifiers, and alternate input devices.
35
36 %package -n typelib-Atk
37 Summary:        An Accessibility ToolKit -- Introspection bindings
38 Group:          System/Libraries
39
40 %description -n typelib-Atk
41 The ATK library provides a set of accessibility interfaces. By
42 supporting the ATK interfaces, an application or toolkit can be used
43 with screen readers, magnifiers, and alternate input devices.
44
45 This package provides the GObject Introspection bindings for ATK.
46
47 %package devel
48 Summary:        Include Files and Libraries mandatory for Development
49 Group:          Development/Libraries/GNOME
50 Requires:       libatk = %{version}
51 %if %{with introspection}
52 Requires:       typelib-Atk = %{version}
53 %endif
54
55 %description devel
56 This package contains all necessary include files and libraries needed
57 to develop applications that require these.
58
59
60 %prep
61 %setup -q
62
63 %build
64 %configure \
65   --disable-static
66 make %{?_smp_mflags}
67
68 %install
69 %make_install
70 %fdupes %{buildroot}
71
72 %post -n libatk -p /sbin/ldconfig
73
74 %postun -n libatk -p /sbin/ldconfig
75
76 %files -n libatk
77 %defattr(-, root, root)
78 %license COPYING
79 %{_libdir}/lib*.so.*
80
81
82 %if %{with introspection}
83 %files -n typelib-Atk
84 %defattr(-, root, root)
85 %{_libdir}/girepository-1.0/Atk-1.0.typelib
86 %endif
87
88 %files devel
89 %defattr(-, root, root)
90 %{_includedir}/atk-1.0
91 %{_libdir}/lib*.so
92 %{_libdir}/pkgconfig/*.pc
93 %if %{with introspection}
94 %{_datadir}/gir-1.0/*.gir
95 %endif
96
97 %docs_package