[License] modify license to LGPL-2.0+
[platform/upstream/atk.git] / packaging / atk.spec
1 %bcond_with introspection
2 %define baseline 2.12
3 %define api_level 1.0
4 %define api_level_alpha 10
5
6
7 Name:           atk
8 Version:        2.12.0
9 Release:        0
10 License:        LGPL-2.0+
11 Summary:        An Accessibility ToolKit
12 Url:            http://www.gtk.org/
13 #X-Vc-Url:      git://git.gnome.org/atk
14 Group:          System/Libraries
15 Source:         http://download.gnome.org/sources/%{name}/%{baseline}/%{name}-%{version}.tar.xz
16 Source98:       baselibs.conf
17 Source1001:     %{name}.manifest
18 BuildRequires:  gettext-tools
19 BuildRequires:  gnome-common
20 BuildRequires:  gtk-doc
21 BuildRequires:  fdupes
22 BuildRequires:  gcc-c++
23 BuildRequires:  glib2-devel >= 2.35.2
24 %if %{with introspection}
25 BuildRequires:  gobject-introspection-devel
26 %endif
27 Requires:       lib%{name}
28
29 %description
30 The ATK library provides a set of accessibility interfaces. By
31 supporting the ATK interfaces, an application or toolkit can be used
32 with screen readers, magnifiers, and alternate input devices.
33
34 %package -n lib%{name}
35 Summary:        An Accessibility ToolKit
36 Group:          System/Libraries
37 Provides:       %{name} = %{version}
38 Obsoletes:      %{name} < %{version}
39
40 %description -n lib%{name}
41 The ATK library provides a set of accessibility interfaces. By
42 supporting the ATK interfaces, an application or toolkit can be used
43 with screen readers, magnifiers, and alternate input devices.
44
45 %package -n typelib-Atk
46 Summary:        An Accessibility ToolKit -- Introspection bindings
47 Group:          System/Libraries
48
49 %description -n typelib-Atk
50 The ATK library provides a set of accessibility interfaces. By
51 supporting the ATK interfaces, an application or toolkit can be used
52 with screen readers, magnifiers, and alternate input devices.
53
54 This package provides the GObject Introspection bindings for ATK.
55
56 %package devel
57 Summary:        Include Files and Libraries mandatory for Development
58 Group:          System/Libraries
59 Requires:       lib%{name} = %{version}-%{release}
60 %if %{with introspection}
61 Requires:       typelib-Atk = %{version}-%{release}
62 %endif
63
64 %description devel
65 This package contains all necessary include files and libraries needed
66 to develop applications that require these.
67
68
69 %prep
70 %setup -q
71 cp %{SOURCE1001} .
72
73 %build
74 NOCONFIGURE=1 ./autogen.sh
75
76 %configure \
77   --disable-static
78
79 %__make %{?_smp_mflags}
80
81
82 %install
83 %make_install
84 install -d %{buildroot}/usr/share/help
85
86 %find_lang %{name}%{api_level_alpha}
87 fdupes %{buildroot}
88
89 %post -n lib%{name} -p /sbin/ldconfig
90
91 %postun -n lib%{name} -p /sbin/ldconfig
92
93 %files -n lib%{name}
94 %manifest %{name}.manifest
95 %defattr(-, root, root)
96 %license COPYING
97 %{_libdir}/lib*.so.*
98
99
100 %if %{with introspection}
101 %files -n typelib-Atk
102 %manifest %{name}.manifest
103 %defattr(-, root, root)
104 %{_libdir}/girepository-%{api_level}/Atk-%{api_level}.typelib
105 %endif
106
107 %files devel
108 %manifest %{name}.manifest
109 %defattr(-, root, root)
110 %{_includedir}/%{name}-%{api_level}
111 %{_libdir}/lib*.so
112 %{_libdir}/pkgconfig/*.pc
113 %if %{with introspection}
114 %{_datadir}/gir-%{api_level}/*.gir
115 %endif
116
117
118 %lang_package -f %{name}%{api_level_alpha}