resetting manifest requested domain to floor
[platform/upstream/atk.git] / packaging / atk.spec
1 %bcond_with introspection
2
3 Name:           atk
4 Version:        2.8.0
5 Release:        0
6 License:        LGPL-2.1+
7 Summary:        An Accessibility ToolKit
8 Url:            http://www.gtk.org/
9 Group:          System/Libraries
10 Source:         http://download.gnome.org/sources/atk/2.8/%{name}-%{version}.tar.xz
11 Source98:       baselibs.conf
12 Source1001:     atk.manifest
13 BuildRequires:  fdupes
14 BuildRequires:  gcc-c++
15 BuildRequires:  glib2-devel >= 2.35.2
16 %if %{with introspection}
17 BuildRequires:  gobject-introspection-devel
18 %endif
19 Requires:       libatk
20
21 %description
22 The ATK library provides a set of accessibility interfaces. By
23 supporting the ATK interfaces, an application or toolkit can be used
24 with screen readers, magnifiers, and alternate input devices.
25
26 %package -n libatk
27 Summary:        An Accessibility ToolKit
28 Group:          System/Libraries
29 Provides:       %{name} = %{version}
30 Obsoletes:      %{name} < %{version}
31
32 %description -n libatk
33 The ATK library provides a set of accessibility interfaces. By
34 supporting the ATK interfaces, an application or toolkit can be used
35 with screen readers, magnifiers, and alternate input devices.
36
37 %package -n typelib-Atk
38 Summary:        An Accessibility ToolKit -- Introspection bindings
39 Group:          System/Libraries
40
41 %description -n typelib-Atk
42 The ATK library provides a set of accessibility interfaces. By
43 supporting the ATK interfaces, an application or toolkit can be used
44 with screen readers, magnifiers, and alternate input devices.
45
46 This package provides the GObject Introspection bindings for ATK.
47
48 %package devel
49 Summary:        Include Files and Libraries mandatory for Development
50 Group:          Development/Gnome
51 Requires:       libatk = %{version}
52 %if %{with introspection}
53 Requires:       typelib-Atk = %{version}
54 %endif
55
56 %description devel
57 This package contains all necessary include files and libraries needed
58 to develop applications that require these.
59
60
61 %prep
62 %setup -q
63 cp %{SOURCE1001} .
64
65 %build
66 %configure \
67   --disable-static
68 make %{?_smp_mflags}
69
70 %install
71 %make_install
72 %fdupes %{buildroot}
73
74 %post -n libatk -p /sbin/ldconfig
75
76 %postun -n libatk -p /sbin/ldconfig
77
78 %files -n libatk
79 %manifest %{name}.manifest
80 %defattr(-, root, root)
81 %license COPYING
82 %{_libdir}/lib*.so.*
83
84
85 %if %{with introspection}
86 %files -n typelib-Atk
87 %manifest %{name}.manifest
88 %defattr(-, root, root)
89 %{_libdir}/girepository-1.0/Atk-1.0.typelib
90 %endif
91
92 %files devel
93 %manifest %{name}.manifest
94 %defattr(-, root, root)
95 %{_includedir}/atk-1.0
96 %{_libdir}/lib*.so
97 %{_libdir}/pkgconfig/*.pc
98 %if %{with introspection}
99 %{_datadir}/gir-1.0/*.gir
100 %endif
101
102 %docs_package