Using %license macro to install license file instead of using manual command.
[platform/upstream/atk.git] / packaging / atk.spec
1 %define baseline 2.16
2 Name:           atk
3 Version:        2.16.0
4 Release:        0
5 License:        LGPL-2.0+
6 Summary:        An Accessibility ToolKit
7 Url:            http://www.gtk.org/
8 Group:          System/Libraries
9 Source:         http://download.gnome.org/sources/%{name}/%{baseline}/%{name}-%{version}.tar.xz
10 Source98:       baselibs.conf
11 Source1001:     %{name}.manifest
12
13 BuildRequires:  fdupes
14 BuildRequires:  gcc-c++
15 BuildRequires:  glib2-devel >= 2.35.2
16 BuildRequires:  intltool
17 BuildRequires:  which
18 %if %{with introspection}
19 BuildRequires:  gobject-introspection-devel
20 %endif
21 Requires:       libatk
22
23 %description
24 The ATK library provides a set of accessibility interfaces. By
25 supporting the ATK interfaces, an application or toolkit can be used
26 with screen readers, magnifiers, and alternate input devices.
27
28 %package -n libatk
29 Summary:        An Accessibility ToolKit
30 Group:          System/Libraries
31 Provides:       %{name} = %{version}
32 Obsoletes:      %{name} < %{version}
33
34 %description -n libatk
35 The ATK library provides a set of accessibility interfaces. By
36 supporting the ATK interfaces, an application or toolkit can be used
37 with screen readers, magnifiers, and alternate input devices.
38
39 %package -n typelib-Atk
40 Summary:        An Accessibility ToolKit -- Introspection bindings
41 Group:          System/Libraries
42
43 %description -n typelib-Atk
44 The ATK library provides a set of accessibility interfaces. By
45 supporting the ATK interfaces, an application or toolkit can be used
46 with screen readers, magnifiers, and alternate input devices.
47
48 This package provides the GObject Introspection bindings for ATK.
49
50 %package devel
51 Summary:        Include Files and Libraries mandatory for Development
52 Group:          Development/Libraries/GNOME
53 Requires:       libatk = %{version}
54
55 %description devel
56 This package contains all necessary include files and libraries needed
57 to develop applications that require these.
58
59 %prep
60 %setup -q
61 cp %{SOURCE1001} .
62
63 %build
64 %autogen \
65   --disable-static
66 make %{?_smp_mflags}
67
68 %install
69 %make_install
70 %fdupes %{buildroot}
71
72 %post -n libatk -p /sbin/ldconfig
73
74 %postun -n libatk -p /sbin/ldconfig
75
76 %files -n libatk
77 %manifest %{name}.manifest
78 %defattr(-, root, root)
79 %doc COPYING
80 %license COPYING
81 %{_libdir}/lib*.so.*
82
83 %files devel
84 %manifest %{name}.manifest
85 %defattr(-, root, root)
86 %{_includedir}/atk-1.0
87 %{_libdir}/lib*.so
88 %{_libdir}/pkgconfig/*.pc
89