launch universal-switch, if any of associated vconf flags is set
[platform/upstream/at-spi2-core.git] / packaging / at-spi2-core.spec
1 %bcond_with x
2
3 Name: at-spi2-core
4 Version: 2.26.1
5 Release: 0
6 Summary: Assistive Technology Service Provider Interface - D-Bus based implementation
7 License: LGPL-2.0+
8 Group: System/Libraries
9 Url: http://www.gnome.org/
10 Source: http://ftp.gnome.org/pub/GNOME/sources/at-spi2-core/2.26/%{name}-%{version}.tar.xz
11 Source1001:    %{name}.manifest
12 Requires:      dbus
13 BuildRequires: python-devel
14 BuildRequires: python-xml
15 BuildRequires: intltool
16 BuildRequires: dbus-devel
17 BuildRequires: glib2-devel
18 BuildRequires: gettext
19 BuildRequires: gtk-doc
20 %if %{with x}
21 BuildRequires: libX11-devel
22 BuildRequires: libXtst-devel
23 BuildRequires: libXi-devel
24 %endif
25 BuildRequires: pkgconfig(vconf)
26 BuildRequires: pkgconfig(appsvc)
27 BuildRequires: pkgconfig(dlog)
28 BuildRequires: pkgconfig(aul)
29 BuildRequires: gobject-introspection
30
31 %description
32 AT-SPI is a general interface for applications to make use of the
33 accessibility toolkit. This version is based on dbus.
34
35 This package contains the AT-SPI registry daemon. It provides a
36 mechanism for all assistive technologies to discover and interact
37 with applications running on the desktop.
38
39 %package -n libatspi0
40 Summary: An Accessibility ToolKit -- Library
41 Group: System/Libraries
42
43 %description -n libatspi0
44 AT-SPI is a general interface for applications to make use of the
45 accessibility toolkit. This version is based on dbus.
46
47 %package -n typelib-1_0-Atspi-2_0
48 Summary: An Accessibility ToolKit -- Introspection bindings
49 Group: System/Libraries
50
51 %description -n typelib-1_0-Atspi-2_0
52 AT-SPI is a general interface for applications to make use of the
53 accessibility toolkit. This version is based on dbus.
54
55 This package provides the GObject Introspection bindings for the
56 libatspi library.
57
58 %package devel
59 Summary: Include Files and Libraries mandatory for Development
60 Group: Development/Libraries
61 Requires: %{name} = %{version}
62 Requires: libatspi0 = %{version}
63 Requires: typelib-1_0-Atspi-2_0 = %{version}
64
65 %description devel
66 This package contains all necessary include files and libraries needed
67 to develop applications that require these.
68
69 %prep
70 %setup -q
71 cp %{SOURCE1001} .
72
73 %build
74 %autogen --libexecdir=%{_libexecdir}/at-spi2 \
75         --with-dbus-daemondir=%{_bindir} \
76 %if !%{with x}
77         --disable-x11 \
78 %endif
79         --disable-static
80 %__make %{?_smp_flags}
81
82 %install
83 rm -rf %{buildroot}
84 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
85
86 %make_install
87 %find_lang %{name}
88
89 %clean
90 rm -fr %{buildroot}
91
92 %post -n libatspi0 -p /sbin/ldconfig
93
94 %postun -n libatspi0 -p /sbin/ldconfig
95
96 %files -f %{name}.lang
97 %manifest %{name}.manifest
98 %defattr(-,root,root)
99 %{_bindir}/at_spi2_tool
100
101 %doc AUTHORS README
102 %license COPYING
103 %{_libexecdir}/at-spi2/at-spi-bus-launcher
104 %{_libexecdir}/at-spi2/at-spi2-registryd
105 %{_datadir}/defaults/at-spi2/accessibility.conf
106 %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
107 %{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
108 %{_datadir}/dbus-1/services/org.a11y.Bus.service
109 %{_prefix}/lib/systemd/user/at-spi-dbus-bus.service
110 %files -n libatspi0
111 %manifest %{name}.manifest
112 %defattr(-, root, root)
113 %{_libdir}/libatspi.so.0*
114
115 %files -n typelib-1_0-Atspi-2_0
116 %manifest %{name}.manifest
117 %defattr(-, root, root)
118
119 %files devel
120 %manifest %{name}.manifest
121 %defattr(-, root, root)
122 %{_includedir}/at-spi-2.0
123 %{_libdir}/libatspi.so
124 %{_libdir}/pkgconfig/atspi-2.pc