5cea9dc260db2a13ec90130b937a88535affa2ad
[platform/upstream/aspell.git] / packaging / aspell.spec
1 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
2 #
3 # All modifications and additions to the file contributed by third parties
4 # remain the property of their copyright owners, unless otherwise agreed
5 # upon. The license for this file, and modifications and additions to the
6 # file, is the same license as for the pristine package itself (unless the
7 # license for the pristine package is not an Open Source License, in which
8 # case the license is the MIT License). An "Open Source License" is a
9 # license that conforms to the Open Source Definition (Version 1.9)
10 # published by the Open Source Initiative.
11
12 Name:           aspell
13 Version:        0.60.6.1
14 Release:        0
15 License:        LGPL-2.1+
16 Summary:        A Free and Open Source Spell Checker
17 Url:            http://aspell.net/
18 Group:          System/Libraries
19 Source0:        ftp://ftp.gnu.org/gnu/aspell/%{name}-%{version}.tar.gz
20 BuildRequires:  fdupes
21 BuildRequires:  gcc-c++
22 BuildRequires:  gettext-tools
23 BuildRequires:  libtool
24 BuildRequires:  ncurses-devel
25
26 %description
27 GNU Aspell is a spell checker designed to eventually replace Ispell. It
28 can be used as a library or as an independent spell checker.
29
30 Its main feature is that it does a much better job of coming up with
31 possible suggestions than just about any other spell checker available
32 for the English language, including Ispell and Microsoft Word. It also
33 has many other technical enhancements over Ispell, such as using shared
34 memory for dictionaries and intelligently handling personal
35 dictionaries when more than one Aspell process is open at once.
36
37 %package devel
38 Summary:        Include Files and Libraries Mandatory for Development with aspell
39 Group:          Development/Libraries
40 Requires:       glibc-devel
41 Requires:       libaspell = %{version}
42 Requires:       libpspell = %{version}
43
44 %description devel
45 This package contains all necessary include files and libraries needed
46 to develop applications that require aspell.
47
48 %package ispell
49 Summary:        GNU Aspell - Ispell compatibility
50 Group:          System/Tools
51 Requires:       %{name} = %{version}
52
53 %description ispell
54 GNU Aspell is a spell checker designed to eventually replace Ispell. It
55 can be used as a library or as an independent spell checker.
56
57 This package contains an ispell script for compatibility reasons so that
58 programs that expect the "ispell" command will work correctly.
59
60 %package spell
61 Summary:        GNU Aspell - Spell compatibility
62 Group:          System/Tools
63 Requires:       %{name} = %{version}
64
65 %description spell
66 GNU Aspell is a spell checker designed to eventually replace Ispell. It
67 can be used as a library or as an independent spell checker.
68
69 This package contains a spell script for compatibility reasons so that programs
70 that expect the "spell" command will work correctly.
71
72 %package -n libaspell
73 Summary:        GNU Aspell Library
74 Group:          System/Libraries
75
76 %description -n libaspell
77 GNU Aspell is a spell checker designed to eventually replace Ispell. It
78 can be used as a library or as an independent spell checker.
79
80 This package contains the aspell library.
81
82 %package -n libpspell
83 Summary:        GNU Aspell - Pspell Compatibility Library
84 Group:          System/Libraries
85
86 %description -n libpspell
87 GNU Aspell is a spell checker designed to eventually replace Ispell. It
88 can be used as a library or as an independent spell checker.
89
90 This package contains the pspell compatibility library.
91
92 %prep
93 %setup -q
94
95 %build
96 autoreconf -fiv
97 export CXXFLAGS="%{optflags} `ncursesw6-config --cflags`"
98 #this is an ugly kludge , don't look :-)
99 export LDFLAGS="`ncursesw6-config --libs`"
100 %configure \
101     --enable-curses="-lncursesw" \
102  --disable-rpath
103
104 make %{?_smp_mflags}
105
106 %install
107 %make_install
108 # Links for compatibility reasons (ispell and spell)
109 ln -s %{_libdir}/aspell-0.60/ispell %{buildroot}%{_bindir}
110 ln -s %{_libdir}/aspell-0.60/spell %{buildroot}%{_bindir}
111 %fdupes -s %{buildroot}
112
113 %find_lang %{name}
114
115
116 %docs_package
117
118 %post -n libaspell -p /sbin/ldconfig
119
120 %postun -n libaspell -p /sbin/ldconfig
121
122 %post -n libpspell -p /sbin/ldconfig
123
124 %postun -n libpspell -p /sbin/ldconfig
125
126
127 %files -f %{name}.lang
128 %defattr(-,root,root,-)
129 %license COPYING 
130 %{_bindir}/aspell
131 %{_bindir}/aspell-import
132 %{_bindir}/pre*
133 %{_bindir}/run-with-aspell
134 %{_bindir}/word-list-compress
135
136 %files devel
137 %defattr(-,root,root,-)
138 %doc manual/aspell-dev.html/
139 %{_bindir}/pspell-config
140 %{_includedir}/pspell/
141 %{_includedir}/*.h
142 %{_libdir}/libaspell.so
143 %{_libdir}/libpspell.so
144 %doc %{_infodir}/%{name}-dev.info%{ext_info}
145 %doc %{_mandir}/man1/pspell-config.1%{ext_man}
146
147 %files ispell
148 %defattr(-,root,root,-)
149 %{_bindir}/ispell
150
151 %files spell
152 %defattr(-,root,root,-)
153 %{_bindir}/spell
154
155 %files -n libaspell
156 %defattr(-,root,root,-)
157 %{_libdir}/aspell-0.60/
158 %{_libdir}/libaspell.so.15*
159
160 %files -n libpspell
161 %defattr(-,root,root,-)
162 %{_libdir}/libpspell.so.15*