resetting manifest requested domain to floor
[platform/upstream/aspell.git] / packaging / aspell.spec
1 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
2 #
3 # All modifications and additions to the file contributed by third parties
4 # remain the property of their copyright owners, unless otherwise agreed
5 # upon. The license for this file, and modifications and additions to the
6 # file, is the same license as for the pristine package itself (unless the
7 # license for the pristine package is not an Open Source License, in which
8 # case the license is the MIT License). An "Open Source License" is a
9 # license that conforms to the Open Source Definition (Version 1.9)
10 # published by the Open Source Initiative.
11
12 Name:           aspell
13 Version:        0.60.6.1
14 Release:        0
15 License:        LGPL-2.1+
16 Summary:        A Free and Open Source Spell Checker
17 Url:            http://aspell.net/
18 Group:          System/Libraries
19 Source0:        ftp://ftp.gnu.org/gnu/aspell/%{name}-%{version}.tar.gz
20 Source1001:     aspell.manifest
21 BuildRequires:  fdupes
22 BuildRequires:  gcc-c++
23 BuildRequires:  gettext-tools
24 BuildRequires:  libtool
25 BuildRequires:  ncurses-devel
26
27 %description
28 GNU Aspell is a spell checker designed to eventually replace Ispell. It
29 can be used as a library or as an independent spell checker.
30
31 Its main feature is that it does a much better job of coming up with
32 possible suggestions than just about any other spell checker available
33 for the English language, including Ispell and Microsoft Word. It also
34 has many other technical enhancements over Ispell, such as using shared
35 memory for dictionaries and intelligently handling personal
36 dictionaries when more than one Aspell process is open at once.
37
38 %package devel
39 Summary:        Include Files and Libraries Mandatory for Development with aspell
40 Group:          Development/Libraries
41 Requires:       glibc-devel
42 Requires:       libaspell = %{version}
43 Requires:       libpspell = %{version}
44
45 %description devel
46 This package contains all necessary include files and libraries needed
47 to develop applications that require aspell.
48
49 %package ispell
50 Summary:        GNU Aspell - Ispell compatibility
51 Group:          System/Tools
52 Requires:       %{name} = %{version}
53
54 %description ispell
55 GNU Aspell is a spell checker designed to eventually replace Ispell. It
56 can be used as a library or as an independent spell checker.
57
58 This package contains an ispell script for compatibility reasons so that
59 programs that expect the "ispell" command will work correctly.
60
61 %package spell
62 Summary:        GNU Aspell - Spell compatibility
63 Group:          System/Tools
64 Requires:       %{name} = %{version}
65
66 %description spell
67 GNU Aspell is a spell checker designed to eventually replace Ispell. It
68 can be used as a library or as an independent spell checker.
69
70 This package contains a spell script for compatibility reasons so that programs
71 that expect the "spell" command will work correctly.
72
73 %package -n libaspell
74 Summary:        GNU Aspell Library
75 Group:          System/Libraries
76
77 %description -n libaspell
78 GNU Aspell is a spell checker designed to eventually replace Ispell. It
79 can be used as a library or as an independent spell checker.
80
81 This package contains the aspell library.
82
83 %package -n libpspell
84 Summary:        GNU Aspell - Pspell Compatibility Library
85 Group:          System/Libraries
86
87 %description -n libpspell
88 GNU Aspell is a spell checker designed to eventually replace Ispell. It
89 can be used as a library or as an independent spell checker.
90
91 This package contains the pspell compatibility library.
92
93 %prep
94 %setup -q
95 cp %{SOURCE1001} .
96
97 %build
98 autoreconf -fiv
99 export CXXFLAGS="%{optflags} `ncursesw6-config --cflags`"
100 #this is an ugly kludge , don't look :-)
101 export LDFLAGS="`ncursesw6-config --libs`"
102 %configure \
103     --enable-curses="-lncursesw" \
104  --disable-rpath
105
106 make %{?_smp_mflags}
107
108 %install
109 %make_install
110 # Links for compatibility reasons (ispell and spell)
111 ln -s %{_libdir}/aspell-0.60/ispell %{buildroot}%{_bindir}
112 ln -s %{_libdir}/aspell-0.60/spell %{buildroot}%{_bindir}
113 %fdupes -s %{buildroot}
114
115 %find_lang %{name}
116
117
118 %docs_package
119
120 %post -n libaspell -p /sbin/ldconfig
121
122 %postun -n libaspell -p /sbin/ldconfig
123
124 %post -n libpspell -p /sbin/ldconfig
125
126 %postun -n libpspell -p /sbin/ldconfig
127
128
129 %files -f %{name}.lang
130 %manifest %{name}.manifest
131 %defattr(-,root,root,-)
132 %license COPYING 
133 %{_bindir}/aspell
134 %{_bindir}/aspell-import
135 %{_bindir}/pre*
136 %{_bindir}/run-with-aspell
137 %{_bindir}/word-list-compress
138
139 %files devel
140 %manifest %{name}.manifest
141 %defattr(-,root,root,-)
142 %doc manual/aspell-dev.html/
143 %{_bindir}/pspell-config
144 %{_includedir}/pspell/
145 %{_includedir}/*.h
146 %{_libdir}/libaspell.so
147 %{_libdir}/libpspell.so
148 %doc %{_infodir}/%{name}-dev.info%{ext_info}
149 %doc %{_mandir}/man1/pspell-config.1%{ext_man}
150
151 %files ispell
152 %manifest %{name}.manifest
153 %defattr(-,root,root,-)
154 %{_bindir}/ispell
155
156 %files spell
157 %manifest %{name}.manifest
158 %defattr(-,root,root,-)
159 %{_bindir}/spell
160
161 %files -n libaspell
162 %manifest %{name}.manifest
163 %defattr(-,root,root,-)
164 %{_libdir}/aspell-0.60/
165 %{_libdir}/libaspell.so.15*
166
167 %files -n libpspell
168 %manifest %{name}.manifest
169 %defattr(-,root,root,-)
170 %{_libdir}/libpspell.so.15*