changing the spec file
[apps/osp/Internet.git] / packaging / apps.Internet.spec
1 Name:       apps.Internet
2 Summary:    Internet application
3 Version:    1.0.0.0
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(osp-content)
10 BuildRequires:  pkgconfig(osp-appfw)
11 BuildRequires:  osp-appfw-internal-devel
12 BuildRequires:  pkgconfig(osp-uifw)
13 BuildRequires:  osp-uifw-internal-devel
14 BuildRequires:  pkgconfig(osp-media)
15 BuildRequires:  osp-media-internal-devel
16 BuildRequires:  pkgconfig(osp-image)
17 BuildRequires:  osp-image-internal-devel
18 BuildRequires:  pkgconfig(osp-net)
19 BuildRequires:  osp-net-internal-devel
20 BuildRequires:  pkgconfig(osp-shell)
21 BuildRequires:  osp-shell-internal-devel
22 BuildRequires:  pkgconfig(osp-json)
23 BuildRequires:  pkgconfig(osp-web)
24 BuildRequires:  pkgconfig(osp-image-core)
25 BuildRequires:  pkgconfig(osp-locations)
26 BuildRequires:  hash-signer
27
28 %description
29 Verification application: Internet
30
31 %prep
32 %setup -q
33
34 %build
35 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
36 %ifarch %{ix86}
37 %if 0%{?simulator}
38 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
39 %else
40 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ " cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
41 %endif
42 %else
43 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
44 %endif
45
46 # Call make instruction with smp support
47 make %{?jobs:-j%jobs}
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}/usr/share/license
52 cp LICENSE.Flora %{buildroot}/usr/share/license/%{name}
53 %make_install
54 ###### for package signing step ######
55 PKG_ID=kmcele1k0n
56 %define tizen_sign 1
57 %define tizen_sign_base /usr/apps/${PKG_ID}
58 %define tizen_sign_level platform
59 %define tizen_author_sign 1
60 %define tizen_dist_sign 1
61
62 %post
63 /sbin/ldconfig
64 PKG_ID=kmcele1k0n
65 echo "/usr/etc/package-manager/backend/tpk -i /usr/apps/"${PKG_ID}
66 /usr/etc/package-manager/backend/tpk -i /usr/apps/${PKG_ID}
67 cp -f /usr/lib/osp/osp-ui-app-loader /usr/apps/${PKG_ID}/bin/Internet
68
69 %postun
70 /sbin/ldconfig
71 PKG_ID=kmcele1k0n
72 echo "/usr/etc/package-manager/backend/tpk -u "${PKG_ID}
73 /usr/etc/package-manager/backend/tpk -u ${PKG_ID}
74
75 %files
76 %defattr(-,root,root,-)
77 /usr/apps/*
78 /usr/share/license/%{name}