bd581213a85a76796f20b3a07aafd3252d036af4
[platform/framework/native/certificate-selector.git] / packaging / apps.CertificateSelector.spec
1 Name:                   apps.CertificateSelector
2 Summary:                The app-control of the certificate manager
3 Version:                1.2.2.0
4 Release:                1
5 Group:                  TO_BE/FILLED_IN
6 License:                Apache License, Version 2.0
7 Source0:                %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(osp-appfw)
10 BuildRequires:  osp-appfw-internal-devel
11 BuildRequires:  pkgconfig(osp-uifw)
12 BuildRequires:  hash-signer
13
14 # smack domain requires
15 Requires(post): osp-security-service
16
17 # runtime requires
18 Requires:               chromium
19 Requires:               pkgmgr
20
21 %description
22 The app-control of the certificate manager
23
24 %prep
25 %setup -q
26
27 %build
28 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
29 %ifarch %{ix86}
30 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
31 %else
32 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
33 %endif
34
35 # Call make instruction with smp support
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 mkdir -p %{buildroot}/usr/share/license
41 cp %{_builddir}/%{name}-%{version}/LICENSE.Apache-2.0 %{buildroot}/usr/share/license/%{name}
42
43 %make_install
44 ###### for package signing step ######
45 PKG_ID=hyCsE05ySM
46 %define tizen_sign 1
47 %define tizen_sign_base /usr/apps/${PKG_ID}
48 %define tizen_sign_level platform
49 %define tizen_author_sign 1
50 %define tizen_dist_sign 1
51
52 %post
53 /bin/rm -fr /opt/apps/hyCsE05ySM
54 /usr/etc/package-manager/backend/tpk -i /usr/apps/hyCsE05ySM
55
56 %files
57 %manifest apps.CertificateSelector.manifest
58 %defattr(-,root,root,-)
59 /usr/share/license/%{name}
60 /usr/apps/*