sync with master
[platform/framework/native/certificate-selector.git] / packaging / apps.CertificateSelector.spec
1 Name:                   apps.CertificateSelector
2 Summary:                The app-control of the certificate manager
3 Version:                1.2.1.0
4 Release:                1
5 Group:                  TO_BE/FILLED_IN
6 License:                Apache License, Version 2.0
7 Source0:                %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(osp-appfw)
10 BuildRequires:  osp-appfw-internal-devel
11 BuildRequires:  pkgconfig(osp-uifw)
12
13 Requires:               chromium
14 Requires:               osp-security-service
15 Requires:               pkgmgr
16
17 %description
18 The app-control of the certificate manager
19
20 %prep
21 %setup -q
22
23 %build
24 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
25 %ifarch %{ix86}
26 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
27 %else
28 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
29 %endif
30
31 # Call make instruction with smp support
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36 mkdir -p %{buildroot}/usr/share/license
37 cp %{_builddir}/%{name}-%{version}/LICENSE.Apache-2.0 %{buildroot}/usr/share/license/%{name}
38
39 %make_install
40
41 %post
42 /sbin/ldconfig
43 PKG_ID=hyCsE05ySM
44 pkgcmd -q -i -t tpk -p /usr/apps/${PKG_ID}
45
46 %postun
47 /sbin/ldconfig
48 PKG_ID=hyCsE05ySM
49 pkgcmd -q -u -t tpk -n ${PKG_ID}
50
51 %files
52 %defattr(-,root,root,-)
53 /usr/share/license/%{name}
54 /usr/apps/*