fix mount fail error during update
[platform/core/appfw/app2sd.git] / packaging / app2sd.spec
1 Name:       app2sd
2 Summary:    Application installation on external memory
3 Version:    0.5.27
4 Release:    1
5 Group:      Application Framework/Application Installer
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     app2sd.manifest
9
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(db-util)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(libssl)
14 BuildRequires:  pkgconfig(openssl)
15 BuildRequires:  pkgconfig(pkgmgr-info)
16 BuildRequires:  pkgconfig(vconf)
17
18 %description
19 Tizen application installation on external memory
20
21 %package devel
22 Summary:        Application install on external memory (devel)
23 Requires:       app2sd = %{version}-%{release}
24
25 %description devel
26 Tizen application installation on external memory (devel)
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31
32 %build
33 %cmake .
34 make %{?_smp_mflags}
35
36 %install
37 %make_install
38
39 mkdir -p %{buildroot}/usr/share/license
40 cp LICENSE %{buildroot}/usr/share/license/%{name}
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46 %files
47 %manifest %{name}.manifest
48 %defattr(-,root,root,-)
49 %{_libdir}/libapp2ext.so.*
50 %{_libdir}/libapp2sd.so*
51 /usr/share/license/%{name}
52
53 %files devel
54 %manifest %{name}.manifest
55 %defattr(-,root,root,-)
56 %{_includedir}/app2ext_interface.h
57 %{_libdir}/pkgconfig/app2sd.pc
58 %{_libdir}/libapp2sd.so
59 %{_libdir}/libapp2ext.so
60
61
62