a517556530721423b077dbc5f6063bedae89bc2b
[framework/appfw/app2sd.git] / packaging / app2sd.spec
1 Name:       app2sd
2 Summary:    Application installation on external memory
3 Version:    0.5.34
4 Release:    1
5 Group:      Application Framework/Application Installer
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig(libssl)
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(openssl)
13 BuildRequires:  pkgconfig(db-util)
14 BuildRequires:    pkgconfig(pkgmgr-info)
15 BuildRequires:    pkgconfig(libprivilege-control)
16 BuildRequires:  cmake
17
18 %description
19 Tizen application installation on external memory
20
21 %package devel
22 Summary:    Application install on external memory (devel)
23 Group:      Development/Libraries
24 Requires:   app2sd = %{version}-%{release}
25
26 %description devel
27 Tizen application installation on external memory (devel)
28
29 %prep
30 %setup -q
31
32 %build
33
34 %if 0%{?tizen_build_binary_release_type_eng}
35 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
36 export CXXFLAGS="$CXXFLAGS ?DTIZEN_ENGINEER_MODE"
37 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
38 %endif
39
40 %cmake .
41
42 make %{?jobs:-j%jobs}
43
44 %install
45 rm -rf %{buildroot}
46 %make_install
47
48 mkdir -p %{buildroot}/usr/share/license
49 cp LICENSE %{buildroot}/usr/share/license/%{name}
50
51 %post -p /sbin/ldconfig
52
53 %postun -p /sbin/ldconfig
54
55 %files
56 %manifest app2sd.manifest
57 %defattr(-,root,root,-)
58 %{_libdir}/libapp2ext.so.*
59 %{_libdir}/libapp2sd.so*
60 /usr/share/license/%{name}
61
62
63 %files devel
64 %defattr(-,root,root,-)
65 %{_includedir}/app2ext_interface.h
66 %{_libdir}/pkgconfig/app2sd.pc
67 %{_libdir}/libapp2sd.so
68 %{_libdir}/libapp2ext.so
69
70
71