update installed storage to pkgmgr db when pkg is moved
[framework/appfw/app2sd.git] / packaging / app2sd.spec
1 Name:       app2sd
2 Summary:    Application installation on external memory
3 Version:    0.5.13
4 Release:    1
5 Group:      Application Framework/Application Installer
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig(libssl)
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(openssl)
13 BuildRequires:  pkgconfig(db-util)
14 BuildRequires:    pkgconfig(pkgmgr-info)
15 BuildRequires:  cmake
16
17 %description
18 Tizen application installation on external memory
19
20 %package devel
21 Summary:    Application install on external memory (devel)
22 Group:      Development/Libraries
23 Requires:   app2sd = %{version}-%{release}
24
25 %description devel
26 Tizen application installation on external memory (devel)
27
28 %prep
29 %setup -q
30
31 %build
32 %cmake .
33
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %files
45 %manifest app2sd.manifest
46 %defattr(-,root,root,-)
47 %{_libdir}/libapp2ext.so.*
48 %{_libdir}/libapp2sd.so*
49
50
51 %files devel
52 %defattr(-,root,root,-)
53 %{_includedir}/app2ext_interface.h
54 %{_libdir}/pkgconfig/app2sd.pc
55 %{_libdir}/libapp2sd.so
56 %{_libdir}/libapp2ext.so
57
58
59