improve packaging
[platform/core/appfw/app2sd.git] / packaging / app2sd.spec
1 Name:           app2sd
2 Version:        0.5.22
3 Release:        1
4 License:        Apache-2.0
5 Summary:        Application installation on external memory
6 Group:          Application Framework/Package Management
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:     app2sd.manifest
9
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(db-util)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(libssl)
14 BuildRequires:  pkgconfig(openssl)
15 BuildRequires:  pkgconfig(pkgmgr-info)
16 BuildRequires:  pkgconfig(vconf)
17
18 %description
19 Tizen application installation on external memory
20
21 %package devel
22 Summary:        Application install on external memory (devel)
23 Requires:       app2sd = %{version}-%{release}
24
25 %description devel
26 Tizen application installation on external memory (devel)
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31
32 %build
33 %cmake .
34 make %{?_smp_mflags}
35
36 %install
37 %make_install
38
39 %post -p /sbin/ldconfig
40
41 %postun -p /sbin/ldconfig
42
43 %files
44 %manifest %{name}.manifest
45 %defattr(-,root,root,-)
46 %{_libdir}/libapp2ext.so.*
47 %{_libdir}/libapp2sd.so.*
48
49
50 %files devel
51 %manifest %{name}.manifest
52 %defattr(-,root,root,-)
53 %{_includedir}/app2ext_interface.h
54 %{_libdir}/pkgconfig/app2sd.pc
55 %{_libdir}/libapp2sd.so
56 %{_libdir}/libapp2ext.so
57
58
59