Release version 0.1.57
[platform/core/appfw/app-svc.git] / packaging / app-svc.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       app-svc
5 Summary:    Application Service
6 Version:    0.1.57
7 Release:    0
8 Group:      Application Framework/Service
9 License:    Apache-2.0
10 Source0:    %{name}-%{version}.tar.gz
11 Source1001: app-svc.manifest
12 Source1002: app-svc-tests.manifest
13
14 Requires(post):     /sbin/ldconfig
15 Requires(postun):   /sbin/ldconfig
16
17 BuildRequires: cmake
18
19 BuildRequires: pkgconfig(dlog)
20 BuildRequires: pkgconfig(bundle)
21 BuildRequires: pkgconfig(aul)
22 BuildRequires: pkgconfig(ecore)
23 %if %{with x}
24 BuildRequires:      pkgconfig(ecore-x)
25 %endif
26
27 %description
28 Application Service
29
30 %package devel
31 Summary:    App svc
32 Group:      Development/Application Framework
33 Requires:   %{name} = %{version}-%{release}
34 %description devel
35 %devel_desc
36
37 %package tests
38 Summary:    tests for App svc
39 Requires:   %{name} = %{version}
40
41 %description tests
42 tests for App svc
43
44 %prep
45 %setup -q
46 cp %{SOURCE1001} .
47 cp %{SOURCE1002} .
48
49 %build
50 %cmake . \
51 %if %{with wayland} && !%{with x}
52 -Dwith_wayland=TRUE
53 %else
54 -Dwith_x=TRUE
55 %endif
56
57 %__make %{?jobs:-j%jobs}
58
59 %install
60 %make_install
61
62 %post -p /sbin/ldconfig
63
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(-,root,root,-)
68 %manifest %{name}.manifest
69 %license LICENSE
70 %{_libdir}/libappsvc.so.0
71 %{_libdir}/libappsvc.so.0.1.0
72
73 %files devel
74 %defattr(-,root,root,-)
75 %manifest %{name}.manifest
76 %{_libdir}/pkgconfig/appsvc.pc
77 %{_libdir}/libappsvc.so
78 %{_includedir}/appsvc/*.h
79
80 %files tests
81 %manifest %{name}-tests.manifest
82 %{_bindir}/appsvc_test