Change rpm group classification
[platform/core/appfw/app-installers.git] / packaging / app-installers.spec
1 Name:           app-installers
2 Summary:        Application installers
3 Version:        1.0
4 Release:        0
5 Group:          Application Framework/Package Management
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8
9 BuildRequires:  libcap-devel
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(pkgmgr)
12 BuildRequires:  pkgconfig(pkgmgr-parser)
13 BuildRequires:  pkgconfig(pkgmgr-info)
14 BuildRequires:  pkgconfig(pkgmgr-installer)
15 BuildRequires:  pkgconfig(libxml-2.0)
16 BuildRequires:  pkgconfig(zlib)
17 BuildRequires:  pkgconfig(minizip)
18 BuildRequires:  boost-devel
19
20 %description
21 This is a meta package that installs the common application
22 installers of Tizen.
23
24 %package -n wgt-backend
25 Summary: Backend of WGT files
26
27 %description -n wgt-backend
28 Backend for standard widget files WGT
29
30 %package -n xpk-backend
31 Summary: Backend of XPK files
32
33 %description -n xpk-backend
34 Backend for standard widget files XPK
35
36 %prep
37 %setup -q
38
39 %build
40 %cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}
41 make %{?_smp_mflags}
42
43 %install
44 %make_install
45
46 mkdir -p %{buildroot}/etc/package-manager/backend
47 ln -s %{_bindir}/wgt-backend %{buildroot}%{_sysconfdir}/package-manager/backend/wgt
48 ln -s %{_bindir}/xpk-backend %{buildroot}%{_sysconfdir}/package-manager/backend/xpk
49
50 %post -p /sbin/ldconfig
51
52 %postun -p /sbin/ldconfig
53
54 %files
55 %defattr(-,root,root)
56 %{_libdir}/libcommon-installer.so*
57 %license LICENSE
58
59 %files -n wgt-backend
60 %{_sysconfdir}/package-manager/backend/wgt
61 %{_bindir}/wgt-backend
62
63 %files -n xpk-backend
64 %{_sysconfdir}/package-manager/backend/xpk