fixed build on x86_64 and clean up CFLAGS
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 Name:       app-core
2 Summary:    Application basic
3 Version:    1.2
4 Release:    41
5 Group:      Application Framework
6 License:    Apache License, Version 2.0
7 Source0:    app-core-%{version}.tar.gz
8 Source101:  packaging/core-efl.target
9 BuildRequires:  pkgconfig(sensor)
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(aul)
12 BuildRequires:  pkgconfig(rua)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(x11)
15 BuildRequires:  pkgconfig(sysman)
16 BuildRequires:  pkgconfig(elementary)
17 BuildRequires:  pkgconfig(ecore)
18 BuildRequires:  pkgconfig(ecore-x)
19 BuildRequires:  pkgconfig(gobject-2.0)
20 BuildRequires:  pkgconfig(glib-2.0)
21 BuildRequires:  cmake
22 BuildRequires:  sysman-devel
23
24
25 %description
26 SLP common application basic
27
28
29
30 %package efl
31 Summary:    App basic EFL
32 Group:      Development/Libraries
33 Requires(post): /sbin/ldconfig
34 Requires(postun): /sbin/ldconfig
35
36 %description efl
37 Application basic EFL
38
39 %package efl-devel
40 Summary:    App basic EFL (devel)
41 Group:      Development/Libraries
42 Requires:   %{name}-efl = %{version}-%{release}
43 Requires:   %{name}-common-devel = %{version}-%{release}
44
45 %description efl-devel
46 Application basic EFL (devel)
47
48 %package common
49 Summary:    App basics common
50 Group:      Development/Libraries
51 Requires(post): /sbin/ldconfig
52 Requires(postun): /sbin/ldconfig
53
54 %description common
55 Application basics common
56
57 %package common-devel
58 Summary:    App basics common (devel)
59 Group:      Development/Libraries
60 Requires:   %{name}-common = %{version}-%{release}
61 Requires:   pkgconfig(sensor)
62 Requires:   pkgconfig(vconf)
63 Requires:   pkgconfig(elementary)
64 Requires:   pkgconfig(aul)
65
66 %description common-devel
67 Application basics common (devel)
68
69 %package template
70 Summary:    App basics template
71 Group:      Development/Libraries
72
73 %description template
74 Application basics template
75
76
77 %prep
78 %setup -q 
79
80 %build
81 %cmake . -DENABLE_GTK=OFF
82
83
84 make %{?jobs:-j%jobs}
85
86 %install
87 rm -rf %{buildroot}
88 %make_install
89 install -d %{buildroot}%{_prefix}/lib/systemd/user/core-efl.target.wants
90 install -m0644 %{SOURCE101} %{buildroot}%{_prefix}/lib/systemd/user/
91
92
93 %post efl -p /sbin/ldconfig
94
95 %postun efl -p /sbin/ldconfig
96
97 %post common -p /sbin/ldconfig
98
99 %postun common -p /sbin/ldconfig
100
101
102
103
104
105 %files efl
106 %manifest app-core.manifest
107 %defattr(-,root,root,-)
108 %{_libdir}/libappcore-efl.so.*
109
110 %files efl-devel
111 %defattr(-,root,root,-)
112 %{_includedir}/appcore/appcore-efl.h
113 %{_libdir}/libappcore-efl.so
114 %{_libdir}/pkgconfig/appcore-efl.pc
115
116 %files common
117 %manifest app-core.manifest
118 %defattr(-,root,root,-)
119 %{_libdir}/libappcore-common.so.*
120 %{_prefix}/lib/systemd/user/core-efl.target
121 %{_prefix}/lib/systemd/user/core-efl.target.wants/
122
123 %files common-devel
124 %defattr(-,root,root,-)
125 %{_libdir}/libappcore-common.so
126 %{_libdir}/pkgconfig/appcore-common.pc
127 %{_includedir}/appcore/appcore-common.h
128 %{_includedir}/SLP_Appcore_PG.h
129