Clean spec file
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           app-core
5 Summary:        Application basic
6 Version:        1.2
7 Release:        0
8 Group:          Application Framework/Libraries
9 License:        Apache-2.0
10 Source0:        app-core-%{version}.tar.gz
11 %if %{with wayland} && !%{with x}
12 Source101:      packaging/core-efl-wayland.target
13 %else
14 Source101:      packaging/core-efl-x.target
15 BuildRequires:  pkgconfig(x11)
16 BuildRequires:  pkgconfig(ecore-x)
17 %endif
18 Source1001:     app-core.manifest
19 BuildRequires:  pkgconfig(sensor)
20 BuildRequires:  pkgconfig(vconf)
21 BuildRequires:  pkgconfig(aul)
22 BuildRequires:  pkgconfig(rua)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(elementary)
25 BuildRequires:  pkgconfig(ecore)
26 BuildRequires:  pkgconfig(gobject-2.0)
27 BuildRequires:  pkgconfig(glib-2.0)
28 BuildRequires:  pkgconfig(libtzplatform-config)
29 BuildRequires:  cmake
30
31 %description
32 SLP common application basic
33
34
35 %package efl
36 Summary:    App basic EFL
37 Group:      Development/Libraries
38 Requires(post): /sbin/ldconfig
39 Requires(postun): /sbin/ldconfig
40
41 %description efl
42 Application basic EFL
43
44
45 %package efl-devel
46 Summary:    App basic EFL (devel)
47 Group:      Development/Libraries
48 Requires:   %{name}-efl = %{version}-%{release}
49 Requires:   %{name}-common-devel = %{version}-%{release}
50
51 %description efl-devel
52 Application basic EFL (devel)
53
54
55 %package common
56 Summary:    App basics common
57 Group:      Development/Libraries
58 Requires(post): /sbin/ldconfig
59 Requires(postun): /sbin/ldconfig
60
61 %description common
62 Application basics common
63
64
65 %package common-devel
66 Summary:    App basics common (devel)
67 Group:      Development/Libraries
68 Requires:   %{name}-common = %{version}-%{release}
69 Requires:   pkgconfig(sensor)
70 Requires:   pkgconfig(vconf)
71 Requires:   pkgconfig(elementary)
72 Requires:   pkgconfig(aul)
73 %if %{with x}
74 Requires:  pkgconfig(x11)
75 %endif
76
77 %description common-devel
78 Application basics common (devel)
79
80
81 %package template
82 Summary:    App basics template
83 Group:      Development/Libraries
84
85 %description template
86 Application basics template
87
88
89 %prep
90 %setup -q 
91 cp %{SOURCE1001} .
92
93
94 %build
95
96 %cmake . \
97 %if %{with wayland} && !%{with x}
98 -Dwith_wayland=TRUE\
99 %endif
100 -DENABLE_GTK=OFF
101
102 make %{?jobs:-j%jobs}
103
104
105 %install
106 rm -rf %{buildroot}
107 %make_install
108 install -d %{buildroot}%{_unitdir_user}/core-efl.target.wants
109 install -m0644 %{SOURCE101} %{buildroot}%{_unitdir_user}/core-efl.target
110
111
112 %post -n app-core-efl -p /sbin/ldconfig
113
114 %postun -n app-core-efl -p /sbin/ldconfig
115
116 %post -n app-core-common -p /sbin/ldconfig
117
118 %postun -n app-core-common -p /sbin/ldconfig
119
120
121 %files efl
122 %manifest %{name}.manifest
123 %defattr(-,root,root,-)
124 %{_libdir}/libappcore-efl.so.*
125 %license LICENSE
126
127 %files efl-devel
128 %manifest %{name}.manifest
129 %defattr(-,root,root,-)
130 %{_includedir}/appcore/appcore-efl.h
131 %{_libdir}/libappcore-efl.so
132 %{_libdir}/pkgconfig/appcore-efl.pc
133
134 %files common
135 %manifest %{name}.manifest
136 %defattr(-,root,root,-)
137 %{_libdir}/libappcore-common.so.*
138 %{_prefix}/lib/systemd/user/core-efl.target
139 %{_prefix}/lib/systemd/user/core-efl.target.wants/
140 %license LICENSE
141
142 %files common-devel
143 %manifest %{name}.manifest
144 %defattr(-,root,root,-)
145 %{_libdir}/libappcore-common.so
146 %{_libdir}/pkgconfig/appcore-common.pc
147 %{_includedir}/appcore/appcore-common.h
148 %{_includedir}/SLP_Appcore_PG.h