Merge "Add new api for customizing main loop" into tizen
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           app-core
5 Summary:        Application basic
6 Version:        1.2
7 Release:        0
8 Group:          Application Framework/Libraries
9 License:        Apache-2.0
10 Source0:        app-core-%{version}.tar.gz
11 %if %{with x}
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(ecore-x)
14 BuildRequires:  pkgconfig(eina)
15 %else
16 %if %{with wayland}
17 BuildRequires:  pkgconfig(ecore-wayland)
18 %endif
19 %endif
20 Source1001:     app-core.manifest
21 BuildRequires:  pkgconfig(dbus-1)
22 BuildRequires:  pkgconfig(sensor)
23 BuildRequires:  pkgconfig(vconf)
24 BuildRequires:  pkgconfig(aul)
25 BuildRequires:  pkgconfig(rua)
26 BuildRequires:  pkgconfig(dlog)
27 BuildRequires:  pkgconfig(elementary)
28 BuildRequires:  pkgconfig(ecore)
29 BuildRequires:  pkgconfig(gobject-2.0)
30 BuildRequires:  pkgconfig(glib-2.0)
31 BuildRequires:  pkgconfig(libtzplatform-config)
32 BuildRequires:  pkgconfig(pkgmgr-info)
33 BuildRequires:  cmake
34
35 %description
36 SLP common application basic
37
38
39 %package efl
40 Summary:    App basic EFL
41 Group:      Development/Libraries
42 Requires(post): /sbin/ldconfig
43 Requires(postun): /sbin/ldconfig
44
45 %description efl
46 Application basic EFL
47
48
49 %package efl-devel
50 Summary:    App basic EFL (devel)
51 Group:      Development/Libraries
52 Requires:   %{name}-efl = %{version}-%{release}
53 Requires:   %{name}-common-devel = %{version}-%{release}
54
55 %description efl-devel
56 Application basic EFL (devel)
57
58
59 %package common
60 Summary:    App basics common
61 Group:      Development/Libraries
62 Requires(post): /sbin/ldconfig
63 Requires(postun): /sbin/ldconfig
64
65 %description common
66 Application basics common
67
68
69 %package common-devel
70 Summary:    App basics common (devel)
71 Group:      Development/Libraries
72 Requires:   %{name}-common = %{version}-%{release}
73 Requires:   pkgconfig(sensor)
74 Requires:   pkgconfig(vconf)
75 Requires:   pkgconfig(elementary)
76 Requires:   pkgconfig(aul)
77 %if %{with x}
78 Requires:   pkgconfig(x11)
79 %endif
80
81 %description common-devel
82 Application basics common (devel)
83
84
85 %package template
86 Summary:    App basics template
87 Group:      Development/Libraries
88
89 %description template
90 Application basics template
91
92
93 %prep
94 %setup -q
95 cp %{SOURCE1001} .
96
97
98 %build
99
100 %cmake . \
101 %if %{with wayland}
102 -Dwith_wayland=TRUE\
103 %endif
104 %if %{with x}
105 -Dwith_x11=TRUE\
106 %endif
107 -DENABLE_GTK=OFF
108
109 make %{?_smp_mflags}
110
111
112 %install
113 rm -rf %{buildroot}
114 %make_install
115
116
117 %post -n app-core-efl -p /sbin/ldconfig
118
119 %postun -n app-core-efl -p /sbin/ldconfig
120
121 %post -n app-core-common -p /sbin/ldconfig
122
123 %postun -n app-core-common -p /sbin/ldconfig
124
125
126 %files efl
127 %manifest %{name}.manifest
128 %{_libdir}/libappcore-efl.so.*
129 %license LICENSE
130
131 %files efl-devel
132 %manifest %{name}.manifest
133 %{_includedir}/appcore/appcore-efl.h
134 %{_libdir}/libappcore-efl.so
135 %{_libdir}/pkgconfig/appcore-efl.pc
136
137 %files common
138 %manifest %{name}.manifest
139 %{_libdir}/libappcore-common.so.*
140 %license LICENSE
141
142 %files common-devel
143 %manifest %{name}.manifest
144 %{_libdir}/libappcore-common.so
145 %{_libdir}/pkgconfig/appcore-common.pc
146 %{_includedir}/appcore/appcore-common.h
147 %{_includedir}/SLP_Appcore_PG.h