Release version 1.18.3
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 Name:           app-core
2 Summary:        Application basic
3 Version:        1.18.3
4 Release:        0
5 Group:          Application Framework/Libraries
6 License:        Apache-2.0
7 Source0:        app-core-%{version}.tar.gz
8 BuildRequires:  pkgconfig(ecore-wl2)
9 BuildRequires:  pkgconfig(wayland-client)
10 BuildRequires:  pkgconfig(tizen-extension-client)
11 BuildRequires:  pkgconfig(wayland-tbm-client)
12 Source1001:     app-core.manifest
13 BuildRequires:  pkgconfig(gio-2.0)
14 BuildRequires:  pkgconfig(sensor)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(aul)
17 BuildRequires:  pkgconfig(bundle)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(elementary)
20 BuildRequires:  pkgconfig(ecore)
21 BuildRequires:  pkgconfig(gobject-2.0)
22 BuildRequires:  pkgconfig(glib-2.0)
23 BuildRequires:  pkgconfig(pkgmgr-info)
24 BuildRequires:  pkgconfig(ttrace)
25 BuildRequires:  pkgconfig(gmock)
26 BuildRequires:  cmake
27 BuildRequires:  pkgconfig(capi-system-info)
28
29 %if 0%{?gcov:1}
30 BuildRequires:  lcov
31 BuildRequires:  zip
32 %endif
33
34 %description
35 SLP common application basic
36
37
38 %package efl
39 Summary:    App basic EFL
40 Group:      Development/Libraries
41 Requires(post): /sbin/ldconfig
42 Requires(postun): /sbin/ldconfig
43
44 %description efl
45 Application basic EFL
46
47
48 %package efl-devel
49 Summary:    App basic EFL (devel)
50 Group:      Development/Libraries
51 Requires:   %{name}-efl = %{version}-%{release}
52 Requires:   %{name}-ui-devel = %{version}-%{release}
53
54 %description efl-devel
55 Application basic EFL (devel)
56
57 %package multiwindow
58 Summary:    Application core for multiwindow
59 Group:      Development/Libraries
60 Requires(post): /sbin/ldconfig
61 Requires(postun): /sbin/ldconfig
62
63 %description multiwindow
64 Application core for multiwindow
65
66 %package multiwindow-devel
67 Summary:    Application core for multiwindow (devel)
68 Group:      Development/Libraries
69 Requires:   %{name}-multiwindow = %{version}-%{release}
70 Requires:   %{name}-common-devel = %{version}-%{release}
71
72 %description multiwindow-devel
73 Application core for multiwindow (devel)
74
75 %package common
76 Summary:    App basics common
77 Group:      Development/Libraries
78 Requires(post): /sbin/ldconfig
79 Requires(postun): /sbin/ldconfig
80
81 %description common
82 Application basics common
83
84
85 %package common-devel
86 Summary:    App basics common (devel)
87 Group:      Development/Libraries
88 Requires:   %{name}-common = %{version}-%{release}
89 Requires:   pkgconfig(sensor)
90 Requires:   pkgconfig(vconf)
91 Requires:   pkgconfig(elementary)
92 Requires:   pkgconfig(aul)
93
94 %description common-devel
95 Application basics common (devel)
96
97 %package ui
98 Summary:    App basic UI
99 Group:      Development/Libraries
100 Requires(post): /sbin/ldconfig
101 Requires(postun): /sbin/ldconfig
102
103 %description ui
104 Application basic UI
105
106 %package ui-devel
107 Summary:    App basic UI (devel)
108 Group:      Development/Libraries
109 Requires:   %{name}-ui = %{version}-%{release}
110 Requires:   %{name}-common-devel = %{version}-%{release}
111
112 %description ui-devel
113 Application basic EFL (devel)
114
115
116 %package template
117 Summary:    App basics template
118 Group:      Development/Libraries
119
120 %description template
121 Application basics template
122
123
124 %if 0%{?gcov:1}
125 %package gcov
126 Summary:  Application Core API(gcov)
127 Group:    Application Framework/Libraries
128
129 %description gcov
130 gcov objects of a widget application library
131 %endif
132
133 %prep
134 %setup -q
135 cp %{SOURCE1001} .
136
137 %build
138 %if 0%{?gcov:1}
139 export CFLAGS+=" -fprofile-arcs -ftest-coverage"
140 export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
141 export FFLAGS+=" -fprofile-arcs -ftest-coverage"
142 export LDFLAGS+=" -lgcov"
143 %endif
144 export CFLAGS+=" -DEFL_BETA_API_SUPPORT "
145 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
146 %cmake . \
147         -DENABLE_GTK=OFF \
148         -DFULLVER=%{version} \
149         -DMAJORVER=${MAJORVER}
150
151 make %{?_smp_mflags}
152
153 %if 0%{?gcov:1}
154 mkdir -p gcov-obj
155 find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
156 %endif
157
158 %install
159 rm -rf %{buildroot}
160 %make_install
161
162 %if 0%{?gcov:1}
163 mkdir -p %{buildroot}%{_datadir}/gcov/obj/%{name}
164 install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj/%{name}
165 %endif
166
167 %check
168 ctest -V
169 %if 0%{?gcov:1}
170 lcov -c --ignore-errors graph --no-external -q -d . -o app-core.info
171 genhtml app-core.info -o app-core.out
172 zip -r app-core.zip app-core.out
173 install -m 0644 app-core.zip %{buildroot}%{_datadir}/gcov/
174 %endif
175
176
177 %post -n app-core-efl -p /sbin/ldconfig
178
179 %postun -n app-core-efl -p /sbin/ldconfig
180
181 %post -n app-core-multiwindow -p /sbin/ldconfig
182
183 %postun -n app-core-multiwindow -p /sbin/ldconfig
184
185 %post -n app-core-common -p /sbin/ldconfig
186
187 %postun -n app-core-common -p /sbin/ldconfig
188
189 %post -n app-core-ui -p /sbin/ldconfig
190
191 %postun -n app-core-ui -p /sbin/ldconfig
192
193 %files efl
194 %manifest %{name}.manifest
195 %{_libdir}/libappcore-efl.so.*
196
197 %{_libdir}/libapp-core-efl-cpp.so.*
198 %license LICENSE
199
200 %files efl-devel
201 %manifest %{name}.manifest
202 %{_includedir}/appcore/appcore-efl.h
203 %{_includedir}/appcore/appcore_efl_base.h
204 %{_libdir}/libappcore-efl.so
205 %{_libdir}/pkgconfig/appcore-efl.pc
206
207 %{_includedir}/appcore_cpp/app_core_efl_base.hh
208 %{_libdir}/libapp-core-efl-cpp.so
209 %{_libdir}/pkgconfig/app-core-efl-cpp.pc
210
211 %files multiwindow
212 %manifest %{name}.manifest
213 %{_libdir}/libappcore-multiwindow.so.*
214
215 %{_libdir}/libapp-core-multi-window-cpp.so.*
216 %license LICENSE
217
218 %files multiwindow-devel
219 %manifest %{name}.manifest
220 %{_includedir}/appcore/appcore_multiwindow_base.h
221 %{_libdir}/libappcore-multiwindow.so
222 %{_libdir}/pkgconfig/appcore-multiwindow.pc
223
224 %{_includedir}/appcore_cpp/app_core_multi_window_base.hh
225 %{_libdir}/libapp-core-multi-window-cpp.so
226 %{_libdir}/pkgconfig/app-core-multi-window-cpp.pc
227
228 %files common
229 %manifest %{name}.manifest
230 %{_libdir}/libappcore-common.so.*
231
232 %{_libdir}/libapp-core-cpp.so.*
233 %license LICENSE
234
235 %files common-devel
236 %manifest %{name}.manifest
237 %{_libdir}/libappcore-common.so
238 %{_libdir}/pkgconfig/appcore-common.pc
239 %{_includedir}/appcore/appcore-common.h
240 %{_includedir}/appcore/appcore_base.h
241 %{_includedir}/appcore/appcore_watchdog.h
242 %{_includedir}/appcore/appcore_base_control.h
243
244 %{_includedir}/appcore_cpp/app_core_base.hh
245 %{_includedir}/appcore_cpp/interface_app_core.hh
246 %{_includedir}/appcore_cpp/interface_app_core_ui.hh
247 %{_includedir}/appcore_cpp/interface_app_core_ui_event.hh
248 %{_includedir}/appcore_cpp/interface_main_loop.hh
249 %{_includedir}/appcore_cpp/interface_window.hh
250 %{_libdir}/libapp-core-cpp.so
251 %{_libdir}/pkgconfig/app-core-cpp.pc
252
253 %files ui
254 %manifest %{name}.manifest
255 %{_libdir}/libappcore-ui.so.*
256
257 %{_libdir}/libapp-core-ui-cpp.so.*
258 %license LICENSE
259
260 %files ui-devel
261 %manifest %{name}.manifest
262 %{_includedir}/appcore/appcore_ui_base.h
263 %{_libdir}/libappcore-ui.so
264 %{_libdir}/pkgconfig/appcore-ui.pc
265
266 %{_includedir}/appcore_cpp/app_core_task_base.hh
267 %{_includedir}/appcore_cpp/app_core_ui_base.hh
268 %{_includedir}/appcore_cpp/api/app_core_ui_base.h
269 %{_libdir}/libapp-core-ui-cpp.so
270 %{_libdir}/pkgconfig/app-core-ui-cpp.pc
271
272 %if 0%{?gcov:1}
273 %files gcov
274 %{_datadir}/gcov/*
275 %endif