a878ca0f27f814a55d4ad01182cca768095cf9b0
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       app-core
5 Summary:    Application basic
6 Version:    1.2
7 Release:    48
8 Group:      Application Framework
9 License:    Apache License, Version 2.0
10 Source0:    app-core-%{version}.tar.gz
11 %if %{with wayland} && !%{with x}
12 Source101:  packaging/core-efl-wayland.target
13 %else
14 Source101:  packaging/core-efl-x.target
15 BuildRequires:  pkgconfig(x11)
16 BuildRequires:  pkgconfig(ecore-x)
17 %endif
18 Source1001:     app-core.manifest
19 BuildRequires:  pkgconfig(sensor)
20 BuildRequires:  pkgconfig(vconf)
21 BuildRequires:  pkgconfig(aul)
22 BuildRequires:  pkgconfig(rua)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(elementary)
25 BuildRequires:  pkgconfig(ecore)
26 BuildRequires:  pkgconfig(gobject-2.0)
27 BuildRequires:  pkgconfig(glib-2.0)
28 BuildRequires:  cmake
29
30
31 %description
32 SLP common application basic
33
34
35
36 %package efl
37 Summary:    App basic EFL
38 Group:      Development/Libraries
39 Requires(post): /sbin/ldconfig
40 Requires(postun): /sbin/ldconfig
41
42 %description efl
43 Application basic EFL
44
45 %package efl-devel
46 Summary:    App basic EFL (devel)
47 Group:      Development/Libraries
48 Requires:   %{name}-efl = %{version}-%{release}
49 Requires:   %{name}-common-devel = %{version}-%{release}
50
51 %description efl-devel
52 Application basic EFL (devel)
53
54 %package common
55 Summary:    App basics common
56 Group:      Development/Libraries
57 Requires(post): /sbin/ldconfig
58 Requires(postun): /sbin/ldconfig
59
60 %description common
61 Application basics common
62
63 %package common-devel
64 Summary:    App basics common (devel)
65 Group:      Development/Libraries
66 Requires:   %{name}-common = %{version}-%{release}
67 Requires:   pkgconfig(sensor)
68 Requires:   pkgconfig(vconf)
69 Requires:   pkgconfig(elementary)
70 Requires:   pkgconfig(aul)
71
72 %description common-devel
73 Application basics common (devel)
74
75 %package template
76 Summary:    App basics template
77 Group:      Development/Libraries
78
79 %description template
80 Application basics template
81
82
83 %prep
84 %setup -q 
85 cp %{SOURCE1001} .
86
87 %build
88 %cmake . \
89 %if %{with wayland} && !%{with x}
90 -Dwith_wayland=TRUE\
91 %endif
92 -DENABLE_GTK=OFF
93
94 make %{?jobs:-j%jobs}
95
96 %install
97 rm -rf %{buildroot}
98 %make_install
99 install -d %{buildroot}%{_unitdir_user}/core-efl.target.wants
100 install -m0644 %{SOURCE101} %{buildroot}%{_unitdir_user}/core-efl.target
101
102 mkdir -p %{buildroot}/usr/share/license
103 cp LICENSE %{buildroot}/usr/share/license/%{name}
104
105
106 %post efl -p /sbin/ldconfig
107
108 %postun efl -p /sbin/ldconfig
109
110 %post common -p /sbin/ldconfig
111
112 %postun common -p /sbin/ldconfig
113
114
115
116
117
118 %files efl
119 %manifest %{name}.manifest
120 %defattr(-,root,root,-)
121 %{_libdir}/libappcore-efl.so.*
122
123 %files efl-devel
124 %manifest %{name}.manifest
125 %defattr(-,root,root,-)
126 %{_includedir}/appcore/appcore-efl.h
127 %{_libdir}/libappcore-efl.so
128 %{_libdir}/pkgconfig/appcore-efl.pc
129
130 %files common
131 %manifest %{name}.manifest
132 %defattr(-,root,root,-)
133 %{_libdir}/libappcore-common.so.*
134 %{_prefix}/lib/systemd/user/core-efl.target
135 %{_prefix}/lib/systemd/user/core-efl.target.wants/
136 /usr/share/license/%{name}
137
138 %files common-devel
139 %manifest %{name}.manifest
140 %defattr(-,root,root,-)
141 %{_libdir}/libappcore-common.so
142 %{_libdir}/pkgconfig/appcore-common.pc
143 %{_includedir}/appcore/appcore-common.h
144 %{_includedir}/SLP_Appcore_PG.h
145