Merge branch tizen_2.2 into tizen
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       app-core
5 Summary:    Application basic
6 Version:    1.2
7 Release:    48
8 Group:      Application Framework
9 License:    Apache-2.0
10 Source0:    app-core-%{version}.tar.gz
11 %if %{with wayland} && !%{with x}
12 Source101:  packaging/core-efl-wayland.target
13 %else
14 Source101:  packaging/core-efl-x.target
15 BuildRequires:  pkgconfig(x11)
16 BuildRequires:  pkgconfig(ecore-x)
17 %endif
18 Source1001:     app-core.manifest
19 BuildRequires:  pkgconfig(sensor)
20 BuildRequires:  pkgconfig(vconf)
21 BuildRequires:  pkgconfig(aul)
22 BuildRequires:  pkgconfig(rua)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(elementary)
25 BuildRequires:  pkgconfig(ecore)
26 BuildRequires:  pkgconfig(gobject-2.0)
27 BuildRequires:  pkgconfig(glib-2.0)
28 BuildRequires:  cmake
29
30
31 %description
32 SLP common application basic
33
34
35
36 %package efl
37 Summary:    App basic EFL
38 Group:      Development/Libraries
39 Requires(post): /sbin/ldconfig
40 Requires(postun): /sbin/ldconfig
41
42 %description efl
43 Application basic EFL
44
45 %package efl-devel
46 Summary:    App basic EFL (devel)
47 Group:      Development/Libraries
48 Requires:   %{name}-efl = %{version}-%{release}
49 Requires:   %{name}-common-devel = %{version}-%{release}
50
51 %description efl-devel
52 Application basic EFL (devel)
53
54 %package common
55 Summary:    App basics common
56 Group:      Development/Libraries
57 Requires(post): /sbin/ldconfig
58 Requires(postun): /sbin/ldconfig
59
60 %description common
61 Application basics common
62
63 %package common-devel
64 Summary:    App basics common (devel)
65 Group:      Development/Libraries
66 Requires:   %{name}-common = %{version}-%{release}
67 Requires:   pkgconfig(sensor)
68 Requires:   pkgconfig(vconf)
69 Requires:   pkgconfig(elementary)
70 Requires:   pkgconfig(aul)
71 %if %{with x}
72 Requires:  pkgconfig(x11)
73 %endif
74
75
76 %description common-devel
77 Application basics common (devel)
78
79 %package template
80 Summary:    App basics template
81 Group:      Development/Libraries
82
83 %description template
84 Application basics template
85
86
87 %prep
88 %setup -q 
89 cp %{SOURCE1001} .
90
91 %build
92 %cmake . \
93 %if %{with wayland} && !%{with x}
94 -Dwith_wayland=TRUE\
95 %endif
96 -DENABLE_GTK=OFF
97
98 make %{?jobs:-j%jobs}
99
100 %install
101 rm -rf %{buildroot}
102 %make_install
103 install -d %{buildroot}%{_unitdir_user}/core-efl.target.wants
104 install -m0644 %{SOURCE101} %{buildroot}%{_unitdir_user}/core-efl.target
105
106 mkdir -p %{buildroot}/usr/share/license
107 cp LICENSE %{buildroot}/usr/share/license/%{name}-efl
108 cp LICENSE %{buildroot}/usr/share/license/%{name}-efl-devel
109 cp LICENSE %{buildroot}/usr/share/license/%{name}-common
110 cp LICENSE %{buildroot}/usr/share/license/%{name}-common-devel
111
112 %post efl -p /sbin/ldconfig
113
114 %postun efl -p /sbin/ldconfig
115
116 %post common -p /sbin/ldconfig
117
118 %postun common -p /sbin/ldconfig
119
120
121
122
123
124 %files efl
125 %manifest %{name}.manifest
126 %defattr(-,root,root,-)
127 %{_libdir}/libappcore-efl.so.*
128 /usr/share/license/%{name}-efl
129
130 %files efl-devel
131 %manifest %{name}.manifest
132 %defattr(-,root,root,-)
133 %{_includedir}/appcore/appcore-efl.h
134 %{_libdir}/libappcore-efl.so
135 %{_libdir}/pkgconfig/appcore-efl.pc
136 /usr/share/license/%{name}-efl-devel
137
138 %files common
139 %manifest %{name}.manifest
140 %defattr(-,root,root,-)
141 %{_libdir}/libappcore-common.so.*
142 %{_prefix}/lib/systemd/user/core-efl.target
143 %{_prefix}/lib/systemd/user/core-efl.target.wants/
144 /usr/share/license/%{name}-common
145
146 %files common-devel
147 %manifest %{name}.manifest
148 %defattr(-,root,root,-)
149 %{_libdir}/libappcore-common.so
150 %{_libdir}/pkgconfig/appcore-common.pc
151 %{_includedir}/appcore/appcore-common.h
152 %{_includedir}/SLP_Appcore_PG.h
153 /usr/share/license/%{name}-common-devel
154