5223a8302d0dba9f4d42fb603fb8d61462c08e76
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 Name:       app-core
2 Summary:    Application basic
3 Version:    1.2
4 Release:    47
5 Group:      Application Framework
6 License:    Apache License, Version 2.0
7 Source0:    app-core-%{version}.tar.gz
8 Source101:  packaging/core-efl.target
9 Source1001:     app-core.manifest
10 BuildRequires:  pkgconfig(sensor)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(aul)
13 BuildRequires:  pkgconfig(rua)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(x11)
16 BuildRequires:  pkgconfig(elementary)
17 BuildRequires:  pkgconfig(ecore)
18 BuildRequires:  pkgconfig(ecore-x)
19 BuildRequires:  pkgconfig(gobject-2.0)
20 BuildRequires:  pkgconfig(glib-2.0)
21 BuildRequires:  cmake
22
23
24 %description
25 SLP common application basic
26
27
28
29 %package efl
30 Summary:    App basic EFL
31 Group:      Development/Libraries
32 Requires(post): /sbin/ldconfig
33 Requires(postun): /sbin/ldconfig
34
35 %description efl
36 Application basic EFL
37
38 %package efl-devel
39 Summary:    App basic EFL (devel)
40 Group:      Development/Libraries
41 Requires:   %{name}-efl = %{version}-%{release}
42 Requires:   %{name}-common-devel = %{version}-%{release}
43
44 %description efl-devel
45 Application basic EFL (devel)
46
47 %package common
48 Summary:    App basics common
49 Group:      Development/Libraries
50 Requires(post): /sbin/ldconfig
51 Requires(postun): /sbin/ldconfig
52
53 %description common
54 Application basics common
55
56 %package common-devel
57 Summary:    App basics common (devel)
58 Group:      Development/Libraries
59 Requires:   %{name}-common = %{version}-%{release}
60 Requires:   pkgconfig(sensor)
61 Requires:   pkgconfig(vconf)
62 Requires:   pkgconfig(elementary)
63 Requires:   pkgconfig(aul)
64
65 %description common-devel
66 Application basics common (devel)
67
68 %package template
69 Summary:    App basics template
70 Group:      Development/Libraries
71
72 %description template
73 Application basics template
74
75
76 %prep
77 %setup -q 
78 cp %{SOURCE1001} .
79
80 %build
81 %cmake . -DENABLE_GTK=OFF
82
83
84 make %{?jobs:-j%jobs}
85
86 %install
87 rm -rf %{buildroot}
88 %make_install
89 install -d %{buildroot}%{_unitdir_user}/core-efl.target.wants
90 install -m0644 %{SOURCE101} %{buildroot}%{_unitdir_user}
91
92
93 %post efl -p /sbin/ldconfig
94
95 %postun efl -p /sbin/ldconfig
96
97 %post common -p /sbin/ldconfig
98
99 %postun common -p /sbin/ldconfig
100
101
102
103
104
105 %files efl
106 %manifest %{name}.manifest
107 %defattr(-,root,root,-)
108 %{_libdir}/libappcore-efl.so.*
109
110 %files efl-devel
111 %manifest %{name}.manifest
112 %defattr(-,root,root,-)
113 %{_includedir}/appcore/appcore-efl.h
114 %{_libdir}/libappcore-efl.so
115 %{_libdir}/pkgconfig/appcore-efl.pc
116
117 %files common
118 %manifest %{name}.manifest
119 %defattr(-,root,root,-)
120 %{_libdir}/libappcore-common.so.*
121 %{_unitdir_user}/core-efl.target
122 %{_unitdir_user}/core-efl.target.wants/
123
124 %files common-devel
125 %manifest %{name}.manifest
126 %defattr(-,root,root,-)
127 %{_libdir}/libappcore-common.so
128 %{_libdir}/pkgconfig/appcore-common.pc
129 %{_includedir}/appcore/appcore-common.h
130 %{_includedir}/SLP_Appcore_PG.h
131